Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

index.php causing header problems across two separate wordpress installations.

Old May 5, 2011, 01:53 PM
NoisyDvL5's Avatar
27 posts · Jun 2010
Hey guys, I've got a strange one for you today.

I have my site http://www.itsalltrue.net that utilizes Wordpress 3.1.2 and Atahualpa 3.6.4 and a sub/add-on domain that has a separate wordpress installation with the same versions of WP & Atahualpa.

Everything has been working fine for weeks until some time between 8-9 this morning the sites started returning error messages. The main site now must have the "WWW" present while the subsite can not have the www (it must match the settings in wordpress) or it returns one of a handful of errors.

Currently, it says:

Warning: Cannot modify header information - headers already sent by (output started at /home/itsallt/public_html/wp-content/plugins/dynamic-headers/custom-header.php:97) in /home/itsallt/public_html/wp-includes/pluggable.php on line 897

But it has also blamed line 97 or 98 of index.php and will blame a different plugin if I deactive the one it's currently referencing.

I am aware that the header error apparently always implies there is an extra space somewhere, but I have NOT edited any php files on the site. I don't know where an extra space could come from.

Anyway, I've been in contact with my host and their final solution is to remove the theme entirely:


Thank you for your patience. Please remove and utilize a new theme as the direct line of error is being caused within the following line of code:

* Front to the WordPress application. This file doesn't do anything, but loads
* wp-blog-header.php which does and tells WordPress to load the theme.
* @package WordPress

* Tells WordPress to load the WordPress theme and output it.
* @var bool
define('WP_USE_THEMES', true);

/** Loads the WordPress Environment and Template */


I love atahualpa and there has to be a workaround for this, but I have no idea what it is.

Last edited by NoisyDvL5; May 5, 2011 at 01:56 PM.
Old May 5, 2011, 02:37 PM
juggledad's Avatar
23,743 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I hate to toss water on the support people, but that code they reference is NOT the theme code, it is part of WordPress.

If you made no, and I mean no changes (not even a new post) then the host may have changed something and I'd get back on their case.

BTW who is the host?
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
Old May 5, 2011, 02:54 PM
NoisyDvL5's Avatar
27 posts · Jun 2010
It's Surpass Hosting.

The last post I made was about 4 hours prior to the problem occuring. There was one comment made on one of the posts during the timeframe between when the site was working and when it wasn't.

See, I was also wondering if there was an issue on their end because the phpbb forum acted up at the same time and that's completely separate from the WP installation.

They just finished repairing the forum, but I had to clear my cookies/cache to gain access and that robbed me of access to the WP-Admin screen as the login page is now behind the error. Sigh.
Old May 5, 2011, 11:40 PM
NoisyDvL5's Avatar
27 posts · Jun 2010
I just wanted to give a quick update here since my server people still aren't quite sure what the issue seems to be.

My phone was fortunately still logged into my wp admin, so I was able to get in there despite them locking me out on my computer.

I deactivated the plugins that were listed in the error. I had to keep disactivating them as the error switched to a new one each time. I ended up turning off the dynamic headers, deactivate google sitemaps, nextgen gallery, page links to, polldaddy, stats, pagenavi, table reloaded, wptouch, and yet another related posts plugins.

The site is functioning now regardless of the "www" being present, but if I turn any of the plugins back on I get this error:

"The plugin generated 2 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin."

Basically, I think this confirms it's not an issue with altahualpa whatsoever. Thanks for the insight though.
Old Jul 23, 2011, 10:08 AM
Mary McAndrew
11 posts · Mar 2009
hi guys, I had the same problem and got so nervous because when I read your lingo here in the forum I can't even understand how to use it! So I got nervous. But just updating all my pluggins, then updated the new version of Atahualpa, then upgraded to latest version of WP (3.2.1) seems to have fixed it. Whew! I get nervous about upgrading because I'm afraid of something not being compatible.

Just thought I'd add my experience in case someone else can try it.


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Header Images and other elements in WP Network installations BanditSiix Header configuration & styling 1 Jan 13, 2011 06:47 PM
Separate folder-installations not equal to separate configurations? Jaguwar Atahualpa 3 Wordpress theme 6 Nov 13, 2010 11:49 AM
Using ATA header php file outside of Wordpress but in same directory jaxon Header configuration & styling 1 Feb 25, 2010 02:21 PM

All times are GMT -6. The time now is 01:53 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.