Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Very slow loading-possible problem with .htaccess?


  #1  
Old Mar 25, 2009, 07:27 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Very slow loading-possible problem with .htaccess?

The ISP guys are working on finding out why my WP/Atahualpa site loads so slowly. Oddly, I have WP and Atahualpa in 2 other folders on the same server, and they load quickly. Neither of those has much in their respective databases compared to the one causing trouble.

I looked at the .htaccess files for all three installations. Could this be where the problem is?

For the slow installation, here is the .htaccess file:
Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wp27/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wp27/index.php [L]
</IfModule>

# END WordPress
For the other two, fast installations, .htaccess is simply:
Code:
# BEGIN WordPress

# END WordPress
Could a plugin or widget slow things down?
  #2  
Old Mar 25, 2009, 10:40 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
The other two have no content in their htaccess files because you're not using Permalinks on those two sites I guess.

The htaccess for the one with permalinks looks fine

htaccess does add load but should not cause a noticeable slowdown. Creating the actual WP page should use much more resources than looking up and following the htaccess rules.
  #3  
Old Mar 25, 2009, 11:08 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
OK. I'm frustrated now because I haven't heard back from the ISP folks about this. I wonder what else could be causing the trouble.

Just now, when in the dashboard area, I noticed that when I click on Dashboard itself, I get "Error in connecting to database." But everything else is working there, just slowly.

*EDIT* Well! I never did hear back from the ISP support guys, but I think I fixed it myself. I deactivated and deleted several plugins, including WP-Polls and Poll Daddy, and Next Gen gallery. I'm not sure which one was the problem, but now I'm getting normally fast loading time. Would somebody please test it yourself and let me know how it seems to you?

http://larchmontgazette.com/wp27/ This is the front page, with one 87kb image and several 8k images.

I am still getting the database error message when clicking on Dashboard from within Dashboard.

Last edited by paulae; Mar 25, 2009 at 01:31 PM.
  #4  
Old Mar 25, 2009, 04:39 PM
bpbaker
 
23 posts · Dec 2008
Whitstable, Kent, England.
From the UK I am getting page load times on your site of between 3 and 6 seconds (YSlow). This seems to be an acceptable speed.

Your database connection problems remind me of a similar issue I once had when running a couple of Joomla sites in different sub directories. One was fine, the other was very slow and kept coming up with database connection issues. When I accessed the SQL database of the slow one directly through PHP Admin it would take around a minute to load. It transpired that the server that held this database was suffering from heavy loads from other databases housed on it that were nothing to do with me but were reducing its overall efficiency.

In your case it might be as simple as conducting some housekeeping on the database that serves your site.
  #5  
Old Mar 26, 2009, 07:26 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I'll ask the ISP guys about that.

We have 8 databases enabled and are using only 4 of them. They are all, as far as I know, on the same server.

By the way, what did think of Joomla?
  #6  
Old Mar 26, 2009, 07:58 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Quote:
Originally Posted by paulae
...<snip>...

http://larchmontgazette.com/wp27/ This is the front page, with one 87kb image and several 8k images.

...<snip>...
g'Morning Paula! The front page just now loaded quickly enough that it didn't even occur to me to time it.

Question: Might occasional load delay be related to the "serving" of the various ads you have positioned on your pages. I can see there's some kind of a script running that's loading a selection of ad graphics -- where are they coming from?

I was a bit surprised to hear that the "waterfall" was 86+ KB. I re-processed it through PhotoShop, saved it at a "jpg quality rating" of 50% using PS's "Save for Web and Devices" option and came up with a very acceptable (saying so myself! ) downsized 24 KB version of the pic. I didn't even feel that the result needed any re-sharpening. "Mine" is the first pic, the original on your Front Page is the lower.





I was a photographer in a previous life so count "fooling around with PhotoShop" as one of my many hobbies.

BTW -- The Larchmont Gazette Atahualpa site is looking AWESOME ....TOTALLY!!
  #7  
Old Mar 26, 2009, 08:26 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Your version certainly looks fine. I did use PS's Save for Web option but did it at 100%. I guess I could be thriftier with file sizes, right? Thanks for the heads-up on that one! And thanks for the kudos about the way the site is looking. I struggle with making graphics for the site, since I'm not a graphic designer by experience or training. I took the header photo a couple of days ago down by Long Island Sound, and applied the blue color, tried to feather it for softening, and slapped on the text. I'm not fully happy with it, but it's something to put there for now. Of course, by the time we go live with the redesign, we'll need a more spring-like photo! Changing with the seasons isn't a bad idea anyway.

We use a Perl script called csBanner to serve our ads. I have dummy ads in there at the moment while we settle on where and what will go up.

I'm a budding photographer, one of those obnoxious types who buys fancy equipment before being worthy of it! I have a Nikon D300 and I'm mystified by most of what it can do. In April, I'm going to a workshop in D.C. put on by the National Geographic, so I should learn a lot there. In the meantime, I'm busily shooting flora, fauna and hapless passersby in my town.

I love your use of photography on your site, by the way. Do you have an online gallery of your stuff?

Last edited by paulae; Mar 26, 2009 at 08:51 AM.
  #8  
Old Mar 26, 2009, 01:34 PM
js9600
 
29 posts · Dec 2008
You have 6x queries - is that not a lot?

There have been posts about tricks to speed up WP like in this one http://forum.bytesforall.com/showthr...ghlight=speedy but Ive not seen Widget cache mentioned http://wordpress.org/extend/plugins/wp-widget-cache/ if serving files works well enough limiting database load might be all you need. Ive tried it and was impressed Compare before/after and see for yourself. Check plugin site for comments, issues - worked out of the box for me but of course be careful if you go crazy and combine with other caching. Screenshots on WP site should explain how little it take to set up. "No cache" could be for special widgets which has own caching or just dont work well with this, ajax? From what I know it is safe to try out so keep eye on footer...

I know it does not work with Widget logic, a plugin which lets you decide which widgets to show on each page.

Tried Gzip? You dont use it right now. Sounds good but also show why each have to test on their site/host. If I enable gzip on host site slows down big time, they are cheap with cpu power I think. Bandwidth is of course divided by 4 or 5, Gzip works great but overall result is still not useful. Test and test

Last edited by js9600; Mar 26, 2009 at 01:50 PM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Very slow loading woomik Atahualpa 3 Wordpress theme 2 Jun 4, 2009 06:15 PM
WP dashboard and site loading impossibly slow... johnd Installing & running WordPress 0 May 24, 2009 05:40 PM
Where is my .htaccess file? andyhugh Page & Category Menu Bars 1 May 7, 2009 12:32 AM
slow loading? PJK Atahualpa 3 Wordpress theme 2 Apr 26, 2009 08:40 PM
.htaccess for permalinks HenryGomez Atahualpa 3 Wordpress theme 4 Feb 5, 2009 05:09 PM


All times are GMT -6. The time now is 01:27 AM.


Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.