Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Post-Kicker, -Byline & -Footer »

%author-linked% and All-in-one-SEO


  #1  
Old Feb 6, 2009, 02:41 AM
artiflo
 
4 posts · Feb 2009
Hi,

I use All-in-one-SEO and Atahualpa 3 %author-linked% but when I try to click on %author-linked% I have a page not found error.

For exemple : http://www.myblog.net/author/Firstname lastname/

How I can fix that ?

thanks

Last edited by artiflo; Feb 6, 2009 at 02:48 AM.
  #2  
Old Feb 6, 2009, 04:57 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Post or PM a URL please. There's probably a space somewhere in an URL or something like that
  #3  
Old Feb 6, 2009, 05:24 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
There's a bug with full author names I think. Could you please find in functions/postinfo.php, line 50

PHP Code:
$author_linked '<a href="' $author_url '">' $author_name '</a>'
and replace with

PHP Code:
$author_linked '<a href="' get_the_author_url(). '">' $author_name '</a>'
and see if that works (and let me know)?
  #4  
Old Feb 6, 2009, 05:31 AM
artiflo
 
4 posts · Feb 2009
I change but the new link is http://www.myblog.net/ instead of http://www.myblog.net/author/lastName firstname/
  #5  
Old Feb 6, 2009, 05:47 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
This one should work? postinfo.php line 48, replace

PHP Code:
$author_url get_author_posts_url($post_author_id$author_name); 
with
PHP Code:
$author_url get_author_posts_url($post_author_id); 
and leave / change back line 50 to how it was before:

PHP Code:
$author_linked '<a href="' $author_url '">' $author_name '</a>'
On the resulting page there might be something like "Archive for '' Category"... looking into that now
  #6  
Old Feb 6, 2009, 05:50 AM
artiflo
 
4 posts · Feb 2009
yes that works.

now when I click in %author-linked% I have http://www.myblog.net/author/nickname.

Can I have First name et lastname instead of nickname ?

Thanks a lot.
  #7  
Old Feb 6, 2009, 06:00 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Then you'd have to change the author's login name to something that is in line with the nicename but without spaces. Like John.Doe, John-Doe, JohnDoe or John_Doe then. The nicename would be "John Doe", the login name would be "John-Doe" or whatever you want to have appear in the URL. See Site Admin -> Users.

What you cannot have is a link to /.../John Doe/ (with a space). The permalink is pointing to the login name because that is going to be something without spaces or weird characters.

And re: "Archive for '' Category" - that's only happening with the Page2Cat plugin it seems so you're not affected. Fixing that too now
  #8  
Old Dec 16, 2009, 04:49 AM
Robinwoods
 
1 posts · Dec 2009
Yes, I experienced that problem as many times. The author name in Url the link is not correct? How to I rectify these problem?
  #9  
Old Dec 22, 2009, 03:56 AM
juggledad's Avatar
juggledad
 
23,545 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Robinwoods, please be more specific about what YOUR issue is- details - examples - url showing issue - what verswions of things are you using.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old Jan 24, 2010, 07:55 PM
pinah
 
5 posts · May 2009
Indonesia
Send a message via Yahoo to pinah
any idea why does my author page address look like this?

http://duniaastronomi.com/author/hanieftrihantoro-2/

there is only one user use hanieftrihantoro as usernam in my site. i've changed the "nickname" and the "display name publicly as" name, the display name is changed but it still go to the same address.

i use atahualpa ver 3.2 and wp 2.9.1
  #11  
Old Jan 25, 2010, 05:19 AM
juggledad's Avatar
juggledad
 
23,545 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What is your permalink (dashboard->settings->permalinks) set to?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #12  
Old Feb 1, 2010, 07:32 PM
pinah
 
5 posts · May 2009
Indonesia
Send a message via Yahoo to pinah
i am sorry for a late reply because i have disable it after the first try.

my permalink is
http://duniaastronomi.com/2010/02/sample-post/

-now i have another problem since upgrading to 2.9.1: my posts doesn't show comments and comment form, doh-

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
category pages - with just the linked title, author, date of each related post janey73 Atahualpa 3 Wordpress theme 2 Jun 25, 2009 01:11 PM
how to make header image linked to a post URL? dreamfree Header configuration & styling 3 Jun 13, 2009 02:54 AM
3.2 to 3.3.2 Update: %author-linked% in ByLine does not longer work Mariosagt Post-Kicker, -Byline & -Footer 3 Apr 14, 2009 08:25 PM
author-linked c32v Post-Kicker, -Byline & -Footer 1 Feb 26, 2009 06:43 PM
Posted by %author-linked% on %date('j F Y')% bseppa Post-Kicker, -Byline & -Footer 0 Dec 13, 2008 12:38 PM


All times are GMT -6. The time now is 07:46 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.