Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Atahualpa IE7 "endif" Error header.php


  #1  
Old Apr 21, 2009, 12:42 PM
Actus
 
2 posts · Apr 2009
Hello,
I am a new user of Atahualpa and this is my very first blog so my technical knowledge is very limited. I am using Atahualpa 3.3.2.

I am getting multiple (but "same") errors at the top of my blog that says "endif":

<!--[endif]--> <!--[endif]-->

<!--[endif]--> <!--[endif]-->

Does anybody know how to fix this? The error can be seen when using Internet Explorer7. The error does NOT exist when using FireFox.

I know the error is within the "header.php". But I don't know what piece of code to use and where to place the corrected code within Atahualpa header.php. Thank you for your help.
  #2  
Old Apr 21, 2009, 08:13 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Did you paste something from MS Word into your site? That's usually the cause for this. Paste again but this time into a text editor first and into WP from there so the MS formatting gets dropped.
  #3  
Old Apr 22, 2009, 03:40 PM
Actus
 
2 posts · Apr 2009
Yes, I did paste my blog contents from MS Word. I write my contents in MS Word then copy and paste to WP form.

I followed your instructions and it worked. The "endif" error disappeared in IE7. Thank you very much for your help.
  #4  
Old Sep 23, 2009, 09:42 PM
juandrah
 
24 posts · Jul 2009
Thank you. I just experienced this problem and this was the answer for me as well.

However, my first attempt at fixing the problem by saving my content as text and then replacing the page content in admin failed. Hmmmm.....

So, I cut the content from the page and published the blank page. This attempt failed again. The <!--[endif]--> was STILL there in IE!

Then I'm thinking, okaaaay...., I'm seeing it in IE but not in Firefox, let's bring up WP admin in IE. When I looked at the pages, the code was there! So, for the third time, I cut and pasted the entire text version of the content. This got rid of the <!--[endif]--> but the text formatting was all messed up in IE. It was still fine in Firefox.

So, I checked another page in IE WP admin and, for the fourth attempt, simply deleted the <!--[endif]--> without replacing the content and republished. SUCCESS!!!!! The <!--[endif]--> code was gone and the text formatting retained integrity in both browsers.

Why? Because I tried to do the editing in Firefox and the problem only existed in IE. When you look at the page content in Firefox WP admin the <!--[endif]--> is not there so it can't be edited out. When you view the page content in IE WP admin the <!--[endif]--> is there, so it can be edited out. You DO NOT have to repaste the entire content.

So, to resolve this problem you MUST view and edit the page content in WP admin using IE. To edit, simply select and cut <!--[endif]--> from the page and republish. The visual appearance of both pages will retain integrity.

However, it's a good idea to check your pages anyway for any stray code which affects the formatting. I have found occasional stray snippets which over ride the Atahualpa settings.

You can mark thread as resolved now?

Good luck and happy authoring.

Bookmarks

Tags
atahualpa header.php, ie7 endif error

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
make index.php be a "page" and blog postings go to different php page zhidoni Atahualpa 3 Wordpress theme 0 Jun 21, 2009 05:25 PM
request: please add "links.php" page template. dhani Atahualpa 3 Wordpress theme 0 May 22, 2009 04:36 AM
I have uploaded atahualpa to my server but am getting "fatal error". Dianne Atahualpa 3 Wordpress theme 5 Apr 11, 2009 04:06 PM
How to use <?php... ?> code in "Post Info Items" sections? TotalBalance Post-Kicker, -Byline & -Footer 0 Mar 14, 2009 04:01 PM
"Fatal error: .../atahualpa/header.php on line 848" ??? Dem Header configuration & styling 5 Feb 19, 2009 07:06 AM


All times are GMT -6. The time now is 08:17 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.