Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] How To Create A Tag Cloud Page


  #1  
Old Jun 11, 2009, 06:10 PM
fromtheranks
 
149 posts · Apr 2009
Dev Env't: XP Pro SP3, IIS 5.1, MySQL 5.1, PHP 5.2.x, WP 2.7.1, Atahualpa 3.3.3, IE 7, FF 3.0.x
I've been wanting to create a Tag Cloud Page for a while -- I have other uses for my side-bars -- without resorting to plugins. This was on my To-Do list for today so, with the help of a number of answers given to others by Flynn, via replies in various locations, and with some research in the WordPress Codex, I have come up with an approach for creating such a page. This is somewhat detailed so bear with me (though it is actually fairly straightforward):

Step 1:
Copy index.php (in ..\themes\atahualpa333) and paste it back into this folder, then rename it to the tag cloud name of your choice. I called mine (cleverly enough) tagcloud.php.

Step 2:
At the very top of your tagcloud.php file, before anything else, add this code (use your tag cloud page title, if it is different):

Code:
<!-- included 6/11/09 by DPH to create new template name -->
<?php
/*
Template Name: Tag Cloud
*/
?>
Note: I left the comment line in there as a demo of the style that I found works best for me, I don't have to be quite so careful where and how I put it (as I discovered yesterday to my chagrin when using Flynn's style).

Step 3:
For default tag cloud settings add the following code, what is in red only, exactly here on a line after the "endwhile; ?>":

Code:
<?php // END of the LOOP
endwhile; ?>
	
<!-- modified by DPH 6/11/09 to add wp_tag_cloud template tag; doesn't seem to need to be "in the loop" -->
<?php wp_tag_cloud(); ?>

Step 4:
So that the Byline doesn't show up on the Tag Cloud page, in your tagcloud.php either delete the following line or remark it out (I prefer remarking out personally):

Code:
<?php bfa_post_byline(); // Post Byline: To edit the output, see functions/bfa_post_parts.php ?>
Note: changing code in this file does not affect index.php or any of the rest of the theme.

Step 5:
Go to the WP Admin Dashboad, go to "Pages" and create a new page entitled "Tag Cloud" or whatever works for you -- the title is not critical. I simply called mine: "Tag Cloud".

If you wish to have some explanatory text under the Page title, add it. The tag cloud will display below your text.

If you don't wish to publish the page yet, change the Status to Pending Review so you can save the page because you need to get to "Quick Edit".

In Quick Edit find and go to the Template field. The dropdown list will (if you haven't typo'd in your php file) show your new template. Select this. Disable Allow Comments and Allow Pings while you're at it (unless you wish comments or pings). Then do an Update Page.

Step 6:
Go to your site and, if all is well, you will see the "Tag Cloud" tab on the Page Menu Bar. When you click on this you will see the Page Title and your tag cloud below it.

Step 7:
If you wish to "tweak" the style of your tag cloud see Flynn's reply at: http://forum.bytesforall.com/showthr...t=wp_tag_cloud.

A sample I played with, to learn how the parameters work, is:

Code:
<?php wp_tag_cloud('smallest=10&largest=20&format=list'); ?>
I hope this helps.

P.S. Major kudos to Flynn for creating such a flexible theme!

Last edited by fromtheranks; Jun 23, 2009 at 04:13 PM. Reason: To delete reference to image which didn't attach.
  #2  
Old Jun 18, 2009, 03:19 PM
fromtheranks
 
149 posts · Apr 2009
Dev Env't: XP Pro SP3, IIS 5.1, MySQL 5.1, PHP 5.2.x, WP 2.7.1, Atahualpa 3.3.3, IE 7, FF 3.0.x
Hi.

I just ran into a tiny glitch on my tagcloud.php page (as described below).

It works great ... except that it doesn't hold the "background color: hover" color on the page menu bar tab once the page is selected ... as the other tabs do.

Is there a way to fix this? With a CSS insert or something like that?

Thanks in advance.
  #3  
Old Jun 23, 2009, 04:26 PM
fromtheranks
 
149 posts · Apr 2009
Dev Env't: XP Pro SP3, IIS 5.1, MySQL 5.1, PHP 5.2.x, WP 2.7.1, Atahualpa 3.3.3, IE 7, FF 3.0.x
Never mind. I must not have cleared the cache during my original testing, because I just went back to work on my Tag Cloud page and hover works perfectly after the page is selected.

P.S. Firefox's Firebug tool is a great tool for debugging ... even non-existent issues.

Bookmarks

Tags
tag cloud, tag cloud page, wp_tag_cloud

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change styling for the Tag Cloud StudioGal Atahualpa 3 Wordpress theme 9 May 28, 2010 07:08 AM
[SOLVED] Probs w/tag line ariels Header configuration & styling 8 Jul 13, 2009 07:41 PM
[SOLVED] Create a poll plug in error message ldsmedia Plugins & Atahualpa 3 Jul 10, 2009 03:41 PM
[SOLVED] Adding wp_footer before body tag Chester Post-Kicker, -Byline & -Footer 6 Jun 7, 2009 11:24 AM
[SOLVED] Conditional Tag to exclude widget d_random Sidebars & Widgets 8 Jun 2, 2009 08:23 AM


All times are GMT -6. The time now is 05:41 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.