Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

Password protected Page


  #1  
Old Aug 11, 2009, 04:36 PM
aebrigham
 
35 posts · Aug 2009
I might be off my rocker, but is it standard for Atahualpa to have "This post is password protected. Enter the password to view comments." at the bottom of pages that are password protected that have comments and pingbacks turned off.

I could have sworn that it was only. "This post is password protected. To view it please enter your password below:" at the top?

Any help would be appreciated.
  #2  
Old Aug 11, 2009, 04:48 PM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
That's a Wordpress item. Switch to the default theme and you will see the same message
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Oct 5, 2009 at 08:15 AM.
  #3  
Old Aug 11, 2009, 05:07 PM
aebrigham
 
35 posts · Aug 2009
Actually Juggledad, if you switch to the default wordpress theme and view a Page that has Comments and Pingbacks turned off, it does not display

"This post is password protected. Enter the password to view comments."

below the Submit button to enter your password.
  #4  
Old Aug 11, 2009, 05:33 PM
aebrigham
 
35 posts · Aug 2009
To anyone that cares. This is how I fixed it. Under "Style Configure Comments" I removed

Allow comments on "Page" pages, too? to equal No

I do find this weird though because if I have turned off Comments and Pingbacks in the actual Page. You think it would override this setting. Regardless, I have the result I want.
  #5  
Old Aug 11, 2009, 05:44 PM
aebrigham
 
35 posts · Aug 2009
Actually I would be interested to know if you can turn off "Allow comments on "Page" pages, too? to equal No" for only certain pages?
  #6  
Old Aug 11, 2009, 06:42 PM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
hmmm this is interesting. I just shut off comments and pingbacks and swapped back to the default theme and I still get 'This post is password protected. To view it please enter your password below:'
This is on WP 2.8.2 - what version are you running?

I just noticed you mention pages and posts in your initial message. I was looking at the blog page Are you looking at a page or a post?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Aug 11, 2009 at 06:44 PM.
  #7  
Old Aug 11, 2009, 11:16 PM
aebrigham
 
35 posts · Aug 2009
I think the same message is used for both pages and posts. I am referring to pages in all references. I quoted the message which has posts in it.

What I would really like to see is. For pages that I want to password protect and have Comments and Ping backs turned off, even if I specify (Allow comments on "Page" pages, too? to equal Yes) in the Atahualpa settings, that no bottom message in display indicating comments are password protected.

I know its a little hard to follow but all I want to see is "This post is password protected. To view it please enter your password below:" I don't want to see any message about comments, even though I have comments turned off in the page, but turned on in Atahualpa...

The reason I need it turned on in Atahualpa is because I have a Guestbook page that is my only Page that allows comments.

It would be nice to see an option in Atahualpa indicate the settings for specific pages instead of a global setting.

eeee, I totally am rambling
  #8  
Old Aug 12, 2009, 10:59 AM
aebrigham
 
35 posts · Aug 2009
Really what I did to resolve this, which I am not totally happy with is put code in the comments.php and legacy.comments.php file

if (!is_page(#) ) {

text I didn't want displayed

}

My problem is, its not dynamic, and when I upgrade to a newer release of your theme, this code will be overridden...

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to customize Login, Registration and Lost Password with wp-customized-lo fromtheranks Plugins & Atahualpa 15 Apr 24, 2012 04:24 PM
Formatting of Sumbit Button on Password Protected Page aebrigham Header configuration & styling 7 Sep 14, 2009 10:42 AM
Making a 'child page' password protected when it holds a forum Steven Atahualpa 3 Wordpress theme 2 Mar 31, 2009 07:11 PM


All times are GMT -6. The time now is 02:28 AM.


Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.