Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Atahualpa 3.3.3. BFA Subscribe Widget not Working Correctly in WP 2.8

Old Jul 1, 2009, 09:26 AM
3 posts · Jul 2009
Hi Flynn -

Thanks for the great theme! I am going to donate shortly.

I am having trouble with the BFA Subscribe Widget. It is not letting me enter any text for the buttons. I was able to enter a title, text in the email subscription box, and text for the email subscription button. Also got feedburner working ok for the email subscription.

BUT, when I place the cursor in the boxes to add text next to the Email, RSS, and Comments buttons, it doesn't allow me to type anything. I've tried dragging the plugin out to deactivate (and supposedly delete settings) several times. When I drag it back in, it is still remembering my previous entries, which I can edit, but it will not let me do anything with those text fields for the buttons.

I'm not sure if this is a Wordpress bug, or a compatibility issue?

Old Jul 1, 2009, 06:04 PM
Flynn's Avatar
3,768 posts · Oct 2008
Munich, Germany
What is your WP and Atahualpa version? It worked for me in WP 2.7 and Atahualpa 3.3.3
Old Jul 1, 2009, 09:13 PM
3 posts · Jul 2009
Flynn -

Sorry about that - I put the versions in the subject line, but not in the body of the post. WP 2.8 and Atahualpa 3.3.3 The input boxes that aren't working don't even show a blinking cursor. The cursor blinks once when I click in the box, then disappears. I can't enter any text at all. It seems really odd, because a couple of the boxes are working fine, and the rest are not. I think that the first time I tried to use the widget, they all worked, but then something went weird after the first save, and I started having this problem when I tried to change things around.

Also, when I remove the widget from the sidebar to the available widgets area, logout of WP admin, then log back in and try to reactivate the widget by bringing it back to the sidebar, the text I entered on last save is still there. Weird, because if I understand it correctly, it should be deleting settings and entries from the widget when I drag back to the "available widgets" area. Hopefully this is a bug in widget handling in WP 2.8, rather than something corrupted in my files. I'm a newbie to all this!

Old Jul 6, 2009, 07:25 AM
juggledad's Avatar
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
seems to me that this is going to be a plugin by plugin issue. Most plugin's/widgets store info in the wp_options table. Unless the widget has code to delete these options when the widget is removed, those entries will still be there.

It's a real puzzle, since you can deactivate a widget by deleting the files from the plugin directory. In this case Wordpress doesn't know what the entries in the wp-options table were so how can it deletee them. And you don't want them removed when you remove a widget from a sidebar - maybe you are just moving it from one sidebar to another or you switch to a theme that only has one sidebar, decide you don't like it and switch back.

Even Atahualpa leaves things in wp-options, this allows you to swap themes and come back without loosing your settings.
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jul 6, 2009 at 02:55 PM.
Old Jul 14, 2009, 04:05 AM
1 posts · Jul 2009
UK Southampton
Got a little lost in the technical issues....

I seem to have the same problem and can't use the BFA Subscribe. I just upgraded to latest wordpress and latest theme 3.4.2 and still have the same problems. I can't add anything into any of the other boxes

I just found this theme - what a product - I have only just touched the surface but really does look great
Old Jul 15, 2009, 03:55 PM
Flynn's Avatar
3,768 posts · Oct 2008
Munich, Germany
WP DID make a rather huge change to widgets and plugins in 2.8, I'll have to check the widgets in 2.8, put on To Do list
Old Jul 24, 2009, 11:17 PM
3 posts · Jul 2009
Flynn - saw this one on your to do list for 3.4.3 Thanks so much for checking it out. I'm still waiting with 3.3.3 and will upgrade once 3.4.3 comes out. Looking forward to some of the newer features (like a way to turn off body titles for pages) that I hear you've added. Thanks again for all of your hard work on this theme!
Old Sep 23, 2009, 08:05 PM
Flynn's Avatar
3,768 posts · Oct 2008
Munich, Germany
This wasn't related to WP 2.8 but my fault. Fixed in 3.4.3 and for now you can type if you keep holding down the mouse button after you clicked into one of the text areas


bfa subscribe, rss display sidebar, widget problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
CSS used in 3.2.2 not working correctly in 3.4.2 on intial page load bcorrigan New Versions, & Updating 2 Jul 14, 2009 08:59 AM
[SOLVED] how to Change BFA Subscribe widget design ppat2 Sidebars & Widgets 3 Apr 28, 2009 09:29 PM
Widget text not aligning correctly in sidebar StudioGal Sidebars & Widgets 2 Apr 14, 2009 08:08 AM
BFA Subscribe widget like RSS in header? Puretext RSS, Feeds & Subscribing 1 Mar 6, 2009 03:00 PM
BFA Subscribe using Feedburner - Email subscriptions mactony RSS, Feeds & Subscribing 2 Jan 30, 2009 02:26 PM

All times are GMT -6. The time now is 01:42 PM.

Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.