Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Comments, trackbacks & pings »

How do I add comments to pages?


  #1  
Old Mar 1, 2009, 07:24 AM
Bjones
 
2 posts · Mar 2009
How do I add comments to pages?

Hey Flynn,

I love this theme. The only problem that I am currently having is that I cannot figure out how to add comments on seperate pages, they are only showing up on the main page. Im not sure if Im missing something here. Please keep in mind that Im new to wordpress and dont know how to write code, etc.

Thanks for your help...
  #2  
Old Mar 1, 2009, 11:12 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
To add comments (the actual comments, if you got any, and the comment form, where readers can submit a comment) to a page, see Atahualpa Theme Options -> Comments -> Allow comments on "Page" pages, too?

To add comment links (links from multi post pages to the comments & comment form on the single post page or "Page" page) below or above posts or "Page" pages, see Atahualpa Theme Options -> Post/Page Info Items.

Example: To add a "Leave a comment" link below all posts on multi post pages, add
PHP Code:
%comments('Leave a comment''One comment''% comments''Comments are closed')% 
into the last textarea at the bottom of Atahualpa Theme Options -> Post/Page Info Items, named FOOTER: Multi Post Pages

Last edited by Flynn; Mar 2, 2009 at 03:02 PM. Reason: "Leave a comment" link below a "Page" page would probably not work. Changed comment link example to "Multi Post Pages"
  #3  
Old Mar 1, 2009, 09:56 PM
Bjones
 
2 posts · Mar 2009
Thanks Flynn, guess I was missing something...
  #4  
Old Apr 28, 2009, 03:06 AM
pedja
 
6 posts · Apr 2009
I have enabled comments on pages but it seems theme now allows comments on all pages, not just ones I allowed them to.

Each page has flag that sets if comments are allowed on page or not. I have most of pages with disabled comments and some with comments enabled. After I allowed comments in theme options, each page allows comments.

Theme should follow page specific settings.
  #5  
Old Aug 5, 2009, 09:25 PM
Wimbledon's Avatar
Wimbledon
 
320 posts · Apr 2009
[VA & AZ], USA
Quote:
Originally Posted by pedja
I have enabled comments on pages but it seems theme now allows comments on all pages, not just ones I allowed them to.

Each page has flag that sets if comments are allowed on page or not. I have most of pages with disabled comments and some with comments enabled. After I allowed comments in theme options, each page allows comments.

Theme should follow page specific settings.
I am having the same problem as pedja.

Any update to this, Flynn or juggledad? This is crucial to my new site so I would appreciate any help to make this work.

I have comments enabled on pages under ATO Comments, but I don't want comments on all pages. The "Allow comments on page?" box under page settings does not work. Right now I have comment boxes on all pages.

I'm running 3.4.2.

How can I fix this to allow comments only on the pages I specify?
  #6  
Old May 5, 2009, 06:09 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Yes it should, I am looking into it...
  #7  
Old May 13, 2009, 12:01 PM
nikkidev
 
5 posts · Mar 2009
Quote:
Originally Posted by Flynn
To add comments (the actual comments, if you got any, and the comment form, where readers can submit a comment) to a page, see Atahualpa Theme Options -> Comments -> Allow comments on "Page" pages, too?
Since using version 3.3.3 and enabling allow comments on Page pages too, the comment box still doesn't turn up on pages and subpages even if allow comments is checked.

Sorry, this seems to be my fault. I'd edited the comments.php file so that the comment form appeared above the list of comments but can't have done it correctly. If it's not inappropriate to ask on this post, exactly which bit do I need to move to make this work.

Last edited by nikkidev; May 13, 2009 at 02:11 PM. Reason: Further investigation reveals "bug" is my error
  #8  
Old May 13, 2009, 02:52 PM
bcorrigan
 
85 posts · Feb 2009
Flynn, it is this issue that had me turn off comments on all posts and pages. I would like to have them on for some and off for others, but it doesn't work. As a result, I turned off comments and edited the comments.php file to make sure "comments are closed" did not appear per instruction in this thread:

http://forum.bytesforall.com/showthr...=4092#post4092

So I hope you find out what the issue is.

thanks

Bill
  #9  
Old May 13, 2009, 05:46 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I'll have this fixed in 3.3.4
  #10  
Old May 14, 2009, 01:33 PM
bcorrigan
 
85 posts · Feb 2009
that will be great, and then I will be down to having only one file edit/addition in your theme, making it very manageable and easily updateable.

Using this theme has kept me away from Drupal, as it make skinning so easy.

thanks again for a great theme.
  #11  
Old Jul 17, 2009, 03:32 PM
rpulse
 
3 posts · Jul 2009
But how do I add a reply to the comment?
  #12  
Old Jul 23, 2009, 04:35 AM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
make sure you have nested comments set - dashboard->settings->discussions-> Enable threaded (nested) comments ___ levels deep set to more than 1. Then the word 'Reply' should show up after the date for each comment that has been made
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #13  
Old Jul 23, 2009, 05:33 AM
dee
 
14 posts · Jul 2009
Maryland
Will this code help my comments from showing that comments are closed. I see the form on some post but not all of my post. I have everything checked off like you suggested but some of the post are showing comments closed when the title is clicked and taken to single post page.

Example: see Vogue: The September Issue post, third post on my website.
  #14  
Old Jul 23, 2009, 05:47 AM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
dee, what is your url?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #15  
Old Jul 17, 2009, 01:03 PM
rpulse
 
3 posts · Jul 2009
Hi,

I added your suggested code for comments but my my readers are telling me they can only add one comment. I need unlimited number

I also cannot reply, not sure if I have the correct code in your admin.

I would like to allow comments, allow replys.

Can you give me the code that will allow comments and always remain open for more?

Thanks Liz

Last edited by rpulse; Jul 17, 2009 at 01:07 PM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Show actual comments in multi-post pages arbatax Comments, trackbacks & pings 5 May 4, 2013 08:54 AM
Add New Item to RSS / Email / Comments in header kesterbrewin RSS, Feeds & Subscribing 2 May 6, 2009 09:14 AM
How to add 'Home' to 'Pages' Widget DavePorter Sidebars & Widgets 3 Mar 20, 2009 05:40 PM
Comments on pages Steve_T Comments, trackbacks & pings 2 Mar 1, 2009 05:42 AM
Add something over/before the posts on tag/cat pages chris Atahualpa 3 Wordpress theme 1 Feb 23, 2009 03:13 PM


All times are GMT -6. The time now is 01:10 PM.


Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.