Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

CSS used in 3.2.2 not working correctly in 3.4.2 on intial page load

Old Jul 13, 2009, 11:38 AM
85 posts · Feb 2009
CSS used in 3.2.2 not working correctly in 3.4.2 on intial page load

Hi there,

on my site:

I have some CSS/HTML accessibility code for screen readers. This code has a link that is rendered first
(located in ATO -> HTML Inserts: Body Top)
HTML Code:
<div class="skip"><a  href="#content">Skip to Main Content</a></div>
and some CSS to hide it off-screen (located in ATO -> CSS Inserts)
HTML Code:
/* decorate the Skip to Main Content Link */
.skip  a {
padding: 0 0.5em; display: inline; z-index: 2;
text-decoration: none; position: absolute; width: 14 em; left: -200em; 
The link jumps to a NAME tag (located in 3.4.2 in ATO -> The LOOP, above post_bodycopy)
HTML Code:
<a name="content">&nbsp;</a>

<?php bfa_post_bodycopy('<div class="post-bodycopy clearfix">','</div>'); ?>
Everything works except that on the link is centered on the top of the page, and not off the screen per the CSS.

Worked fine in 3.2.2.

What do I need to change?

Old Jul 13, 2009, 07:18 PM
Flynn's Avatar
3,768 posts · Oct 2008
Munich, Germany
A bug, the compression deletes the 2 spaces between .skip and a completely, making it .skipa

Changing that for 3.4.3, thanks.

You can fix it for now by removing one of the two spaces.

Or edit css.php and replace

PHP Code:
/* remove tabs, spaces, newlines, etc. */
$buffer str_replace(array("\r\n""\r""\n""\t"'  ''   ''    '), ''$buffer); 

PHP Code:
/* remove tabs, spaces, newlines, etc. */
$buffer str_replace(array("\r\n""\r""\n""\t"), ''$buffer);
$buffer str_replace(array('  ''   ''    ''     '), ' '$buffer); 

Also, you have a space between 14 and em, even though that's not causing the issue:
width: 14 em should be width: 14em

Last edited by Flynn; Jul 13, 2009 at 07:21 PM.
Old Jul 14, 2009, 08:59 AM
85 posts · Feb 2009
Thanks, Flynn, removing the spaces in my HTML fixed the problem. I guess I got a bit sloppy in my coding and didn't run it through tidyHTML, which I normally do to eliminate those 'gotcha's.

Works great now.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Atahualpa SLOW to load! rackphoto Atahualpa 3 Wordpress theme 6 Feb 27, 2012 03:12 AM
[SOLVED] Permalink or 404 error - page not displaying correctly woolef Atahualpa 3 Wordpress theme 19 Apr 4, 2010 02:08 PM
[SOLVED] Atahualpa 3.3.3. BFA Subscribe Widget not Working Correctly in WP 2.8 Matt Atahualpa 3 Wordpress theme 7 Sep 23, 2009 08:05 PM
[SOLVED] Atahualpa load time! wrastler Atahualpa 3 Wordpress theme 21 Jun 9, 2009 08:11 AM
[SOLVED] Safari not displaying page menu bar and post footer correctly chinnerz Atahualpa 3 Wordpress theme 4 May 31, 2009 09:52 PM

All times are GMT -6. The time now is 10:24 AM.

Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.