Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Page Corruption: Visual Editor and Page Revisions vanish when clicking Update!


  #1  
Old Feb 6, 2010, 03:24 PM
asellon
 
23 posts · Feb 2010
Unhappy Page Corruption: Visual Editor and Page Revisions vanish when clicking Update!

I am trying to migrate my current web site content into the Atahualpa Theme 3.4.5 in WP 2.9.1. I have tried copying the content both from the site front-end, and also from the source code. In both cases, I'm copying tables with a mixture of text and images. All goes fine for a couple of hours of reformatting (other than font spacing not alway sticking!), and I save regularly. Then, for no reason I can discern, one of the times I click Update, I see the HTML code on the Visual Editor tab and my list of Page Revisions vanishes! This has happened to me twice now, the first time I had copied the content from the front end, put in the images fresh from my Media gallery, published the page then continued editing. The second time I took the source code for the page and put it onto a new WP page, and proceeded to edit, add images, etc. Either way, same result. Esmi on the WP forum suggested I try restoring a default theme, and sure enough, the page normalizes. So this is an Atahualpa issue. Is there a table bug? I don't see an easy way to create tables in visual editor, and I'd rather not do everything in hand-coded HTML. I can't find anything in the forum quite like this combination of issues, and I'm supposed to migrate my whole site this weekend. Can anyone help?? I set up a much larger site on Atahualpa with no problem, including copying content, but it wasn't tables or so many images. Can these pages be fixed? Or do I have to find a different theme? I do not have any plugins active on this particular site. I saw the info about some "concatenate" code, but was not sure if that still applies to 2.9.1?

Last edited by asellon; Feb 6, 2010 at 03:35 PM. Reason: updated info: no plugins being used
  #2  
Old Feb 6, 2010, 03:51 PM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I don't have time right now to try to parse through all of your troubles, but I can suggest a quick fix for the tables creation problem: if you get the Tiny MCE Advanced plugin, you'll be able to create tables pretty easily in the Visual editor. http://wordpress.org/extend/plugins/tinymce-advanced/

There are a couple of other table-specific plugins too.

You might need to look at the Atahualpa theme options and see if the table CSS is somehow interfering with the way your tables are coded...maybe they have some CSS that conflicts?
  #3  
Old Feb 6, 2010, 04:53 PM
asellon
 
23 posts · Feb 2010
Thanks for your speedy reply, Paula. I will certainly look into that plugin as soon as time allows. But for now, I'm hoping that someone in the forum will recognize these symptoms and provide this newbie non-coder with the specific steps to resolve the issue. It's happened on another page on the site, too, now. For the moment, I can use a default theme to simplify my editing process, then switch to Atahualpa to view, but I'm really hoping for a fix rather than a workaround. Thx!
  #4  
Old Feb 7, 2010, 05:49 AM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what is your url pointing at one of the posts that causes problems.

I haven't seen anything where editing a post cause the post revisions to disappear.

How many plugins do you have?

Does it happen if you disable the plugins? (some plugins can cause problems)

you say that if the problem happens and you switch to the default theme, the post is there.
- Are the revisions?
- when you switch back to Atahualpa - are the revisions there or gone?

My guess is that something with the post is causing a php error and the backend page stops being generated before it displays the revision information. Looking ath the sites error.log on access.log may show the error and lead us to a solution. Please check them to see if there are any php errors showing up at the times you have this problem.

You can verify that this is what's happing by looking at the source of the backend page the next time it happens. Look to see if teh HTML is complete for teh page.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Feb 7, 2010, 06:27 AM
asellon
 
23 posts · Feb 2010
Hi Juggledad -- thanks for your reply, but let me repeat some of the information I provided in my first post:
-- I'm editing static pages on WP
-- I do not have any plugins active on this particular site
-- Yes, when I switch back to a default theme, both Visual Editor and Page Revisions are visible again
-- I'm a non-coding newbie

And per my response to Paula's note, it has now happened on additional pages on that installation. So far three pages have freaked out in the same way upon clicking the Update button after a series of edits. I'm afraid to check out another WP site I already built with Atahualpa on another server for someone else, until I know what's going on with this install. Clearly the information is still there on my new site, but Atahualpa is having trouble showing it for some reason. I am able to edit the pages multiple times and all is fine, then for some reason one of the times I click Update, poof!, Visual Editor and Page Revisions become unavailable, and I'm staring at the HTML code on the Visual Editor tab. I'm thinking either the tables, the images in some of the cells, or something like that, may be throwing it off, but I don't know. When I copied the content from the old pages, I deleted the images on the WP pages, then re-added them from my WP Media Gallery.
I apologize that I don't know how to "look at the site's error.log on access.log" but if you can give me a bit more information, I will gladly check it out.
As to the HTML code I'm pasting from the old, non-WP web site, I'm not sure what to look for? As far as I can see the code is complete, or the table wouldn't render properly, etc., yes? What should I be seeking?
I would also be glad to contribute $ to the forum as I plan to use Atahualpa on 3 sites I'm launching this month and next, if I can get this issue cleared up. But it wasn't clear if there was a general Paypal donation box, or if all donations are to go to you? Yours is the only name on the donations list when I look at it.
I appreciate any further help you can provide! I really love Atahualpa and want to stick with it, but the workaround of using a default theme so that I can see Visual Editor and Page Revisions is awkward. I'd rather not have to rebuild these pages if I can humanly help it. Thx!
  #6  
Old Feb 7, 2010, 06:53 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Do you have any iframe code on those pages?

Bookmarks

Tags
images, page corruption, page revisions, tables, visual editor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Visual Editor is not showing Mande Center area post/pages 4 Jan 29, 2010 11:51 PM
[SOLVED] Can't edit posts - edits vanish - Virus? Theme Issue? WP Issue? jfrenaye Atahualpa 3 Wordpress theme 1 Aug 4, 2009 07:14 AM
read more tag not there when clicking on categories cephas Excerpts, Read more, Pagination 4 Jun 20, 2009 08:25 PM
using Visual Recent Posts with Atahualpa viewdesigninc Plugins & Atahualpa 1 May 19, 2009 08:27 PM
How do I change the "Page" header on top of my menu? I cannot find it in the editor. Jayce Page & Category Menu Bars 1 Apr 11, 2009 09:51 PM


All times are GMT -6. The time now is 10:18 PM.


Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.