Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

Menu issues with IE


  #1  
Old May 7, 2012, 02:59 PM
tsheridan
 
94 posts · Mar 2011
Menu issues with IE

I have 2 IE problems that I need help with please. In 7, 8, & 9 there is a white background behind the active menu item. In 7 & 9, the submenu is disappearing upon hovering over it.

Also, I was wondering how I can position the sub menu? I would like to move it over to the right a bit, but margin or padding aren't giving me any results.

URL is www.blackberrymorganhorses.com.

Atahualpa 3.7.6, WP 3.3.2

Thank you!
  #2  
Old May 9, 2012, 07:26 AM
tsheridan
 
94 posts · Mar 2011
I'm wondering if this could have something to do with updating Wordpress and Atahualpa to the latest versions? I have drop down menus on other sites that haven't yet been updated and they have no problem with the menus in IE.

Anyone?
  #3  
Old May 9, 2012, 08:45 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Instead of calling it the active menu item, call it the current menu item. There are selectors for the current menu item you can see with Firebug. You should try playing with them.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #4  
Old May 10, 2012, 08:23 AM
tsheridan
 
94 posts · Mar 2011
So a:active should be a:current? I have never heard of this. Why is it working on other sites then when I am using a:active?
I tried it for this instance, but it didn't change anything, and in fact the rollover links in the drop down menu didn't change color.

The only place I see any use of the term 'current', is in the sub menu, and the problem I'm having with current or active menu items is in the main menu. How would this effect the drop down menu disappearing when it's hovered on?

Can you possibly help me out and be a little more specific about which direction I need to go here, because I have no clue. I have tried playing around with this a little bit, but nothing is working, and that's because I have no idea what to use, and I'm sure my code is not correct.

Any additional guidance you can give me would be greatly appreciated, because I am beyond stuck here.

Thank you.
  #5  
Old May 10, 2012, 09:19 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
a:active refers to a link element when it is clicked. There is no a:current. In your case it looks like you would use SOMETHING LIKE in the CSS Inserts box.
HTML Code:
#rmenu2 .current-menu-item, #rmenu2 .current_page_item {
    background-color: transparent !important;
}
BTW - The differences in the way the different browsers handle CSS can, in some situations, cause confusion.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old May 10, 2012, 09:58 AM
tsheridan
 
94 posts · Mar 2011
Larry, I'm not sure which of my problems your solution was intended to potentially solve, but it didn't solve either. I don't have a transparent background issue in IE on the submenu, only on the main menu. The submenu will not stay active when moused over in IE, therefore no one would be able to click on the menu items in the submenu. Is this related to the active link setting?

I understand that different browsers handle CSS differently, what I don't understand is why this same code works on other sites in IE, but not on this one. The only difference so far is that this site has the most recent versions of wordpress and atahualpa. Is there a way to roll back to a previous version of atahualpa for troubleshooting purposes?

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
some issues with menu bar dinoc Page & Category Menu Bars 3 Oct 16, 2010 02:04 PM
page menu bar issues with IE6 rinoa3108 Page & Category Menu Bars 2 Sep 19, 2009 12:16 AM


All times are GMT -6. The time now is 04:44 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.