Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] How to set the default post thumbnail / "Crop Post Thumbnails" issue


  #1  
Old Jan 19, 2011, 09:53 AM
Fux
 
142 posts · Apr 2009
Hi -

I'm pretty, pretty sure that there is an option somewhere to enter the path to the default-thumbnail which yould be displayed in those cases where no "post thumbnail" has been set. I know that because my installation is set up to do exactly that. But now I would like to change that path. Where is that? I thought it must be somewhere in Atahualpa. I did not modify the functions.php for this...

Also I tried to use the "Crop Post Thumbnails" option in Atahualpa. What I want to achieve is to have a uniform width x height of 300 x 200px and for all my excerpt images (which will be the post thumbnails). But entering these values on the Atahualpa "Post Thumbnails"-options page and, of course, turning on "Crop Post Thumbnails" does not achieve that. What happens is that the thumbnails outside of the 2:3 ratio will just be scaled so that ONE dimension fits the target size - no cropping.

I am using Ata 3.5.3, WP 3.0.4
  #2  
Old Jan 19, 2011, 08:41 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
To have a default thumbnail I think you may need to use a plugin. As for the size issue there is an interaction of the Atahualpa thumbnail setting and the WordPress Settings>Media settings. After changing the size in the Setting>Media you may have to use a plugin to regenerate the thumbnails.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Jan 20, 2011, 02:05 AM
Fux
 
142 posts · Apr 2009
Thanks for your reply!

Quote:
Originally Posted by lmilesw
To have a default thumbnail I think you may need to use a plugin.
Are you totally sure? As I said, I already have a default thumbnail and I don't use a plugin for that. I do remember that I set this up after the release of WP 3.0 last summer, but I have no clue how I did it. It definitely is no modification of the WP code since it survived all the updates and I am, as I stated, quite sure that I did not modify the Ata functions.phph either (at least i can't find any code or path there related to this).

Quote:
Originally Posted by lmilesw
As for the size issue there is an interaction of the Atahualpa thumbnail setting and the WordPress Settings>Media settings. After changing the size in the Setting>Media you may have to use a plugin to regenerate the thumbnails.
OK, I changed that but still get the same result.

Any more ideas?
  #4  
Old Jan 20, 2011, 08:13 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I cannot think of a theme setting for path to default thumbnail. After you changed Media settings did you regenerate the thumbnails?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Jan 20, 2011, 12:05 PM
Fux
 
142 posts · Apr 2009
Quote:
Originally Posted by lmilesw
I cannot think of a theme setting for path to default thumbnail.
OK, maybe I AM imagining things and did solve this another strange way.. But it sure would be cool to have a plugin that automatically sets up default post thumbnails.

Quote:
Originally Posted by lmilesw
After you changed Media settings did you regenerate the thumbnails?
I did, but it seems there was a hiccup. I now regenerated them for the second time and it finally works.

Thanks a lot, your support is much appreciated!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] "Set Post Thumbnail" is not there blogmom Atahualpa 3 Wordpress theme 2 Oct 27, 2010 04:32 PM
Default "home" in page menu, how do I attach a post or page to it? LoneGunman Page & Category Menu Bars 3 Aug 1, 2010 07:55 PM
[SOLVED] "Post Thumbnail" dimension changes wont save, and problems with excerpts set Seijun Center area post/pages 6 Feb 17, 2010 03:37 AM
How to style "post icon" and "post comments" text Whatsthatcat? RSS, Feeds & Subscribing 3 Apr 1, 2009 10:41 AM


All times are GMT -6. The time now is 04:09 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.