Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] 'Register_sidebar' error after updating to latest version of wordpress


  #1  
Old May 10, 2015, 04:52 AM
msg-meteorites
 
18 posts · Nov 2010
[SOLVED] 'Register_sidebar' error after updating to latest version of wordpress

After updating to the latest wordpress version i have the following appear on all my pages:

Notice: register_sidebar was called incorrectly. No id was set in the arguments array for the "Left Sidebar" sidebar. Defaulting to "sidebar-1". Manually set the id to "sidebar-1" to silence this notice and keep existing sidebar content. Please see Debugging in WordPress for more information. (This message was added in version 4.2.0.) in /hermes/waloraweb018/b1263/moo.msgmeteoritescouk/wp-includes/functions.php on line 3560 Notice: register_sidebar was called incorrectly. No id was set in the arguments array for the "Right Sidebar" sidebar. Defaulting to "sidebar-2". Manually set the id to "sidebar-2" to silence this notice and keep existing sidebar content. Please see Debugging in WordPress for more information. (This message was added in version 4.2.0.) in /hermes/waloraweb018/b1263/moo.msgmeteoritescouk/wp-includes/functions.php on line 3560 Notice: register_sidebar was called incorrectly. No id was set in the arguments array for the "Left Inner Sidebar" sidebar. Defaulting to "sidebar-3". Manually set the id to "sidebar-3" to silence this notice and keep existing sidebar content. Please see Debugging in WordPress for more information. (This message was added in version 4.2.0.) in /hermes/waloraweb018/b1263/moo.msgmeteoritescouk/wp-includes/functions.php on line 3560 Notice: register_sidebar was called incorrectly. No id was set in the arguments array for the "Right Inner Sidebar" sidebar. Defaulting to "sidebar-4". Manually set the id to "sidebar-4" to silence this notice and keep existing sidebar content. Please see Debugging in WordPress for more information. (This message was added in version 4.2.0.) in /hermes/waloraweb018/b1263/moo.msgmeteoritescouk/wp-includes/functions.php on line 3560 Notice: register_sidebar was called incorrectly. No id was set in the arguments array for the "Center Top widget area" sidebar. Defaulting to "sidebar-5". Manually set the id to "sidebar-5" to silence this notice and keep existing sidebar content. Please see Debugging in WordPress for more information. (This message was added in version 4.2.0.) in /hermes/waloraweb018/b1263/moo.msgmeteoritescouk/wp-includes/functions.php on line 3560




Any ideas on what has caused this and how to make it go away? I am not a coder at all and am lost as to what to do. Any help much appreciated :-)

Cheers

Martin
  #2  
Old May 10, 2015, 09:24 AM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Try swapping to twenty-fifteen then swapping back to Atahualpa
What version of atahualpa?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old May 10, 2015, 12:40 PM
msg-meteorites
 
18 posts · Nov 2010
Thanks, just tried that with no difference when i switch back. Disappears on twenty-fifteen but then reappears when i switch back? Running Atahualpa 3.7.23
  #4  
Old May 10, 2015, 05:22 PM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
This is a wordpress 'new feature'?? For the longest time sidebars didn't need to use an 'id' when they were being created. As of WP 4.2, they have made it mandatory or they will issue these messages but everyhtning will stil work.

You can get rid of the messages by editing your wp-config.php and changing the line
HTML Code:
define('WP_DEBUG', true);
and changing it to
HTML Code:
define('WP_DEBUG', false);
This will be addressed in a future release.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old May 11, 2015, 02:51 AM
msg-meteorites
 
18 posts · Nov 2010
Thank you very much, that sorted it instantly. Much appreciated :-)

Cheers

Martin
  #6  
Old May 11, 2015, 06:43 PM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
created a patch for this see PATCH 3723-02: Notice: register_sidebar was called incorrectly.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updating from 3.5.0 to the latest version! prooffairy New Versions, & Updating 1 Nov 14, 2014 10:57 AM
Why no latest version of Atahualpa via WordPress Theme intallation? Carlo New Versions, & Updating 3 Dec 10, 2010 09:39 AM
second level menu background messed up after update to latest Wordpress version gaidin Page & Category Menu Bars 1 Oct 28, 2010 04:16 AM
trouble after updating to latest version btrandolph Atahualpa 3 Wordpress theme 0 Apr 27, 2010 11:13 AM
How to Upgrade Latest Version of Wordpress Nick123 New Versions, & Updating 1 Jan 7, 2010 01:56 AM


All times are GMT -6. The time now is 10:47 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.