Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » Running WordPress » Web Hosting for WordPress »

[SOLVED] Missing my "www"??


  #1  
Old Mar 29, 2009, 08:56 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
[SOLVED] Missing my "www"??

I've been noticing something new/different.

I've always entered my website's address / URL as "www.hatchtown.com" the leading "http://" and trailing "/index.html" were always automatically inserted/provided by the browser and/or internet internal systems.

Lately (since switching to WordPress?), I'm noticing my site's URL shows up in my browser (usually Firefox) at JUST http://hatchtown.com even when I've entered the address with the www

What's changed?!
  #2  
Old Mar 30, 2009, 02:12 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
You probably have a redirect from www.domain.com -> domain.com in your htaccess file, or directly in the webserver configuration file (less likely but possible).
It's a good thing to decide on one version, either domain.com or www.domain.com and then redirect both users and search engines to the preferred version. For the search engines it is better if a "301" redirect was set instead of one without "301". You should see something like "R=301" mentioned in your .htaccess file.
  #3  
Old Mar 30, 2009, 05:14 PM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
I looked at a couple of .htaccess files I found but did not see any mention of any redirect

I've kept a "legacy" file from my "old" website. It's in the root directory and it's URL as shown in the browser is "http://www.hatchtown.com/nostdir.html". Meanwhile, as soon as I click a link back into the WP installation I get URLs like "http://hatchtown.com/tools/misc-tools" (no "www").

Checking the WP Settings in the Dashboard:

WordPress address (URL) = "http://hatchtown.com/wp"

Blog address (URL) = "http://hatchtown.com"

We've always published our URL as www.hatchtown.com -- I think people expect a website to start out with the www. How do I go about getting the w's back?
  #4  
Old Mar 30, 2009, 08:24 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
If you change these

WordPress address (URL) = "http://hatchtown.com/wp"

Blog address (URL) = "http://hatchtown.com"

to

WordPress address (URL) = "http://www.hatchtown.com/wp"

Blog address (URL) = "http://www.hatchtown.com"

it should work if the web server is set to serve bot www.domain and domain from the same directory.

If not, you may have trouble getting to the site again after you made these changes. In that case you'd have to manually edit, with PHPMyAdmin or something else, in the WP database, in the table wp_options, the values of row 1 ('siteurl') and row 39 ('home')
  #5  
Old Mar 31, 2009, 07:01 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Quote:
Originally Posted by Flynn
...<snip>...it should work if the web server is set to serve bot www.domain and domain from the same directory.

If not, you may have trouble getting to the site again after you made these changes. In that case you'd have to manually edit, with PHPMyAdmin or something else, in the WP database, in the table wp_options, the values of row 1 ('siteurl') and row 39 ('home')
Okay! Now you're scaring me!!

Could this have anything to do with something GoDaddy might have done. At some point in the transition from my old html/table website to the new WP-powered one I spoke to GoDaddy tech help and I remember discussion of redirects. I don't remember the specific reason for my call to them.
  #6  
Old Mar 31, 2009, 08:10 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I suggest that you contact Godaddy again and ask them to configure a "301 redirect from domain.com to www.domain.com" instead of the other way round

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Change footer background on &quot;Page&quot; pages only Unca_Tim Post-Kicker, -Byline & -Footer 22 Jun 4, 2009 01:45 PM
[SOLVED] Adding &quot;share this&quot; plug in to post page...Possible? d_random Plugins & Atahualpa 2 May 19, 2009 03:47 PM
[SOLVED] Flynn: &quot;..default hard coded widgets..&quot; ?? Shepherd Jim Sidebars & Widgets 2 May 11, 2009 06:47 AM
[SOLVED] What are the &quot;rules&quot; about using special characters in page titles? Shepherd Jim Page & Category Menu Bars 4 Apr 7, 2009 08:03 AM
[SOLVED] How should top level &quot;button&quot; work on a menu bar? Shepherd Jim Page & Category Menu Bars 2 Mar 14, 2009 03:30 PM


All times are GMT -6. The time now is 06:06 AM.


Powered by vBulletin® Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.