Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

All pages return 'Not Found' with /null URL after activating plugin.

Old Sep 11, 2009, 07:44 AM
2 posts · Sep 2009

After activating a plugin every page, user and admin, displays the content 'Not found' and the URL is always sitename.com/null All the sidebars,header and footer are displayed correctly. Visiting any page/link re-directs back to /null

Deactivating the plugin restores normal operation.

The plugin in question is, http://wordpress.org/extend/plugins/...racing-league/

I am the author of the plugin and have determined, with help from the user, sdjukic, that after changing to the default theme my plugin activates and the site works OK.

Changing back to atahualpa we found that after commenting out the action 'wp_print_scripts' in my plugin then everything works OK. The action for wp_print_scripts just calls wp_enqueue_script with the name of a fairly simple Javascript file, using SACK, to validate user input.

I have installed the atahualpa theme, same version 3.4.2 and all the users other plugins on my test server and do not have a problem. I haven't applied all the same theme/plugin settings are there are so many.

I have spent hours and hours trying to fix this, and I'm not blaming this theme, I would just like to find out why this is happening.

Any help would be appreciated, as this user, sdjukic, who has donated to alahulpa, would like to use my plugin and and I would like to ensure that other users do not have a problem.

Apologies for duplicate post in http://wordpress.org/support/topic/3...2#post-1208026 as sdjukic mentioned this forum after I posted.


Old Sep 11, 2009, 07:58 AM
1 posts · Sep 2009
First, to thank Ian for support about this problem I discovered.
My site URL is:

I am using Atahualpa 3.4.2 and wordpress Version 2.8.4

We have already tried to uninstall several other plugins but without success.
After activating Ian plugin same error with URL/null returns.
Old Sep 19, 2009, 05:26 PM
5 posts · Sep 2009
Another plug-in that causes this is Featured-Content-Gallery .. which is a shame, cos it looks so nice.

Any suggestions for something similar .. or better yet, a fix to the problem??

Old Sep 19, 2009, 07:42 PM
juggledad's Avatar
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
ianhaycox - I just installed the plugin and have no errors - did you fix something?
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
Old Sep 20, 2009, 01:38 AM
2 posts · Sep 2009
Thanks for the response, however, I haven't managed to fix this yet.

I did get it to work on http://simracing.nacionalnaklasa.rs/ by removing the call to wp_enqueue_script in the function actionWpPrintScripts() . The call(s) to wp_enqueue_script generate the following code,

<script type='text/javascript' src='http://simracing.nacionalnaklasa.rs/wp/wp-includes/js/tw-sack.js?ver=1.6.1'></script>
<script type='text/javascript' src='http://simracing.nacionalnaklasa.rs/wp/wp-includes/js/prototype.js?ver=1.6'></script>

<script type='text/javascript' src='http://simracing.nacionalnaklasa.rs/wp/wp-includes/js/scriptaculous/wp-scriptaculous.js?ver=1.8.0'></script>
<script type='text/javascript' src='http://simracing.nacionalnaklasa.rs/wp/wp-includes/js/scriptaculous/effects.js?ver=1.8.0'></script>
<script type='text/javascript' src='http://simracing.nacionalnaklasa.rs/wp/wp-content/plugins/motor-racing-league/js/motorracingleague.js?ver=2.8.4'></script>
If the code above is pasted into the function actionWpHead() then my plugin works correctly. Bizzare. Obviously this is not a long-term solution as the Javascript script file locations and versions are hardcoded.

Interestingly, sdjukic, has now reported that one of the theme configuration options does not work. The option 'Add HTML/CSS Inserts' only allows one line of entry, not multiple lines. If my plugin is deactivated then the theme option works OK. See attached screenshots.

I have reproduced this on my test server and Firefox reports an error in the Javascript console as,

Error: $ is not a function
Source File: http://localhost/wp/wp-includes/js/prototype.js?ver=1.6
Line: 3920
Error: this.inject is not a function
Source File: http://localhost/wp/wp-admin/load-scripts.php?c=1&load=prototype,jquery,utils,sack,scriptaculous-root,scriptaculous-effects&ver=5c268ce53a079c3406fccaea806572c3
Line: 856
At first glance it looks like something is dynamically loading SACK and maybe there is a version conflict. http://simracing.nacionalnaklasa.rs/ does not use Featured-Content-Gallery but does use Next Gen Gallery. Both I believe are based on mootools. (mootools.net)

Not being able to reproduce the problem makes it difficult to fix, so any further hints or help would be appreciated.


Attached Thumbnails
Click image for larger version

Name:	mrl-activated.jpg
Views:	1266
Size:	87.7 KB
ID:	255  Click image for larger version

Name:	mrl-deactivated.jpg
Views:	1245
Size:	89.4 KB
ID:	256  
Old Dec 19, 2009, 01:54 PM
5 posts · Dec 2009
Check out url replace in .htaccess
Old Feb 26, 2010, 09:26 AM
1 posts · Feb 2010
I am having the same problem with a different plugin. I think the plugin causing the problem is the Formbuilder plugin (http://truthmedia.com/wordpress/formbuilder/). I get the "null" page on different pages and when trying to go to site admin (/wp-admin). Sometimes, if I click the link again, it takes me to the page ok. So, the problem is intermittent and I can't seem to find a reproducible pattern. The site is: www.springfieldeducationfoundation.org. Any help would be appreciated.


activation, null, plugin problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Trying to return to Atahualpa - subscription links and padding ariels Sidebars & Widgets 15 Aug 30, 2009 05:52 PM
how do you hide the sidebar on "Not Found" pages/posts w/ incorrect ID in the URL? jonasgrumby Sidebars & Widgets 0 Aug 26, 2009 12:13 PM
Return to the page2cat/archive page issue lhanft Plugins & Atahualpa 3 Jul 23, 2009 08:59 AM
Forum Plugin up and running, but can I remove widgets for select pages? ericinnyc Sidebars & Widgets 1 Jul 21, 2009 04:36 AM
WP-NicEdit Plugin ok with post but not ok with pages Ponics Plugins & Atahualpa 7 Jun 18, 2009 04:09 PM

All times are GMT -6. The time now is 07:29 AM.

Powered by vBulletin® Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.