Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » Forum Usage » Forum How-To »

[SOLVED] Trouble with Safari vs. Firefox


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jun 27, 2009, 11:09 PM
sonaminhas
 
5 posts · Jun 2009
Hi,

First of all I'd like to thank you so much for making such a simple theme, even someone like me who has no idea what css or xhtml even mean could set up my own blog. I have a few questions...sorry, I'm clueless!

1. Everything looks normal in Firefox, but the sidebars are much wider in Safari and the center column is really narrow.

2. I can't for the life of me figure out to change the header image. I've read so many posts and forums, but I still can't figure it out.

3. When I post the pictures, even when they're the same size...they show up a little bigger or smaller than each other. How do I make sure they show up the same size.

4. How do I center embedded videos?

I really appreciate any help. Thank you!

http://thefilmistanconnection.com/

- Sona

Last edited by sonaminhas; Jun 27, 2009 at 11:12 PM. Reason: Remember more questions...
  #2  
Old Jun 29, 2009, 08:27 PM
Flynn's Avatar
Flynn
 
3,766 posts · Oct 2008
Munich, Germany
1. You have set a width of 0.5px for the sidebars, you must have meant something different?

2. The header images are automatically grabbed from the directory /atahualpa333/images/header

Simply delete / upload images into that directory.

3. It tried to fit the images into the available space. Delete
div[class~="post"] img {
height:auto;
}
in style.css

4. Find the ID or class of the flash or its parent container and add a CSS insert

div#id-name {
margin-left: auto;
margin-right: auto;
}

or try

object {
margin-left: auto;
margin-right: auto;
}
  #3  
Old Jun 29, 2009, 09:36 PM
sonaminhas
 
5 posts · Jun 2009
1. I fixed the width of the sidebars and while the sizes are not exaggerated anymore, the pages still looks different, in terms of the width of the three columns, especially the center column. The center column is smaller in Firefox and much wider in Safari....

2. Where is the directory /atahualpa333/images/header? Is it located in style.css or on that page?

3. I deleted that information, but it still didn't change anything. And the images are not smaller/larger in terms of width, but height.

4. (Find the ID or class of the flash or its parent container and add a CSS insert)...would this also be in style.css? I didn't see it, is there a way to change it by adding to the html code?

Last edited by sonaminhas; Jun 29, 2009 at 09:39 PM.
  #4  
Old Jun 29, 2009, 10:39 PM
Flynn's Avatar
Flynn
 
3,766 posts · Oct 2008
Munich, Germany
1. You have this in style.css line 153

.coltwo {
min-width:200px;
width:20%;
}

Change the value to 100%

2. In your case it is /wp-content/themes/atahualpa/images/header/, a directory on your web hosting account

3. After you made the change of 1) this should not be necessary anymore but you can edit style.css and delete the red parts

.post img.size-full {
/*max-width: 100% auto;*/
max-width: 96%; /* resize images in the main column if needed.
97% so images with padding and border don't touch
the right sidebar while being resized. Change this
to 100% if you want, if your images
don't have padding and a border */
width: auto 100%;
margin: 5px 0 5px 0;
/*overflow-x: auto;*/
/* more ... */
}



/* hiding from IE6 which would stretch the image vertically.
IE6 will get width and height via jQuery */
div[class~=post] img {
height: auto; /* FF & Safari need auto */
}



4.)

Edit the post with the Flash and add the green part:

<object style="margin-left:auto; margin-right: auto" width="425" height="344" codebase="http://download.macromedia.com/pub/shockwave


===============

To add or edit CSS, add your CSS at Theme Options -> HTML/CSS Inserts -> CSS Inserts, instead of manually editing style.css. That way your changes will be preserved when you upgrade to a newer Atahualpa version.

Last edited by Flynn; Jun 29, 2009 at 10:41 PM.
  #5  
Old Jun 30, 2009, 12:38 AM
sonaminhas
 
5 posts · Jun 2009
THANK YOU so much! I really appreciate your help! Everything worked, except I edited the post of the embedded video, but it still doesn't center. This is what it looks like unedited. Maybe that will help.

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="425" height="344" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"><param name="allowFullScreen" value="true" /><param name="allowscriptaccess" value="always" /><param name="src" value="http://www.youtube.com/v/0SKjklIEzy8&amp;hl=en&amp;fs=1&amp;color1=0x3a3a3a &amp;color2=0x999999" /><param name="allowfullscreen" value="true" /><embed type="application/x-shockwave-flash" width="425" height="344" src="http://www.youtube.com/v/0SKjklIEzy8&amp;hl=en&amp;fs=1&amp;color1=0x3a3a3a &amp;color2=0x999999" allowscriptaccess="always" allowfullscreen="true"></embed></object>
<strong>Original version of 'Agar Tum Mil Jao' from Zeher</strong>

Once again thank you so much! You're awesome!
  #6  
Old Jun 30, 2009, 06:31 AM
juggledad's Avatar
juggledad
 
22,370 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Put a <center>...</center> arround the <object>...</object> i.e.
HTML Code:
<center>
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="425" height="344" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0">
<param name="allowFullScreen" value="true" />
<param name="allowscriptaccess" value="always" />
<param name="src" value="http://www.youtube.com/v/0SKjklIEzy8&amp;hl=en&amp;fs=1&amp;color1=0x3a3a3a&amp;color2=0x999999" />
<param name="allowfullscreen" value="true" />
<embed type="application/x-shockwave-flash" width="425" height="344" src="http://www.youtube.com/v/0SKjklIEzy8&amp;hl=en&amp;fs=1&amp;color1=0x3a3a3a&amp;color2=0x999999" allowscriptaccess="always" allowfullscreen="true">
</embed>
</object>
</center>
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Jun 30, 2009, 07:08 AM
sonaminhas
 
5 posts · Jun 2009
Thank you both for your help, everything is working now! Thank you, Thank you, Thank you! You guys are awesome!

Bookmarks

Tags
firefox, headerimage, safari

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Safari not displaying page menu bar and post footer correctly chinnerz Atahualpa 3 Wordpress theme 4 May 31, 2009 10:52 PM
Menu bars different in Safari vs. Firefox paulae Page & Category Menu Bars 2 Apr 5, 2009 05:10 PM
Added header images, now none show on Firefox, Safari, etc. ldaily Header configuration & styling 5 Mar 13, 2009 06:36 PM
Firefox and Safari show 3 columns. IE only shows 2. How do I resolve? rwang Sidebars & Widgets 9 Dec 20, 2008 04:46 AM


All times are GMT -6. The time now is 06:27 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.