Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] Can't get header image to display


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old May 18, 2012, 04:00 PM
colinruggiero
 
23 posts · Feb 2012
I feel awful creating another thread on this seemingly simple topic but I've read a bunch of the existing posts on this and still can't figure it out. I recently created a second database on my hosting account and installed wordpress so that I could host a second site. I've managed to get my domain alias and url re-write rules configured in a way that I can view my site at the url (www.exumafilm.com). The default header images were displaying properly but then I tried to replace them with a custom one (ExumaWebTitle1.gif) and now no header image will display. It's a low-grade image but I'm just using it for a test.

I'm not sure why I feel like this is some sort of issue with the subdirectory for my site or wrong file path but I don't know what else it could be. When I try to type in the file path to this image in the address bar of a browser (not even sure if I'm doing that correctlly), it takes me to the site at the root level of my hosting account (www.colinruggiero.com).

My first site is in /htdocs/www/ and the other site, the one I'm having trouble with is in the subdirectory /htdocs/www/exuma/. Any ideas what I could be messing up here? Thanks in advance for any help!

Cheers,
Colin
  #2  
Old May 18, 2012, 10:38 PM
lmilesw's Avatar
lmilesw
 
10,111 posts · Jul 2009
Central New York State USA
Check the spelling of the image and check the file permissions for the images folder and the image itself.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old May 19, 2012, 04:22 PM
colinruggiero
 
23 posts · Feb 2012
Thank you very much for your suggestions. I checked on those things but they don't seem to be the issue. The file and folder permissions are both read enabled for all users. I'm not exactly sure how the spelling is relevant. There is no code that contains the name of the header image, it simply displays any .gif, .jpg or .png that is in the folder. So why would it matter how it is spelled? I assume I'm missing the point somehow but not sure how. When I type the address of the header images folder into a browser I get this:


Index of /exuma/wp-content/themes/atahualpa/images/header

Name Last modified Size Description
Parent Directory -
ExumaWebTitle1.gif 18-May-2012 13:23 367K

It shows that the desired image exists in the directory. When I click on that image however, it takes me to, http://www.exumafilm.com/wp-content/...aWebTitle1.gif.

That is the address in the address bar but it displays the home page for my site www.colinruggiero.com along with this message in the body:

"Not Found

Sorry, but you are looking for something that isn't here."

I feel like somehow the rewrite rules in my .htaccess file are directing searches for my domain name, www.exuma.com, to the correct place but that somehow paths to files in that directory are getting messed up somehow. That doesn't explain why the original header images displayed correctly though. I've tried various header images of various file types and sized but nothing will display. Any additional thoughts about what could be going wrong? Thank you!

Colin
  #4  
Old May 19, 2012, 04:35 PM
colinruggiero
 
23 posts · Feb 2012
If it sheds any light on the issue, I'm having the same problem uploading a background image. I upload the image backr.gif to: /wp-content/themes/atahualpa/images/ and copied the appropriate code into the body style box in the Atahualpa Theme options (background: url(/wp-content/themes/atahualpa/images/backgr.gif) repeat top left but it can't find the image. I'm using Coda for my ftp stuff. When I navigate to the image inside the directory it displays the image but if I click on the preview button it takes me here:

http://colinruggiero.com/htdocs/www/...ges/backgr.gif

and says that the image cannot be found.

Seems like this is a very simple problem I'm just too clueless about this stuff to know how to fix it or exactly where the problem lies.

Thanks very much for any help,
Colin
  #5  
Old May 19, 2012, 04:37 PM
colinruggiero
 
23 posts · Feb 2012
Some sort of formatting turned my semi-colon into an emoticon in that last post. for clarity's sake, there is no smiley in the code...
  #6  
Old May 19, 2012, 07:20 PM
lmilesw's Avatar
lmilesw
 
10,111 posts · Jul 2009
Central New York State USA
Try setting your permalinks to default and save. Then set it back to what you have and save. See if that makes a difference.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #7  
Old May 21, 2012, 03:49 PM
colinruggiero
 
23 posts · Feb 2012
My permalinks were already set to default on the exumafilm.com site. I tried changing them to something else but no luck. I also reset the permalinks on the colinruggiero.com site to default and then back again but it doesn't seem to have done anything either. Thanks for the suggestion though.

Colin
  #8  
Old May 21, 2012, 05:18 PM
juggledad's Avatar
juggledad
 
22,382 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
1) verify the file exists in the atahualpa/images/header folder
2) verify the spelling is exact (case is important)
3) make sure the extension is correct
4) make sure the file permission is the same as the other file that is there.
5) temporally disable the htaccess in the root (change the name from .htaccess to just htaccess)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old May 22, 2012, 02:35 AM
colinruggiero
 
23 posts · Feb 2012
Thanks very much for your help Juggledad. The problem seems to have been something in my database tables. I installed wordpress and then afterward changed the site_url and home settings in my database from colinruggiero.com to exumafilm.com. I was getting progressively weirder behavior until finally typing www.exumafilm.com into a browser took me to www.colinruggiero.com. This seems to have happened all by itself since I didn't touch anything in my Wordpress or database files between when it was working and when it wasn't. In any case, I've reset some of the database tables and re-created my.htaccess file and now things seem to be working normally. Hopefully it will stay that way. Thanks again for your suggestions - I appreciate it.

Cheers,
Colin

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Image display problems in IE deluxcanuck Center area post/pages 12 Jan 7, 2011 02:00 AM
Display Image/Document First kpkes@yahoo.com Header configuration & styling 0 Apr 13, 2010 02:20 PM
[SOLVED] Need static header image to display on the front page but no image on any o joaodagraca Header configuration & styling 2 Aug 10, 2009 02:45 AM


All times are GMT -6. The time now is 08:02 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.