Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Page printing problems in 3.7.3 vs. 3.6.7


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old May 15, 2012, 02:22 PM
Douglas
 
15 posts · Apr 2010
Printing "page" pages no longer functions properly after manually updating (with all fixes) from 3.6.7 to 3.7.3. Chrome still works okay, but both Firefox and IE produce blank first pages and then only some content on subsequent pages. Switching back to 3.6.7 (still installed in themes) corrects the problem.

Pages on our site (http://www.piercenet.com/previews/) are listed in the left sidebar as Product Articles. Individual pages have a right "sidebar" that is actually part of the center content in the page template, so it should (and normally does) print as part of the page.

Any thoughts on what underlying code change in 3.7.3 might have caused this function to break?
  #2  
Old May 15, 2012, 02:26 PM
lmilesw's Avatar
lmilesw
 
10,077 posts · Jul 2009
Central New York State USA
Is there some reason you didn't upgrade to 3.7.6. If you need to stay at 3.7.3 there are several patches for it in the New Versions and Updating forum.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old May 15, 2012, 05:41 PM
juggledad's Avatar
juggledad
 
22,093 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
There were changes made to the CSS to prevent the sidebars from printing. If you need to have the right sidebar appear when printing, you will need to edit the file css.php and find lines 2039-2072 which should be
HTML Code:
	#header, 
	#footer, 
	.colone, 
	.colthree,
	.navigation, 
	.navigation-top,
	.navigation-middle,
	.navigation-bottom,
	.wp-pagenavi-navigation, 
	#comment, 
	#respond,
	.remove-for-print {
		display: none;
		}

	td#left, td#right, td#left-inner, td#right-inner {
		width: 0;
		display: none;
		}

	td#middle {
		width: 100% !important;
		display: block;
		}

	/* 8 hacks for display:none for all sidebars for all browsers except IE. */

	*:lang(en) td#left {
	    display: none;
		}
		
	*:lang(en) td#right {
	    display: none;
		}
and change them to
HTML Code:
	#header, 
	#footer, 
	.colone, 
	     
	.navigation, 
	.navigation-top,
	.navigation-middle,
	.navigation-bottom,
	.wp-pagenavi-navigation, 
	#comment, 
	#respond,
	.remove-for-print {
		display: none;
		}

	td#left,           td#left-inner, td#right-inner {
		width: 0;
		display: none;
		}

	td#middle {
		width: 100% !important;
		display: block;
		}

	/* 8 hacks for display:none for all sidebars for all browsers except IE. */

	*:lang(en) td#left {
	    display: none;
		}
		
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #4  
Old May 16, 2012, 06:59 AM
Douglas
 
15 posts · Apr 2010
Quote:
Originally Posted by lmilesw
Is there some reason you didn't upgrade to 3.7.6. If you need to stay at 3.7.3 there are several patches for it in the New Versions and Updating forum.
Thanks, but I don't like to upgrade to brand new versions because I don't want to be the one to discover bugs. I did apply all of the patches for 3.7.3.
  #5  
Old May 16, 2012, 07:12 AM
Douglas
 
15 posts · Apr 2010
Thanks Juggledad. I'll take a look at those code changes. However, as I stated in my message, what looks like a right sidebar on our "page" pages is actually part of the center content, NOT a sidebar, so I didn't expect that it should have been affected by the sidebar printing changes.

Try to print the following page viewed in Firefox:
http://www.piercenet.com/previews/20...-synaptosomes/

The first two pages of content are blank in the print preview (as well as to an actual printer). The right column (not a sidebar) does seem to be included correctly in the printed content, as suggested by the wide right margin space on pages 3 and 4.

So, it seems like a more general printing problem, not a sidebar issue.

Any other ideas? Thanks so much.
  #6  
Old May 16, 2012, 08:26 AM
juggledad's Avatar
juggledad
 
22,093 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
please remove all widgets from the left sidebar and try it again
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #7  
Old May 16, 2012, 08:31 AM
Douglas
 
15 posts · Apr 2010
I'll have to try that on our development server - can't do without the sidebars widgets on the live site.

If that corrects the problem, what will be the solution? I can't just permanent do without the left sidebar widgets!

Thanks.

Last edited by Douglas; May 16, 2012 at 09:02 AM.
  #8  
Old May 16, 2012, 09:04 AM
juggledad's Avatar
juggledad
 
22,093 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
it seems that the browsers (at least Firefox) does not like something in the left sidebar. There is no problem with Safari on my Mac - it's the way the browsers are interpreting things.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #9  
Old May 16, 2012, 09:13 AM
Douglas
 
15 posts · Apr 2010
So how does that explain why 3.6.7 works just fine? Can I just replace the print CSS code in 3.7.3 with the code from 3.6.7, or is there other places where the two versions of Atahualpa differ with respect to printing?
  #10  
Old May 16, 2012, 09:34 AM
juggledad's Avatar
juggledad
 
22,093 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
try it. The print css was changed because there were errors in the printing - sidebars were printing.

With the differences in browsers no one solution is guaranteed to work in all places. You may find that if you add the old CSS in, it will then work in IE but another browser might be broken (I just love standardization)
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #11  
Old May 16, 2012, 02:24 PM
Douglas
 
15 posts · Apr 2010
Okay, I was able to correct the problem by commenting out the following two lines of CSS:
Line 2056 (display: none; )
Line 2061 (display: block; )

Print now works in IE, Firefox and Chrome. It's sort of curious that the exact change that was added to help printing actually caused a problem where there wasn't one. In any case, the problem appears to be solved as far as my site is concerned.

Now, if only there were a universal standard for telling browsers not to split images with page breaks when printing! No matter what I've tried, I can't get that one to work well.
  #12  
Old May 16, 2012, 09:03 PM
lmilesw's Avatar
lmilesw
 
10,077 posts · Jul 2009
Central New York State USA
As a test I just commented out those two lines and it totally messed up my printing.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Tags
print, printing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Logo and Header image not printing gabbybuzz Atahualpa 3 Wordpress theme 9 Apr 13, 2012 07:41 PM
Printing entire page including sidebars, header, etc. peterf Atahualpa 3 Wordpress theme 8 Dec 20, 2011 07:18 PM
Problems printing with Chrome and Firefox HelgeLarsen Atahualpa 3 Wordpress theme 12 Oct 15, 2011 01:12 AM
Printing "footer" along with page content wp-novice Post-Kicker, -Byline & -Footer 11 Jun 14, 2011 10:22 PM


All times are GMT -6. The time now is 05:19 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.