Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Gallery Plugin Not Respecting Ata's Sidebar Settings


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Apr 24, 2012, 07:43 AM
LaneLester
 
76 posts · May 2010
North Georgia, NA
I've tested a number of gallery plugins for suitability for newbie users. The best one so far is gallery-plugin, but I've hit a snag.

The plugin uses custom templates to set up a page to list all site galleries and another for the individual gallery pages. These template files do not use Ata's sidebar settings, but rather install some default sidebar items (Search Pages Archives Categories Meta). This makes for a mess with the wrong items plus the sidebar gets forced to the bottom of the page.

You can see the situation at http://www.birding4u.com/galleries/

The gallery template has only this in it to produce the sidebar: <?php get_sidebar(); ?>

I may just delete that line and have no sidebar on the gallery pages, but i would prefer to be able to have a sidebar and control its contents.

If I knew where those sidebar items (Search Pages Archives Categories Meta).were being specified I could change the code to what I want. Do you know, or have a different suggestion?

Lane
  #2  
Old Apr 24, 2012, 07:22 PM
lmilesw's Avatar
lmilesw
 
10,047 posts · Jul 2009
Central New York State USA
Those look like the default sidebar contents when no widgets are installed. What is it you want to do (EG What do you want your page to look like)?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Apr 25, 2012, 06:12 AM
LaneLester
 
76 posts · May 2010
North Georgia, NA
Quote:
Originally Posted by lmilesw
Those look like the default sidebar contents when no widgets are installed. What is it you want to do (EG What do you want your page to look like)?
Yes, the default is being displayed. However, on all other posts/pages of my site, my selected widgets are displayed.

Ideally, I would like my selected widgets to be displayed on the gallery pages, as they are on all other pages, and they would be displayed at the side rather than at the bottom.

Plan B would be to be able to manually code what I want in the sidebar (like we used to do in olden times). With other themes, this would be coded in sidebar.php, but it seems Ata has no such file. Is there a file in Ata which serves the same purpose?

Lane
  #4  
Old Apr 25, 2012, 06:31 AM
juggledad's Avatar
juggledad
 
21,945 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
The left sidebars are built in header.php and thr right ones are built in footer.php
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #5  
Old Apr 25, 2012, 07:23 AM
LaneLester
 
76 posts · May 2010
North Georgia, NA
Quote:
Originally Posted by juggledad
The left sidebars are built in header.php and thr right ones are built in footer.php
Thanks! I have only the right sidebar enabled. Looking at footer.php, it seems the default sidebar has only Recent Posts, wp_list_bookmarks(?), and Meta. So the gallery pages are getting their list of sidebar items from somewhere else!

Lane
  #6  
Old Apr 25, 2012, 09:24 AM
lmilesw's Avatar
lmilesw
 
10,047 posts · Jul 2009
Central New York State USA
Quote:
Originally Posted by LaneLester
Ideally, I would like my selected widgets to be displayed on the gallery pages, as they are on all other pages, and they would be displayed at the side rather than at the bottom.

Plan B would be to be able to manually code what I want in the sidebar (like we used to do in olden times). With other themes, this would be coded in sidebar.php, but it seems Ata has no such file. Is there a file in Ata which serves the same purpose?
For displaying widgets only on certain page you can use plugins like Widget Logic or Display Widgets.

As far as putting info in the sidebar why not just use a widget for what you want? Also coding the theme files won't survive a theme upgrade so you will have to document what you do and re-do the edits if you do decide to upgrade. This is something I don't get involved in as I deal with quite a few sites.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #7  
Old Apr 25, 2012, 10:29 AM
LaneLester
 
76 posts · May 2010
North Georgia, NA
Quote:
Originally Posted by lmilesw
For displaying widgets only on certain page you can use plugins like Widget Logic or Display Widgets.
I tried Widget Logic Visual and Display Widgets. I couldn't figure out how to use Display Widgets. Neither of the two I tried had any effect on the gallery pages, although they did control the other pages.

Quote:
As far as putting info in the sidebar why not just use a widget for what you want?
I think I've failed to communicate my situation. I am using the Text widget (it's the only one I want on this site). On all pages except the gallery pages, only the Text widget is displayed. As I noted in my first post, the gallery pages show a whole flock of items, and they display at the bottom of the page.

I've gone ahead and removed from the gallery template files the code <?php get_sidebar(); ?> and that at least gets rid of all the junk I don't want there.

Maybe some day I'll figure out how to put there what I want.

I appreciate all the information and suggestions in this thread.

Lane
  #8  
Old Apr 25, 2012, 10:53 AM
juggledad's Avatar
juggledad
 
21,945 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
You need to edit the two gallery templact files
for gallery-single-template.php change the first line from
HTML Code:
<?php get_header(); ?>
to
HTML Code:
<?php 
list($bfa_ata, $cols, $left_col, $left_col2, $right_col, $right_col2, $bfa_ata['h_blogtitle'], $bfa_ata['h_posttitle']) = bfa_get_options();
get_header(); 
extract($bfa_ata); 
?>
for gallery-template.php, change line 7 from
HTML Code:
<?php get_header(); ?>
to
HTML Code:
<?php 
list($bfa_ata, $cols, $left_col, $left_col2, $right_col, $right_col2, $bfa_ata['h_blogtitle'], $bfa_ata['h_posttitle']) = bfa_get_options();
get_header(); 
extract($bfa_ata); 
?>
and delete line 99 which is
HTML Code:
<?php get_sidebar(); ?>
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #9  
Old Apr 25, 2012, 12:23 PM
LaneLester
 
76 posts · May 2010
North Georgia, NA
Quote:
Originally Posted by juggledad
You need to edit the two gallery templact files.
Thanks!

Strangely enough, that worked for gallery-template.php, but not for gallery-single-template.php. The latter still does not show the widget-containing sidebar.

I opened the file on the server to be sure the code got changed. I flushed the cache, and reloaded the page to be sure I was getting a fresh load.

I had to remove <?php get_sidebar(); ?> from both files to get rid of the junk.

Ata's custom footer settings are taking effect with both types of gallery pages.

Lane
  #10  
Old Apr 25, 2012, 01:51 PM
juggledad's Avatar
juggledad
 
21,945 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I just unzipped the plugin again and the gallery-single-template.php does NOT have the
HTML Code:
<?php get_sidebar(); ?>
in it. you must have added it at some point...
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #11  
Old Apr 25, 2012, 01:58 PM
LaneLester
 
76 posts · May 2010
North Georgia, NA
Quote:
Originally Posted by juggledad
I just unzipped the plugin again and the gallery-single-template.php does NOT have the
HTML Code:
<?php get_sidebar(); ?>
in it. you must have added it at some point...
That's also what I thought at first. It's up higher at line 65 in the file I downloaded.

Lane
  #12  
Old Apr 25, 2012, 02:08 PM
juggledad's Avatar
juggledad
 
21,945 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
ahh, I missed that one
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #13  
Old Apr 25, 2012, 02:45 PM
LaneLester
 
76 posts · May 2010
North Georgia, NA
I'm curious how you figured that replacing
Code:
<?php get_header(); ?>
with
Code:
<?php 
list($bfa_ata, $cols, $left_col, $left_col2, $right_col, $right_col2, $bfa_ata['h_blogtitle'], $bfa_ata['h_posttitle']) = bfa_get_options();
get_header(); 
extract($bfa_ata); 
?>
would solve the sidebar problem?

Any idea why the above fix works for gallery-template.php, but not for gallery-single-template.php?

Lane
  #14  
Old Apr 25, 2012, 07:24 PM
juggledad's Avatar
juggledad
 
21,945 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I'm just good how did I fugure it out, well I've been working with the theme for a couple years and did support for a long long time before that, I've looked at the code and I tried it.

what do you mean the gallery-single-template.php doesn't work, it works for me.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #15  
Old Apr 25, 2012, 07:55 PM
LaneLester
 
76 posts · May 2010
North Georgia, NA
Quote:
Originally Posted by juggledad
what do you mean the gallery-single-template.php doesn't work, it works for me.
I see the Text widget with Google ads at
http://www.birding4u.com/galleries/
but there's only an empty sidebar at
http://www.birding4u.com/galleries/gallery-3/
which is controlled by gallery-single-template.php, and there should be the same kind of ads.

Lane
  #16  
Old Apr 26, 2012, 04:25 AM
juggledad's Avatar
juggledad
 
21,945 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
you have caching turned on - you should always turn off caching while making changes to the siite so ou can see them right away.

please flush the cache and turn the plugin off.

Note: try setting your permalinks back to the default and see what happens.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Apr 26, 2012 at 05:38 AM.
  #17  
Old Apr 26, 2012, 06:48 AM
LaneLester
 
76 posts · May 2010
North Georgia, NA
Quote:
Originally Posted by juggledad
please flush the cache and turn the plugin off.

Note: try setting your permalinks back to the default and see what happens.
Cache disabled. Permalinks at default, although it would be bad if this were necessary.

http://www.birding4u.com/?gallery=gallery-3

Lane
  #18  
Old Apr 26, 2012, 06:55 AM
juggledad's Avatar
juggledad
 
21,945 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
And are you using the two templates with the changes added in? (the change in the header and the sidebar() line removed?)
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #19  
Old Apr 26, 2012, 07:28 AM
LaneLester
 
76 posts · May 2010
North Georgia, NA
Quote:
Originally Posted by juggledad
And are you using the two templates with the changes added in? (the change in the header and the sidebar() line removed?)
You bet! I've attached them (with a slight rename).

Lane
Attached Files
File Type: txt gallery-single-template.txt (3.8 KB, 188 views)
File Type: txt gallery-template.txt (3.8 KB, 199 views)
  #20  
Old Apr 26, 2012, 07:44 AM
juggledad's Avatar
juggledad
 
21,945 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
what version of Atahualpa?
it's working fine with 3.7.6 - try disabling ALL your plugins
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #21  
Old Apr 26, 2012, 08:49 AM
LaneLester
 
76 posts · May 2010
North Georgia, NA
Quote:
Originally Posted by juggledad
what version of Atahualpa?
it's working fine with 3.7.6 - try disabling ALL your plugins
My server is really slow right now, but they're finally disabled. My other sites are loading quickly, so something may be broken at Birding4U!

Oops! I wondered why the gallery pages didn't work. I guess I shouldn't disable that plugin! (Where's the "embarrassed" smiley?)

Well, the pages haven't reloaded yet, but I better send this off before the forum software logs me off!

Lane
  #22  
Old Apr 26, 2012, 09:06 AM
LaneLester
 
76 posts · May 2010
North Georgia, NA
For some reason, the gallery plugin keeps forgetting where the photos are that I uploaded. I'm now uploading them for the third time... and it's taking forever!

Good grief! The template changes are no longer in effect... Oh, I know what happened. When I disabled/enabled the plugin, it copied a fresh set of the default templates (which I haven't edited) to /atahualpa.

Now to go take care of that!

Lane

Last edited by LaneLester; Apr 26, 2012 at 09:21 AM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gallery plugin with slideshow/thumbnail navigation instead of lightbox bswb97 Plugins & Atahualpa 3 May 10, 2012 03:29 AM
Advice on an image gallery plugin Wimbledon Plugins & Atahualpa 0 Jul 24, 2011 02:03 PM
Best photo gallery plugin? (a crowdsourcing question) lhanft Atahualpa 3 Wordpress theme 7 May 11, 2011 06:12 AM
[SOLVED] Featured Gallery Plugin mattf Atahualpa 3 Wordpress theme 4 Jul 28, 2010 09:01 AM
3.4.4 bug (minor) - Ata's Body Title fields incorrect when actual title contains quot fencepost Atahualpa 3 Wordpress theme 0 Nov 22, 2009 08:27 PM


All times are GMT -6. The time now is 12:44 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.