Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

Header Images Fail to Rotate


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jun 6, 2009, 01:15 PM
Yarrokon's Avatar
Yarrokon
 
8 posts · Jun 2009
Surprise, AZ
Hello,

I've upgraded from 3.3.2 to 3.3.3 and my header images no longer rotate as they use to. I have around 30 images in the images/header/ folder and a click of any link would randomly display one of the new header images.

With the upgrade you can click a link, hit refresh, CTRL+refresh and you get the same image. I've tested in IE8 and Chrome and have no script errors. I blew away my Wordpress install and did a full new install and still the images do not rotate.

Please understand I am not looking to rotate my images every few seconds, but to randomly grab one of the 30 images I have with the click of any link like version 3.3.2 use to work.

Regards,
Yarrokon
  #2  
Old Jun 6, 2009, 01:43 PM
juggledad's Avatar
juggledad
 
22,269 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
when you did the upgrade. did you move the header images to the new versions image/header folder?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jun 6, 2009, 05:13 PM
Yarrokon's Avatar
Yarrokon
 
8 posts · Jun 2009
Surprise, AZ
Quote:
Originally Posted by juggledad
when you did the upgrade. did you move the header images to the new versions image/header folder?
juggledad,

Yes, the images were copied over to the new folder in the first install a few weeks ago, and then yesterday I did the fresh install and again uploaded the images to the below location. "\wp-content\themes\atahualpa333\images\header\"

It will mainly show one image, some times two images but will always go back to the first image that is loaded when the site comes up. I am using Wordpress v2.7.1 and Atahualpa 3.3.3 which I again downloaded today.

I've added some pages, and the images seem to rotate more but not as often as the previous version. I am wondering if this could be a CACHING issue? You use to be able to click the same link and get a new image just about every single time.

http://www.phxshared.com/

Again, thank you for your assistance!

Regards,
Yarrokon
  #4  
Old Jun 6, 2009, 06:04 PM
juggledad's Avatar
juggledad
 
22,269 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Do you have any caching plugin's installed? If so, disable them and see what happens.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jun 6, 2009, 07:40 PM
Yarrokon's Avatar
Yarrokon
 
8 posts · Jun 2009
Surprise, AZ
Quote:
Originally Posted by juggledad
Do you have any caching plugin's installed? If so, disable them and see what happens.
Nothing major yet as I have just about the default install pretty much.

Plugins installed are; Akismet, Contact Form 7, and Google Analytics for WordPress (Google Analytics Tracking Code is in header.php)

Are you seeing the same thing with the link that I've provided? For Internet Explorer I have my CACHE removed on exit of the application, set to 50mb and looking for new content set at "Every time I visit the webpage".

Regards,
Yarrokon
  #6  
Old Jun 7, 2009, 03:21 AM
juggledad's Avatar
juggledad
 
22,269 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Quote:
...and Google Analytics for WordPress (Google Analytics Tracking Code is in header.php
wait, did you modify header.php? If so, please restore the original and see if you still have a problem
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Jun 7, 2009, 09:15 AM
Yarrokon's Avatar
Yarrokon
 
8 posts · Jun 2009
Surprise, AZ
No, no change. I had tested before adding it and does exactly as it does now. The code that was added was a JavaScript right below the <body tag.

Regards,
Yarrokon
  #8  
Old Jun 7, 2009, 10:03 AM
juggledad's Avatar
juggledad
 
22,269 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
what version of PHP are you using? If you don't know how to find this out, install the 'WP Security Scan' plugin and it will list our system info
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Jun 7, 2009, 12:17 PM
Yarrokon's Avatar
Yarrokon
 
8 posts · Jun 2009
Surprise, AZ
Quote:
Originally Posted by juggledad
what version of PHP are you using? If you don't know how to find this out, install the 'WP Security Scan' plugin and it will list our system info
juggledad,

No problem, I own the server...

PHP v5.2.9, Zend Optimizer 3.3.0, MySQL 5.0.77, [PHP_BZ2], [PHP_CURL], [PHP_GD2], [PHP_MCRYPT], [PHP_MYSQL], [PHP_SOAP], [PHP_ZIP], [PHP_XMLRPC].

Regards,
Yarrokon
  #10  
Old Jun 8, 2009, 10:02 AM
juggledad's Avatar
juggledad
 
22,269 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Yarrokon
I've been playing with this and have recreated the issue - I think. My guess right now is that there is issue with the PHP function array_rand. In release 3.3.3, Flynn changed the way he was rotating the images, he started using array_rand().

If you get the continous image, tehn open a new page (even google) then go back to the page with the continous image and hit refersh again, you can get a new image - once - then it sticks again.

I've sent a note to Flynn about this.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Jun 8, 2009, 10:17 AM
Yarrokon's Avatar
Yarrokon
 
8 posts · Jun 2009
Surprise, AZ
Hum, I will have to review that section of code, didn't think it would be an issue within that area but again more of a caching issue.

Thank you for reporting it and if I find any other info, I will update this thread.

Bookmarks

Tags
3.3.2, 3.3.3, header image, rotation

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to get a header image to rotate every 'N' seconds juggledad Header configuration & styling 49 May 22, 2011 04:01 PM
Can Rotate Header and Resize Header work together? thetravelchronicle Forum How-To 10 Jun 24, 2009 07:24 PM
Pls help with - How to get a header image to rotate every 'N' seconds (sticky) HavaLyon Header configuration & styling 9 Apr 27, 2009 08:30 AM
header images PJK Header configuration & styling 1 Apr 11, 2009 05:53 PM
no header images kcd_2008 Header configuration & styling 1 Feb 17, 2009 06:16 PM


All times are GMT -6. The time now is 01:37 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.