Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Comments, trackbacks & pings »

[SOLVED] Can't translate comments


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Dec 20, 2011, 11:08 AM
Danielwerner's Avatar
Danielwerner
 
83 posts · Jul 2009
Hello,

I have the exact same issue as in thread http://forum.bytesforall.com/showthread.php?t=15839 (though that thread is closed).

I've done all the steps, such as downloaded the atahualpa.pot file, translated it, and then uploaded it in my atahualpa-folder. Everything is still in english. I tried translating it directly in the comments.php-file, and it STILL is left untranslated.

Downloaded a fresh comments.php, no dice. This seems to have stopped working with either the latest Atahualpa version or the latest Wordpress version (I updated them both at the same time).

Am I missing something?

I am using Atahualpa 3.7.3.
__________________
http://blogg.danielwerner.se/
  #2  
Old Dec 20, 2011, 11:26 AM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Do you have the wp-config.php language option set?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #3  
Old Dec 20, 2011, 11:30 AM
Danielwerner's Avatar
Danielwerner
 
83 posts · Jul 2009
Yep, my entire blog is in swedish (including the dashboard), EXCEPT the comments.
__________________
http://blogg.danielwerner.se/
  #4  
Old Dec 20, 2011, 11:42 AM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
do you mean teh literal 'comments' or the actual comments people enter? (just want to make sure we are talking about the same thing) - the comments people enter will never be translated
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #5  
Old Dec 21, 2011, 10:57 AM
Danielwerner's Avatar
Danielwerner
 
83 posts · Jul 2009
No, I mean the comment section which is generated by wordpress/atahualpa. Not the actual comments ofcourse.

Such as:

Leave a Reply
Name
Email
Website
Post comment

etc.
__________________
http://blogg.danielwerner.se/
  #6  
Old Dec 21, 2011, 11:06 AM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
can you attach the po file you are using?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #7  
Old Dec 21, 2011, 11:36 AM
Danielwerner's Avatar
Danielwerner
 
83 posts · Jul 2009
Surelydiddely! I added both the atahualpa one and the wordpress one. Though I wasn't allowed to upload them as attachments, hopefully you can download them here:

http://www.2shared.com/file/UG2q9Nm_/atahualpa.html
http://www.2shared.com/file/10dss7C0/sv_SE.html

Thanks.
__________________
http://blogg.danielwerner.se/
  #8  
Old Dec 22, 2011, 04:17 AM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
ok, in the po you have
HTML Code:
#: comments-paged.php:25
#: comments.php:26
#: legacy.comments.php:23
msgid "Ingen har kommenterat "
msgstr ""
and it should be
HTML Code:
#: comments-paged.php:25
#: comments.php:26
#: legacy.comments.php:23
msgid "No comments yet to "
msgstr "Ingen har kommenterat "
The 'msgid' is the text TO BE translated and the 'msgstr' is the TRANSLATED text
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #9  
Old Dec 22, 2011, 01:21 PM
Danielwerner's Avatar
Danielwerner
 
83 posts · Jul 2009
Thanks! I had it wrong there. I corrected everything, saved it, uploaded and overwrote the old atahualpa.pot in the themes/atahualpa-folder. It STILL doesn't work though. I'm not sure what I'm missing.

Now it looks like this in the .pot:

#: comments-paged.php:164
#: comments.php:124
#: legacy.comments.php:149
msgid "Leave a Reply"
msgstr "Kommentera"

Just in case, I downloaded a fresh comments.php and overwrote that too. No dice. I also refreshed my cache for my browser and for wordpress.
__________________
http://blogg.danielwerner.se/
  #10  
Old Dec 23, 2011, 05:28 AM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
can you send me your latest po and mo files?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #11  
Old Dec 23, 2011, 11:07 AM
Danielwerner's Avatar
Danielwerner
 
83 posts · Jul 2009
Absolutely. Here are the latest files as they are now:

atahualpa.mo http://www.2shared.com/file/hQMqQDCA/atahualpa.html
atahualpa.pot http://www.2shared.com/file/sOfZAfvw/atahualpa.html
sv_SE.po (for wordpress itself) http://www.2shared.com/file/n45WEIuN/sv_SE.html

Thanks!
__________________
http://blogg.danielwerner.se/
  #12  
Old Dec 24, 2011, 04:59 AM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
The '.mo' file inthe atahualpa folder should be called 'sv_SE.mo' - sorry it took so long to spot this.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #13  
Old Dec 24, 2011, 01:54 PM
Danielwerner's Avatar
Danielwerner
 
83 posts · Jul 2009
Hmm, I must be cursed or something. It still doesn't work! Do I need to do anything in my code or settings for this?

I renamed the atahualpa.mo to sv_SE.mo, so now I have sv_SE.mo and atahualpa.pot in the atahualpa-folder. As usual, I refreshed the cache in my browser and in wordpress.

Merry christmas btw.
__________________
http://blogg.danielwerner.se/
  #14  
Old Dec 24, 2011, 02:56 PM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
You do the language picked in wp-configuration.php right?

Off the air till Monday - merry christmas
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #15  
Old Dec 24, 2011, 03:24 PM
Danielwerner's Avatar
Danielwerner
 
83 posts · Jul 2009
Hmm, not sure what you mean by that. But if you're referring to wp-config.php in my wordpress-folder, yes, both are sv_SE there. For wordpress, everything works, and is translated into swedish. But for the atahualpa part, nothing translation-wise is working.

Dunno what fundamental setting I'm missing here.
__________________
http://blogg.danielwerner.se/
  #16  
Old Dec 26, 2011, 05:31 AM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
This is odd
- I took the sv_SE.mo you sent and put it in wp-content/languages
- took the atahualpa.mo renamed it to sv_SE.mo and put it in the wp-content/themes/atahualpa folder
set "define ('WPLANG', 'sv_SE');" in wp-config
Now when I do to my site this is what I see on the comments
Click image for larger version

Name:	screenShot.png
Views:	348
Size:	16.3 KB
ID:	1695
if you would like I'll poke around in your site - send me a PM with an admin id/pw
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #17  
Old Dec 26, 2011, 01:52 PM
Danielwerner's Avatar
Danielwerner
 
83 posts · Jul 2009
That's really odd... Either it's something I've missed in the configuration, or otherwise there must be something really weird with my entire installation.

Anyway, I sent you my login details.
__________________
http://blogg.danielwerner.se/
  #18  
Old Dec 26, 2011, 07:07 PM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Ok, this is weird. Just for chuckler please try this se_SV.mo - it is the one you sent me and it is working, just want to make sure there wasne a duplicate mo hanging arround
sv_SE.mo.zip
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #19  
Old Dec 27, 2011, 11:10 AM
Danielwerner's Avatar
Danielwerner
 
83 posts · Jul 2009
Nope, still nothing.

I downloaded that .mo and changed to it. Nothing.

I downloaded a fresh copy of Atahualpa, changed only the most noticeable phrases, switched to the new theme, deleted cache as usual, and it STILL doesn't work.

Then I copied the .mo and .pot and put it in a fresh copy of Atahualpa and put THAT in a test-account I have on my server (http://testblogg.danielwerner.se). To be sure, I reset all theme options to default (via the button in the atahualpa settings). And it still doesn't work.

So, there shouldn't be something wrong with my settings at least. And my .mo and .po for the Wordpress-installation should be fine too since those phrases don't affect comments.

Juggledad, could you please attach the .mo and .po which you used on your test-site when it showed swedish (as your printscreen showed)? And also exactly where you put them. And if you did anything else. Just to make sure I don't miss anything trivial here.

Thanks,
__________________
http://blogg.danielwerner.se/
  #20  
Old Dec 27, 2011, 11:37 AM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I don't have a .po since you never sent one and tne .mo is the one you sent me that I sent back.
let me take another look at the site...
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #21  
Old Dec 29, 2011, 07:11 AM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
The problem was with the .mo, there were two of them one right, one wrong. Once they used the 'correct' one the translations are working.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Translate comments? Danielwerner Atahualpa 3 Wordpress theme 2 Dec 11, 2011 07:41 AM
How to translate? jjforums Languages & Translations 0 Sep 30, 2010 10:32 AM
Is there any norwegian translate of ata 3.44? MrStark Languages & Translations 0 Jan 2, 2010 03:54 AM
Translate only the Comments nfdieter Comments, trackbacks & pings 0 Oct 31, 2009 10:31 AM
There i can translate Algiz Languages & Translations 2 Oct 28, 2009 12:10 PM


All times are GMT -6. The time now is 06:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.