Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Languages & Translations »

New POT file as of version 3.7.3


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Dec 8, 2011, 06:21 AM
juggledad's Avatar
juggledad
 
22,269 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Here is an updated POT file as of 3.7.3

removed - updated 12/8/11 8:27 EST fixed some errors
atahualpa373pot.zip - updated 12/24/11 13:54 EST - see post #5 for changes
you will need to make one code change to get a translation of Name' to work in the comment form.
see: PATCH 373-01: Fix issue where one word is not translated
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Dec 24, 2011 at 11:53 AM.
  #2  
Old Dec 12, 2011, 02:17 PM
l4xmfy
 
3 posts · Dec 2011
Hi Juggledad,

I am not an expert on translations, I was actually doing a translation for the first time by help of PoEdit.
However starting with your file was leaving some of the strings untranslated.

So I scanned the sources myself and I started with attached file - maybe you could verify this and let me know if I misunderstood anything?

KR,
Sven
Attached Files
File Type: zip default.zip (2.3 KB, 310 views)
  #3  
Old Dec 12, 2011, 02:54 PM
juggledad's Avatar
juggledad
 
22,269 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
What strings were not translated. I am also not a poedit expert as a matter of fact I hand built the version I posted.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Dec 13, 2011, 01:41 AM
l4xmfy
 
3 posts · Dec 2011
Hi juggledad,

e.g. the "Submit Post" button in the comment form or the "Logged in as [...] Logout >>".
The file I posted I had PoEdit autodetect from the PHP sources (using "__" and "_e" as markers).

For my German translation I merged this with an older translation I found and just translated the gap (~20 strings maybe).

KR,
Sven
  #5  
Old Dec 24, 2011, 11:51 AM
juggledad's Avatar
juggledad
 
22,269 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Ok I found two errors - (like I said, I made this manually) -

line 104 - 107 are
#: comments.php:86
#, php-format
msgid "You must be <a href='%s'>logged in</a> to post a comment."
msgstr ""
but it should be
HTML Code:
#: comments.php:86
#, php-format
msgid "You must be <a href=\"%s\">logged in</a> to post a comment."
msgstr ""
line 115 - 118 are
HTML Code:
#: comments.php:118
#, php-format
msgid "Logged in as <a href='%1$s'>%2$s</a>. <a href='%3$s' title='Log out of this account'>Log out?</a>"
msgstr ""
but should be
HTML Code:
#: comments.php:118
#, php-format
msgid "Logged in as <a href=\"%1$s\">%2$s</a>. <a href=\"%3$s\" title=\"Log out of this account\">Log out?</a>"
msgstr ""
Both of these change a single quote to a backslash double quote
Attached Files
File Type: zip atahualpa373pot.zip (2.6 KB, 334 views)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Dec 24, 2011 at 11:53 AM.
  #6  
Old Dec 30, 2011, 10:53 PM
lusinda
 
8 posts · Apr 2011
Thank you, juggledad!
  #7  
Old Jan 23, 2012, 06:52 AM
merlin
 
1 posts · Jan 2012
Hi!
I found two occurrence that don't translated.
It's the phrase "Permanent link to" in /function/bfa_post_parts.php at lines 39 and 71.

P. S. Thank you for the great theme for Wordpress.
  #8  
Old Jan 23, 2012, 10:38 AM
juggledad's Avatar
juggledad
 
22,269 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
merlin - thanks for the find...but you missed one at line 63

See PATCH 373-04: Fix missing translation in bfa_post_parts.php for the fix
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't import a settings file for 3.6.4. (file from another site running 3.6.4) Foodie With Family New Versions, & Updating 6 Mar 21, 2011 08:51 AM
[SOLVED] Importing Atahualpa settings file, file not valid Neut New Versions, & Updating 12 Feb 1, 2011 07:35 AM
I can't see the new version in the site when I install a higher version than 3.4.6 Cael Varaferro Atahualpa 3 Wordpress theme 1 Jan 6, 2011 01:49 PM
[SOLVED] Ata version 3.5.3 (bfa_ata4) compatability issue with php version php 5.2.12 bettykin Atahualpa 3 Wordpress theme 4 Dec 6, 2010 10:53 AM
[SOLVED] Can't upload the latest version to my Dashboard because I have older version rhymes New Versions, & Updating 2 Apr 25, 2009 10:22 PM


All times are GMT -6. The time now is 10:48 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.