Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

styling text widgets in footer


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Nov 15, 2011, 05:50 AM
DesignFlute
 
27 posts · Apr 2009
Mumbai, India
I have wp 3.2.1
and just upgraded Ata from 3.6.4 to 3.7. 1

I have created a widget area with 5 cells and each cells have 2/3 text widgets in the footer. I had applied top bottom padding (css inserts) to these text widgets which worked perfectly in version 3.6.4. But after upgrading this is lost.
I tried many combinations (with the help of firebug) but nothing seems to work. on my test site here too it is not working. feeling so stupid. Please help.
  #2  
Old Nov 15, 2011, 06:01 AM
juggledad's Avatar
juggledad
 
22,244 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
what is the exact code you used to create the widget area?

go to ATO->export/import settings and export your settings and attach them to a reply
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Nov 15, 2011, 06:12 AM
DesignFlute
 
27 posts · Apr 2009
Mumbai, India
here is the exact code
<?php bfa_widget_area('name=ft&cells=5&align=8&align_2=1 &align_3=7&align_4=2&align_5=3&before_widget=<d iv id="%1$s" class="header-widget %2$s">&after_widget=</div>'); ?> (copied from ata options)

and otherwise in the attachment the way you want.
Thanks
Attached Files
File Type: txt ata-tpdesign-flutecom-20111115.txt (15.1 KB, 262 views)
  #4  
Old Nov 15, 2011, 06:33 AM
juggledad's Avatar
juggledad
 
22,244 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
something weird is happening at your site. When I look at the footer I see
HTML Code:
<td id="footer" colspan="3">
    <p>
    <table id="ft" class="bfa_widget_area" style="table-layout:fixed;width:100%" cellpadding="0" cellspacing="0" border="0"><tr>
<td id="ft_1" align="left" valign="middle"></td>
<td id="ft_2" align="center" valign="middle"></td>
<td id="ft_3" align="left" valign="bottom"></td>
<td id="ft_4" align="center" valign="top">
   <div id=\"meta-5\" class=\"header-widget widget_meta\">
     <div class="widget-title"><h3>Meta</h3></div>			
       <ul>
	<li><a href="http://tp.design-flute.com/wp-login.php">Log in</a></li>
        <li><a href="http://tp.design-flute.com/?feed=rss2" title="Syndicate this site using RSS 2.0">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
	<li><a href="http://tp.design-flute.com/?feed=comments-rss2" title="The latest comments to all posts in RSS">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
	<li><a href="http://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>
		</ul>
</div><div id=\"text-12\" class=\"header-widget widget_text\">			<div class="textwidget">passing</div>
		</div><div id=\"text-11\" class=\"header-widget widget_text\">			<div class="textwidget">charming</div>
		</div>
</td>
<td id="ft_5" align="right" valign="top">
</td>
</tr></table>

Copyright &copy; 2011 <a href="http://tp.design-flute.com/">Test Prayog</a> - All Rights Reserved<br />Powered by <a href="http://wordpress.org/">WordPress</a> &amp; <a href="http://forum.bytesforall.com/">Atahualpa</a>    </p>
    
    
    </td>
notice the lines with the backslash (\)? that shouldn't be there

Try this, deactivate all your plugins and see if things start working them.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Nov 15, 2011, 06:49 AM
DesignFlute
 
27 posts · Apr 2009
Mumbai, India
OMG.
but there was only one plugin and only active (jetpack) that i deactivated immediately. Nothing happened.
But saw a drop-in (install.php) which I know I had not put. (immediately logged on to my cpanel and deleted that drop-in).
worried more now.
I saw the slashes but thought may be it in in upgrade?!!

Going to check my main site's footer
  #6  
Old Nov 15, 2011, 07:27 AM
juggledad's Avatar
juggledad
 
22,244 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
if you want me to take a look, send me a PM with an admin ID/pw and I'll peek
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Nov 15, 2011, 07:41 AM
DesignFlute
 
27 posts · Apr 2009
Mumbai, India
Oh this means a lot to me! Thankx.

I just checked on my main site these weird slashes are there too. Am at the moment deactivating plugins and checking. If prob not solved will get back to you. (probably tomorrow)
  #8  
Old Nov 15, 2011, 07:42 AM
DesignFlute
 
27 posts · Apr 2009
Mumbai, India
entered twice so removed this post.

Last edited by DesignFlute; Nov 15, 2011 at 08:35 AM. Reason: duplicate
  #9  
Old Nov 15, 2011, 08:43 AM
DesignFlute
 
27 posts · Apr 2009
Mumbai, India
It works perfectly in 3.6.4 but not in 3. 6.9 Ata Version.

the funny thing is I have put another widget with simplest Code in the footer:

<?php bfa_widget_area('name=My new widget area'); ?>
(without cells)
then it works and is without weird slashes
  #10  
Old Apr 14, 2012, 12:49 PM
juggledad's Avatar
juggledad
 
22,244 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
the backslash's in the code are caused by the PHP option 'magic_quotes_gpc' being set to 'on'.
you need to edit the php.ini and add
HTML Code:
magic_quotes_gpc = off
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Tags
padding, styling, text widget

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Styling Widgets JonRouston Sidebars & Widgets 4 Feb 25, 2011 02:34 AM
[SOLVED] Styling text widgets unelma Sidebars & Widgets 6 Oct 28, 2009 03:32 PM
BUGFIX 342: Can't change text font, in text widgets Leoni Old Version fixes and change logs 3 Aug 5, 2009 04:30 AM
[SOLVED] Styling text widgets Insane Artist Sidebars & Widgets 2 Jul 17, 2009 06:36 PM


All times are GMT -6. The time now is 09:10 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.