Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

<!--nextpage--> problems


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jun 9, 2011, 04:33 PM
epsymp
 
37 posts · Jul 2010
Hi.

I'd appreciate if someone could help me with two problems I'm having.

The first is that I'm unable to link to pages following the first page.
The default link works at the bottom, but I want one to work at the top as well.
What happens is the page # gets dropped in the link, somehow.
So if I type toadthejournal.com/dan-bern/3 into the url, the page I want will come up.
But if I tag the link (is that the right phrasing?) it just comes up as toadthejournal.com/dan-bern.

I also messed around a little with the bfa_post_parts.php and managed to add "Page %" so it says page before the number, so it's a bit easier to hit the link with the mouse. However, I can't figure out how to get the "Pages:" that comes before to be gone with.

Thanks again.
  #2  
Old Jun 9, 2011, 04:36 PM
epsymp
 
37 posts · Jul 2010
i love how answers come to me after posting...

I realized that because this post has a parent, something automatically adds the parent page as part of the page address whenever a link is clicked.

so...somewhere in that process the page number that i want to open gets dropped.

is there a solution to that?
  #3  
Old Jun 9, 2011, 04:37 PM
epsymp
 
37 posts · Jul 2010
just to clarify...

if i click on the link that's written as: toadthejournal.com/dan-bern/3

what comes up is: toadthejournal.com/issue-12/dan-bern.
  #4  
Old Jun 9, 2011, 04:38 PM
epsymp
 
37 posts · Jul 2010
in case it helps, my permalink settings are custom: /%postname%/
  #5  
Old Jun 9, 2011, 04:45 PM
epsymp
 
37 posts · Jul 2010
Ok, so to fix THAT problem I just changed the link to include the parent name and then the page number didn't get dropped.

Any idea for problem number 2?
Here's what it looks like:
Pages: Page 1 Page 2 Page 3



And here's what I currently have for some code that might relate:
(I deleted the "Pages:" that used to come after <strong> in the first line, but that didn't do the trick.)

function bfa_post_pagination($before = '<p class="post-pagination"><strong>', $after = '</strong></p>') {

global $bfa_ata;

if ( (is_home() AND $bfa_ata['excerpts_home'] == "Full Posts") OR
(is_category() AND $bfa_ata['excerpts_category'] == "Full Posts") OR
(is_date() AND $bfa_ata['excerpts_archive'] == "Full Posts") OR
(is_tag() AND $bfa_ata['excerpts_tag'] == "Full Posts") OR
(is_search() AND $bfa_ata['excerpts_search'] == "Full Posts") OR
(is_author() AND $bfa_ata['excerpts_author'] == "Full Posts") OR
is_single() OR is_page() ) {
wp_link_pages('pagelink=Page %');
}

}

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
3.6.1 problems Sangennaru New Versions, & Updating 5 Feb 4, 2011 09:29 AM
Help please, weird problems ... Tesha Header configuration & styling 9 May 18, 2010 06:26 AM
Read more link right next to body text on each page when using nextpage? Jozefs Center area post/pages 7 Jan 5, 2010 07:30 AM
Problems with Cyrillic Clement Languages & Translations 4 Jun 30, 2009 03:48 AM
Sociable, NextPage, and Post/Page Info Items ... A Thank You. fromtheranks Plugins & Atahualpa 0 Jun 26, 2009 09:40 PM


All times are GMT -6. The time now is 10:31 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.