Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating » Old Version fixes and change logs »

Atahualpa 3.6.7 released (was 3.6.6)


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old May 11, 2011, 09:54 AM
Flynn's Avatar
Flynn
 
3,765 posts · Oct 2008
Munich, Germany
UPDATE: Atahualpa 3.6.7 with working custom widget areas, everything up to post #7 taken care of

Download Atahualpa 3.6.7 here


Because the requirements for themes listed at wordpress.org have been restricted, the ability to add custom PHP code through the Atahualpa Theme Options had to be removed.

If you have custom PHP code somewhere in the theme options the code will be printed now instead of being executed (Edit: Except for <?php bfa_widget_area('....'); ?> which will be executed. ).
The theme options "Content above LOOP", "Loop", "Content below LOOP", "Content if NOT FOUND" are gone now, to edit the Loop or to add code before/after the loop, you'd have to manually edit Atahualpa's index.php now.

3.6.6 also contains all of Juggledad's 364-XX bugfixes

3.6.6 has been successfully checked with WP_DEBUG TRUE, and with the Theme Check plugin.

EDIT: As pointed out by Juggledad, existing custom widget areas will not work in 3.6.6 because they ARE dynamic PHP, at least if you add their code (<?php bfa_widget_area(...); ?>) through one of the Atahualpa Theme Option text areas.

3.6.7 with a fix for custom widget areas is coming later today. If you don't have any custom widget areas, 3.6.6 should work for you.

Last edited by juggledad; Feb 20, 2012 at 08:16 AM.
  #2  
Old May 11, 2011, 12:37 PM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Quote:
If you have custom PHP code somewhere in the theme options the code will be printed now instead of being executed.
Note, this means if you look at the source of the page you will see the code. It will probably not show when viewing the page since it is not valid HTML

Also, If you had a new widget area, these will no longer work.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old May 11, 2011, 12:59 PM
Flynn's Avatar
Flynn
 
3,765 posts · Oct 2008
Munich, Germany
I'll release a new version later today with a fix for the widget areas

Custom widget areas can work again although it is dynamic PHP, because it is only 1 predictable piece of PHP, which can be replaced with the actual output of bfa_widget_area(), with preg_replace

Similar to how the postinfo items work
  #4  
Old May 11, 2011, 03:04 PM
mdmower's Avatar
mdmower
 
71 posts · Jul 2010
Missouri, USA
When I wrote the fix for RFE: allow selectable document mode for IE, I used php echo, so I had to escape double quotation marks. Since you prefer to kill php with ?> to pass html commands, shouldn't these escaped quotation marks be removed?

Example: header.php, line 14 (and others)
Code:
?><meta http-equiv=\"X-UA-Compatible\" content=\"IE=EmulateIE7\"/>
should read
Code:
?><meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7"/>
  #5  
Old May 11, 2011, 04:56 PM
vincent
 
64 posts · Nov 2010
Do any of the changes offer speed improvements?
thanks,

- Vincent
  #6  
Old May 11, 2011, 06:36 PM
Flynn's Avatar
Flynn
 
3,765 posts · Oct 2008
Munich, Germany
Quote:
Originally Posted by mdmower
When I wrote the fix for RFE: allow selectable document mode for IE, I used php echo, so I had to escape double quotation marks. Since you prefer to kill php with ?> to pass html commands, shouldn't these escaped quotation marks be removed?

Example: header.php, line 14 (and others)
Code:
?><meta http-equiv=\"X-UA-Compatible\" content=\"IE=EmulateIE7\"/>
should read
Code:
?><meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7"/>
You're right, thanks

Added to 3.6.7 which I hope to release in an hour or two
  #7  
Old May 12, 2011, 01:34 PM
mdmower's Avatar
mdmower
 
71 posts · Jul 2010
Missouri, USA
3.6.7 very minor details:
In theme options, start page still says "New in 3.6.6:"
Green update notice still appears "Atahualpa - version 3.6.6 available. Have a look"
Readme.txt file lists "3.6.5"

Last edited by mdmower; May 12, 2011 at 01:39 PM.
  #8  
Old May 12, 2011, 01:36 PM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
BUGFIX - see http://forum.bytesforall.com/showpos...94&postcount=4
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old May 12, 2011, 07:07 PM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Please open new threads to report problems with 3.6.7

I've move the several issues to separate threads to make it easier to track the issues.

Closing this thread.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atahualpa 3.6.1 released Flynn Old Version fixes and change logs 33 Jul 13, 2012 08:38 PM
Atahualpa 3.5.3 released Flynn Old Version fixes and change logs 93 Sep 25, 2010 03:14 PM
Atahualpa 3.5.0 released Flynn Old Version fixes and change logs 14 May 27, 2010 04:51 PM
Atahualpa 3.4.9 released Flynn Old Version fixes and change logs 51 May 12, 2010 10:37 AM
Atahualpa 3.4.8 released Flynn Old Version fixes and change logs 25 May 10, 2010 03:56 PM


All times are GMT -6. The time now is 12:58 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.