Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

Permalink for posts without title


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jan 21, 2011, 04:06 AM
Wyro
 
21 posts · Jul 2009
RE: ATA Ver. 3.6.1 Change: * Permalink for posts without title: Instead of the title the word 'Permalink' is displayed and linked to the full post.

QUESTION: Can you please tell me if there is a way to disable the new 3.6.1 feature where "Permalink" shows when a post does not have a title? I want nothing to show, and no vertical space left in it's place, like before.

Thanks guys!
  #2  
Old Jan 21, 2011, 11:17 AM
lmilesw's Avatar
lmilesw
 
10,113 posts · Jul 2009
Central New York State USA
Go to ATO>Configure SEO and turn on Post/Page Options. You will then have a box in each post to not show the title.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Jan 21, 2011, 07:08 PM
Wyro
 
21 posts · Jul 2009
Thanks but that did not work.

Here's my thing: I want to eliminate the (blank 'Permalink') title on my top article (it's a sticky) in my loop. The options in ATA SEO Post/Page Options seem to control showing/not showing the title on Single Post or Static Page titles only.

What I want is to have a post that's on my homepage as a sticky (which contains a slider) and I don't want the blank title to show as 'Permalink' (see attached "361wrong.jpg"). I want nothing to show. It worked that way in 3.5.3 and 3.5.1 without having to mess with any setting. I just have nothing in the title field in the post, and that space disappears (see attached "353right.jpg").

I would wire up the slider some other way if I could - but can't figure out how to get it on the top of the middle column on (important) the first page of the loop only.

Perhaps if you can't offer a solution to blank out the 'Permalink' on my post without a title, you could suggest how I could wire up the PHP for my slider (I know the code) so that it only shows on loop page 1 -- that would also solve me.

Help? Thank you!!!
Attached Thumbnails
Click image for larger version

Name:	353right.jpg
Views:	423
Size:	146.1 KB
ID:	1062  Click image for larger version

Name:	361wrong.jpg
Views:	396
Size:	146.1 KB
ID:	1063  
  #4  
Old Jan 21, 2011, 08:47 PM
lmilesw's Avatar
lmilesw
 
10,113 posts · Jul 2009
Central New York State USA
Along with having the "Check to NOT display the Body Title on Single Post or Static Pages" box checked and make sure you have a title entered for the page or post.
If the title is left blank the Permalink will be seen.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Jan 21, 2011, 08:51 PM
Wyro
 
21 posts · Jul 2009
Larry thanks -- no dice. It does in fact perform the suppress when you click through to the post, but it still shows the title of that post in the loop, even after chacking "NOT to display" and entering a title.

Other ideas? Thank you so much...

Steve
  #6  
Old Jan 21, 2011, 09:07 PM
lmilesw's Avatar
lmilesw
 
10,113 posts · Jul 2009
Central New York State USA
I suspect if you set the boxes in ATO>Configure Excerpts to "Full Posts" the title will not show. Alternatively you could use the following in ATO>Add HTML/CSS Inserts>CSS Inserts but it will not show the title on any post.
HTML Code:
.post-headline {
 display: none;
}
If you only want the title not to show on certain posts you would have to add the page id to that selector as in the example below which would hide post titles on the home page.
HTML Code:
body.home .post-headline {
display: none;
}
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #7  
Old Feb 4, 2011, 06:29 PM
Tollota
 
2 posts · Dec 2010
Catalunya
Hi Wyro,
Try to do this....
In the folder "functions" open and edit the file "bfa_post_parts.php".
It can also be done from the edit item of theme options menu in Wordpress.
Lines 44 and 45 shows the following:

Code:
	// Since 3.6.1: Display a link to the full post if there is no post title and the post is too short
	// for a read more link.
	if ( get_the_title() == '' ) { ?>
		<a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link">Permalink</a><?php 
		
	} else if ( (!is_single() AND !is_page()) OR $bfa_ata_display_body_title == '' ) {
Modify the end of line 44 ("?>") joining to the begining of line 45 and "comment" the entire line 45 EXACTLY as below !!! :

Code:
	// Since 3.6.1: Display a link to the full post if there is no post title and the post is too short
	// for a read more link.
	if ( get_the_title() == '' ) {
		/* ?><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link">Permalink</a><?php */
		
	} else if ( (!is_single() AND !is_page()) OR $bfa_ata_display_body_title == '' ) {
Is VERY IMPORTANT to open and close the comment with "/*" and "*/" as shown !!!
Save the changes.
That disables completely the function of add the word "Permalink" for posts without title.
For undo the change, simply edit again and delete the "comment" marks "/*" and "*/".
Like as you, I have in my homepage a static page with no title.
Hope this is useful to you as it is for me!

Best Regards,
Gabriel

Last edited by Tollota; Feb 5, 2011 at 02:58 AM.
  #8  
Old Feb 21, 2011, 04:52 PM
juggledad's Avatar
juggledad
 
22,382 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
see BUGFIX 364-05: No link to the full post shown on excerpt when post has no title
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Feb 21, 2011, 05:38 PM
Wyro
 
21 posts · Jul 2009
Thank you Juggledad!
  #10  
Old Sep 20, 2011, 04:24 PM
apienovi
 
25 posts · Sep 2011
What can I do to fix this issue with 3.6.7? WP 3.2.1

Last edited by apienovi; Sep 20, 2011 at 04:29 PM.
  #11  
Old Sep 20, 2011, 04:52 PM
lmilesw's Avatar
lmilesw
 
10,113 posts · Jul 2009
Central New York State USA
The first thing to do with 3.6.7 is to apply ALL the patches.
  • PATCH 367-01: Odd effects when 'CSS: Compress' = 'Yes'
  • PATCH 367-02 is incorporated in PATCH 367-04
  • PATCH 367-03: PHP errors when adding widget areas in index.php
  • PATCH 367-04: Hovering over a Post/Page title only shows "Permanent Link to"
  • PATCH 367-05: Site Title appended after the 'WordPress SEO by Yoast' title
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #12  
Old Sep 20, 2011, 05:49 PM
juggledad's Avatar
juggledad
 
22,382 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
are you having a problem?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #13  
Old Jan 6, 2012, 12:21 PM
GA Anderson
 
2 posts · Jan 2012
To Tollota

Great help for a new comer. I posted a similar problem and then found this solution, it worked, thanks but....

the "permalink" is gone, but there is still 50-70px of blank white space. is it possible to remove this and move the center content closer to the bottom of the page header?

GA
  #14  
Old Jan 6, 2012, 01:06 PM
lmilesw's Avatar
lmilesw
 
10,113 posts · Jul 2009
Central New York State USA
Check to make sure there is not code in that post at the top that is causing the space. Or perhaps there is a plugin that is adding code to the top. To test that you can temporarily deactivate all plugins to see if the problem goes away.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Permalink Problem--Home Becomes Nonexistent NotHannah Atahualpa 3 Wordpress theme 1 Dec 6, 2010 01:21 PM
Post Disappears in Permalink & Another Question angievinez Center area post/pages 3 Jun 25, 2010 10:46 PM
BFA Popular Posts widget linking to the same permalink over and over daniel3ub Sidebars & Widgets 3 Mar 23, 2010 05:40 AM
How to Use Image to Point to Permalink of the Post Page justprettygirl Atahualpa 3 Wordpress theme 6 Jan 26, 2010 11:19 PM
Paged comments in Permalink Matthuffy Comments, trackbacks & pings 2 Jul 3, 2009 10:17 PM


All times are GMT -6. The time now is 07:33 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.