Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

Error on posts page after upgrading to 3.6


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jan 8, 2011, 11:31 PM
rjh4242
 
5 posts · May 2010
Just upgraded from 3.5.3 to 3.6. Static pages are fine, but my blog (posts) page shows just the following error:
Fatal error: Cannot redeclare bfa_get_options() (previously declared in C:\xampp\htdocs\Rogo\httpdocs\wp-content\themes\atahualpa\functions\bfa_get_options .php:2) in C:\xampp\htdocs\Rogo\httpdocs\wp-content\themes\atahualpa\functions\bfa_get_options .php on line 512

As you can see at the moment I'm setting the site up on my own computer ready to upgrade on the server. It was working perfectly before the upgrade.

Any suggestions?

NB I have already applied the changes mentioned in the forum post for 3.6.
  #2  
Old Jan 9, 2011, 03:38 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
hold off on using 3.6 for the moment. you can manual install 3.5.3 (http://forum.bytesforall.com/showthread.php?t=8520) and activate it (having it in a folder called atahualpa353) and have 36 installed at the same time. Just switchback to 3.5.3 till the issue with 3.6 is figured out.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 10, 2011, 05:28 PM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Try 3.6.1 - http://forum.bytesforall.com/showthread.php?t=12150
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Jan 10, 2011, 11:04 PM
Pietz
 
5 posts · Jan 2011
After the install of version 3.6.1 I'm still getting a white page with a error message instead the weblog.
This is the error message: PHP has encountered an Access Violation at 0151A75D

The url is http://piet.zijtveld.com

I'm using WP 3.04
  #5  
Old Jan 11, 2011, 03:41 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
where are you seeing the access violation? Are there any more error messages?
what type of server are you running on (if you know)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Jan 11, 2011, 12:55 PM
Pietz
 
5 posts · Jan 2011
Hello,

I get the error message right after thus piece of code:
<!--[if IE 6]>

<script type="text/javascript">DD_roundies.addRule("a.posts-icon, a.comments-icon, a.email-icon, img.logo");</script>

<![endif]-->
If I emtpy the IE6 options on the Configure CSS & JS page, I don't get the error message, but the code stops right after </header> and the page stays white.

The server is running on Microsoft-IIS/6.0.
  #7  
Old Jan 11, 2011, 01:19 PM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
What I wondered is if the message shows on the screen or did you find it in a log. I'm looking to see if there is more info in the log
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Jan 11, 2011, 01:35 PM
Pietz
 
5 posts · Jan 2011
The message shows on the screen and in the source file
  #9  
Old Jan 11, 2011, 03:41 PM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Can you check your sites error log and see if there is anything more?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old Jan 11, 2011, 11:18 PM
Pietz
 
5 posts · Jan 2011
The error log didn't help ,e.
But when I use the extended option for CSS and JS and open the site in Firefox, view the source and click on href="http://piet.zijtveld.com/?bfa_ata_file=css", the file starts with the access violation.
  #11  
Old Jan 12, 2011, 04:53 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
we are looking at the possible cause of this - do you know if your php installation has suhosin? If you don't know what this means, don't worry, roll back to 353 for now and watch the forums for an announcement.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #12  
Old Jan 12, 2011, 07:14 AM
peterould
 
3 posts · Jan 2011
Quote:
Originally Posted by juggledad
we are looking at the possible cause of this - do you know if your php installation has suhosin? If you don't know what this means, don't worry, roll back to 353 for now and watch the forums for an announcement.
I'm getting a similar error on 3.6 and 3.6.1. Have reverted to 3.5.3 but am happy to help test any fixes to this.
  #13  
Old Jan 12, 2011, 11:22 AM
Pietz
 
5 posts · Jan 2011
Couldn't find suhosin in the output from phpinfo.

I will roll back tot 3.5.3 and follow this forum.

Thanks for your support!
  #14  
Old Apr 6, 2011, 04:23 PM
webster
 
43 posts · Apr 2011
I am getting "PHP has encountered an Access Violation at 022AA58D " when I try and preview the latest version 364. I had the same error with the last version, and I am using 353 with no problems.

But I would like some of the new features.
  #15  
Old Apr 7, 2011, 03:38 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
What version of php?
Is the host a linux server?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #16  
Old Apr 7, 2011, 04:48 AM
webster
 
43 posts · Apr 2011
PHP Version 5.2.13
Windows NT
Wordpress 3.1.1

Thanks.
  #17  
Old Apr 7, 2011, 04:57 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Version 3.6.x of Atahualpa uses php 'stream wrappers'. I would assume that something in your PHP install is not allowing the 'bfa' stream wrapper to be used.

You will have to talk to your host's support group about this if the php.ini override doesn't work (see http://forum.bytesforall.com/showthread.php?t=12262)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #18  
Old Apr 7, 2011, 11:00 AM
webster
 
43 posts · Apr 2011
I contacted my host, and they installed the suhosin module and enabled it. Then:
Quote:
We have just updated the value of the parameter "suhosin.executor.include.whitelist"
as suggested here, they have read this thread.

But although the latest version of the theme resides appropriately in themes on the install, it has not been activated as I have been unable to use preview - getting the same php error.

They await developments here and elsewhere. I am using the most up to date 3.5 version of the theme.
  #19  
Old Apr 7, 2011, 03:59 PM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
You know if you install 364 in a separate folder in the themes folder (call the folder 'atahualpa364' you will see both versions in the theme picker, so you can activate 364 and try it. if it doesn't work, activate version 353. I have 7 versions in my theme folder doing it this way so I can switch back and forth based of different questions I look at.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #20  
Old Apr 7, 2011, 06:42 PM
webster
 
43 posts · Apr 2011
Yes I have both installed, Im using 3.5.3, and attempting to use an installed 3.6.4 just as you say

But when I click 'preview' for 3.6, it coughs a php error, and not a preview. All my other themes work fine. If you think there is any point in exporting importing and activating the theme to see if it gets past the errors from preview I'll try it out. My host offered to sched. that for the night time, so if there were need for backup restore, I wouldn't be down for long during a high viewing period, but they also said it was probably not going to be productive, they read this forum too.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error upgrading 3.3.3 to 3.4.6 ymf New Versions, & Updating 4 Feb 21, 2010 12:05 PM
Error while upgrading theme bluedogcreative New Versions, & Updating 1 Jan 28, 2010 03:27 PM
Parse error: syntax error, lost all center column content on all pages/posts Ladyartist Atahualpa 3 Wordpress theme 7 Oct 26, 2009 04:17 PM
404 Page error on all pages (not posts) twola New Versions, & Updating 3 Oct 14, 2009 09:32 PM


All times are GMT -6. The time now is 01:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.