Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] Rotating images in header using NextGen gallery


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Apr 9, 2009, 07:52 PM
juggledad's Avatar
juggledad
 
22,045 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I've been messing around trying to see if I could get a rotating header (I'm helping my sister with a site for a school) and I've almost got things working.

1) Using NextGen gallery, I created a gallery called header_images and loaded my images to it.
2) I edited header.php and changed
-----------------------------------------------------------------
<!-- Header -->
<td id="header" colspan="<?php echo $cols; ?>">

<?php bfa_header_config($bfa_ata['configure_header']); ?>

</td>
<!-- / Header -->
-----------------------------------------------------------------
to
-----------------------------------------------------------------
<!-- Header -->
<td id="header" colspan="<?php echo $cols; ?>">

<?php
if (function_exists("nggSlideshowWidget"))
{ nggSlideshowWidget(6,1440,250); }
?>

<?php bfa_header_config($bfa_ata['configure_header']); ?>

</td>
<!-- / Header -->
-----------------------------------------------------------------
where '6' was the number of the gallery and 1440 is the width of images and the value set in Layout MAX width, while 250 is the hight of the images.

Now the images show up and rotate based on the duration set in the slideshow duration, but the image doesn't honor the other header settings. It's like it sits on top of the page and isn't paying attention to the settings for the header.

Is there any way to have it adhere to the other settings for the header?

Last edited by juggledad; Oct 24, 2009 at 12:04 PM.
  #2  
Old Apr 10, 2009, 06:03 AM
paulae's Avatar
paulae
 
1,331 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I don't know about the code, but I'm looking at it on a MacBook Pro 15", resolution set to 1440x900. The top image extends past the container to the right and forces a horizontal scrollbar. I haven't looked at on a bigger screen yet, but obviously there's a problem with the image size, at the very least. Can you make it the same width as the non-rotating image? Can you put the rotating images in the logo bar instead, so they'll be nice and rounded?
  #3  
Old Apr 10, 2009, 06:10 AM
juggledad's Avatar
juggledad
 
22,045 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
The images in the top (rotating images) and the bottom are the same size. the bottom one is controled by the theme. What I want to do is get the top part to be controled by the theme.

I'm hoping thet Flynn might give me a pointer in the right direction (please please)
  #4  
Old Apr 10, 2009, 08:09 PM
Flynn's Avatar
Flynn
 
3,761 posts · Oct 2008
Munich, Germany
Try with a CSS insert

HTML Code:
#sbsl6_1 {
width: 100%;
}

Last edited by Flynn; Apr 11, 2009 at 09:28 PM. Reason: Changed sbs16_1 to sbsl6_1
  #5  
Old Apr 11, 2009, 05:37 AM
juggledad's Avatar
juggledad
 
22,045 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Ok, that works!!

For anyone else trying this, the code you insert is
#sbsl6_1 {
width: 100%;
}

(Flynn typed a '1' instead of an 'l') and the number after the sbsl is the number of the gallery.

Now...if I can just figure out how to round the corners and move the Blog title and tag line over it. there would be an easy solution to everyone that wants automatic image changes.
  #6  
Old May 20, 2009, 02:28 AM
ciocchi
 
28 posts · Mar 2009
I tryed everything but I have problem with this issue. nextgen doesnt works.
I change in header.php the things suggestion and i insert in css the line above suggest, I create the gallery in nextgen , but nothing seem working. its seem that the calling;
<?php bfa_header_config($bfa_ata['configure_header']); ?> is not working and remain active the calling in bfa_header_config
why? what wrong?
also in safari mac I have a large band in the top. upon the header image
www.mialchemilla.it
  #7  
Old May 20, 2009, 03:26 AM
ciocchi
 
28 posts · Mar 2009
update,
now i can see a black band on top, no image ( i istalled also jw image rotator) also in ff and safari
  #8  
Old May 20, 2009, 05:33 AM
juggledad's Avatar
juggledad
 
22,045 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
To make sure that NextGen is running correctly, add a NextGen Slideshow to the sidebar and see if that works. This will help determine where the issue may be

Last edited by juggledad; Dec 3, 2009 at 06:44 PM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
my header images aren't rotating... tai4ji2x Header configuration & styling 20 Dec 15, 2010 08:38 PM
Rotating images in header, different link for each image? PhunkzV2 Header configuration & styling 5 May 26, 2010 07:22 PM
creating 2 separate boxes in header, for logo and nextgen slideshow gallery rinoa3108 Header configuration & styling 8 Mar 8, 2010 05:19 PM
Nextgen Image Gallery in place of the rotating images marvinc Header configuration & styling 4 Jan 28, 2010 07:49 PM
[SOLVED] NextGen Gallery not showing up in right sidebar WebWeaver Plugins & Atahualpa 2 May 30, 2009 12:27 PM


All times are GMT -6. The time now is 05:57 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.