Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Comments, trackbacks & pings »

Adjusted $allowedtags in kses.php - still no ordered/unordered lists show in comments


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Oct 2, 2010, 04:35 PM
eraccusa's Avatar
eraccusa
 
9 posts · Oct 2010
United States
Yes, I found this thread: http://forum.bytesforall.com/showthread.php?t=1707 and I understand that this may just be a WordPress "gotcha" problem. However, I did just donate to this BytesForALL site, so please bear with me and work with me to solve this. Thanks.

Here is what I have: Atahualpa 3.5.3 on WordPress 3.0.1 with CKEditor 3.4.1 (Plugin version 1.0.2)

I want to allow users to have the ability to use the CKEditor minimal editor and use the clickable buttons on that in posting comments. They can use the editor buttons and all appears to work. But once a comment is approved the ordered / unordered lists do not show numbers and bullets. Also, linked pictures do not show after approval of a comment, although they do show while creating the comment. Other than editing kses.php to allow these in comments, what needs adjusting? Thank you.
__________________
Want an awesome PC? Use Linux and Unix.
http://www.eracc.com/ | http://blog.eracc.com/
  #2  
Old Oct 2, 2010, 04:49 PM
eraccusa's Avatar
eraccusa
 
9 posts · Oct 2010
United States
To check if this is a theme problem I changed to the default theme with WordPress 3.0.1 and the ordered/unordered lists DO show up. Switching back to Atahualpa 3.5.3 breaks that again.

This appears to be a theme related problem with Atahualpa 3.5.3 at this point.
__________________
Want an awesome PC? Use Linux and Unix.
http://www.eracc.com/ | http://blog.eracc.com/
  #3  
Old Oct 2, 2010, 05:12 PM
juggledad's Avatar
juggledad
 
22,094 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
can you point to a page showing the issue?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #4  
Old Oct 2, 2010, 05:40 PM
eraccusa's Avatar
eraccusa
 
9 posts · Oct 2010
United States
Here is the only page with comments where I have tried it so far:

http://blog.eracc.com/2010/10/02/sit...keditor-added/
__________________
Want an awesome PC? Use Linux and Unix.
http://www.eracc.com/ | http://blog.eracc.com/
  #5  
Old Oct 2, 2010, 07:11 PM
juggledad's Avatar
juggledad
 
22,094 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Ok in order to test this, you are going to have to walk me thru
1) where did you put the ckeditor folder
2) what options do you have enabled for the editor
3) what did you do to allow users to enter comments

Once I enable the plugin, the comment form text box did not show up.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #6  
Old Oct 2, 2010, 07:36 PM
eraccusa's Avatar
eraccusa
 
9 posts · Oct 2010
United States
I installed CKEditor from the WordPress 3.0.1 - Plugins - [Add New] button. The folder was added automatically from that. I logged into the site with FTP to see where that is. Here is where I found it:
wp-content/plugins/ckeditor-for-wordpress
CKEditor is set at its defaults, I changed nothing. The comments were already enabled and working prior to adding this plugin. They still worked after adding it.

IIRC there is more than one version of CKEditor for WordPress. I got this one: http://wordpress.org/extend/plugins/...for-wordpress/ For the record, this is not a CKEditor problem. It is a rendering/display problem with the HTML code in the posted/approved comments. If I take CKEditor out of the mix by disabling it in the Plugins menu the problem persists.
__________________
Want an awesome PC? Use Linux and Unix.
http://www.eracc.com/ | http://blog.eracc.com/

Last edited by eraccusa; Oct 2, 2010 at 07:38 PM.
  #7  
Old Oct 2, 2010, 10:18 PM
eraccusa's Avatar
eraccusa
 
9 posts · Oct 2010
United States
Interesting. When I load the RSS feed for my site the ordered and unordered lists in that second comment display in the comments in the feed reader (Liferea). They just do not display in the comments on the site itself while using the Atahualpa 3.5.3 theme.
__________________
Want an awesome PC? Use Linux and Unix.
http://www.eracc.com/ | http://blog.eracc.com/
  #8  
Old Oct 3, 2010, 06:13 AM
juggledad's Avatar
juggledad
 
22,094 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
The issue here is the complexity of the Atahualpa Comment CSS.

The Comments in atahualpa are nested (lists inside lists) and there is CSS that sets the list style to 'none'. This is why the list HTML items are not in the allowed HTML lists.

If you want, you can see if you can add CSS to the CSS Inserts to turn on the lists styles when using this plugin, but I don't guarantee you success.

p.s. I played for well over an hour and couldn't get it to work without ripping out parts of the Atahualpa CSS which could cause issues elsewhere.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #9  
Old Oct 3, 2010, 11:48 AM
eraccusa's Avatar
eraccusa
 
9 posts · Oct 2010
United States
Thank you for looking at it. I thought it might be a CSS related problem since the lists do work in the comments in the default theme. I am no CSS guru, but I will take a whack at this to see if I can figure it out. I suppose this is what I need to edit: wp-content/themes/atahualpa353/css.php after making a backup of course.
__________________
Want an awesome PC? Use Linux and Unix.
http://www.eracc.com/ | http://blog.eracc.com/
  #10  
Old Oct 3, 2010, 11:54 AM
juggledad's Avatar
juggledad
 
22,094 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
if you scrool down and remove the section starting with
HTML Code:
/* ------------------------------------------------------------------
---------- COMMENTS WP 2.7 ------------------------------------------
------------------------------------------------------------------ */
and remove the first three items
HTML Code:
ul.commentlist {
	margin: 15px 0 15px 0;
	list-style-type: none;
	padding: 0;
	display:block;
	border-top: <?php echo $bfa_ata['comment_border']; ?>;
	}

ul.commentlist ul {
	margin: 0;
	border: none;
	list-style-type: none;
	padding: 0;
	}

ul.commentlist li {
	padding: 0;
    margin: 0;
	display: block;
	clear: both;
	height: 1%; /* for IE */
}
I think it will work, but no guarantees that something else might not act screwy
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #11  
Old Oct 3, 2010, 12:05 PM
eraccusa's Avatar
eraccusa
 
9 posts · Oct 2010
United States
I'll play with it and see. This will be "fun", doing these tests on my live site.
__________________
Want an awesome PC? Use Linux and Unix.
http://www.eracc.com/ | http://blog.eracc.com/
  #12  
Old Oct 3, 2010, 12:15 PM
eraccusa's Avatar
eraccusa
 
9 posts · Oct 2010
United States
Okay, I commented out that block:
Code:
/* ul.commentlist {
    margin: 15px 0 15px 0;
    list-style-type: none;
    padding: 0;
    display:block;
    border-top: <?php echo $bfa_ata['comment_border']; ?>;
    }

ul.commentlist ul {
    margin: 0;
    border: none;
    list-style-type: none;
    padding: 0;
    }

ul.commentlist li {
    padding: 0;
    margin: 0;
    display: block;
    clear: both;
    height: 1%; /* for IE */
} */
I'll keep that commented out and browse around on the site. So far, looking at a couple of posts all appears well.
__________________
Want an awesome PC? Use Linux and Unix.
http://www.eracc.com/ | http://blog.eracc.com/
  #13  
Old Oct 3, 2010, 01:39 PM
eraccusa's Avatar
eraccusa
 
9 posts · Oct 2010
United States
It appears that the ordered/unordered lists in comments created with CKEditor buttons now work as intended. The image button has a large number of options that I am not allowing, but what I am allowing seems to work:

http://blog.eracc.com/2010/10/02/sit...keditor-added/

I did have a "borked" site for a few minutes while I figured out a syntax error I made in the kses.php file while trying to allow the 'img' tags I wanted. I really need to set up a test web log for making these changes. As always making time to do that sort of thing for my own sites is a problem.
__________________
Want an awesome PC? Use Linux and Unix.
http://www.eracc.com/ | http://blog.eracc.com/

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] 3.51 Excerpts Don't Show Unsorted Lists Correctly LaneLester Center area post/pages 2 Jun 26, 2010 10:37 AM
Ordered lists in comments not working nikkidev Comments, trackbacks & pings 8 May 24, 2010 10:05 AM
php in footer.php - links to just show up on homepage chris Atahualpa 3 Wordpress theme 6 May 9, 2010 12:50 PM
Show and Hide comments using 'Show Comments' link Alexa Comments, trackbacks & pings 4 Feb 17, 2010 11:51 AM
[SOLVED] Ordered lists &amp; unordered lists overlapping neighboring pictures Smilesbypayet Customization, Design, Programming... 2 Oct 13, 2009 07:33 PM


All times are GMT -6. The time now is 07:43 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.