Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Comments, trackbacks & pings »

[SOLVED] BUGFIX - 3.4.1->3.4.6 - Comment form will not show up after first comment on


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Dec 28, 2009, 04:11 AM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
UPDATE: Note the WORDPRESS BUG code fix in post #14 you need this fixed and the comment.php in post #8
==================
Update: Grab the comment.zip in post#36 to fix this
==================

There is a bug in the comment code which causes the comment form not to show up after the first comment is made on a 'PAGE' page. To fix this bug do the following

Edit comment.php and find line 79-80 (versions 341/344) which should be
HTML Code:
<?php // If comments are open
if ('open' == $post->comment_status) : ?>
and replace them with the following
HTML Code:
<?php // If comments are open
if ( ('open' == $post->comment_status) 
OR ( is_page() and ('Yes' == $bfa_ata[comments_on_pages]) and ('open' == $post->comment_status) )) : ?>
save the file to the host and you should be all set.
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Feb 13, 2010 at 05:26 AM. Reason: fix issue with form showing when comment was closed
  #2  
Old Dec 28, 2009, 09:27 AM
Keikurono's Avatar
Keikurono
 
24 posts · Dec 2009
Colombia
Hi again Juggledad, thanks for the fix, works perfect... thanks again
  #3  
Old Dec 29, 2009, 11:57 PM
Keikurono's Avatar
Keikurono
 
24 posts · Dec 2009
Colombia
Hidding comment form on specific pages

Hi, thanks again for the fix on the comments form but now i want to know if there is any way for hidding the form on some pages where commenting is not allowed (example > http://www.shito-anime.net/?page_id=2324)

even knowing the comments are closed, the form still appears, i want to hide it..

thanks....
  #4  
Old Dec 30, 2009, 01:06 AM
jhoff
 
3 posts · Dec 2009
works for me too! Thanks!

http://www.betsysbabyservices.com/
  #5  
Old Dec 30, 2009, 05:45 AM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I updated the fix so the form won't show when the comments are closed on the page - Thanks to Keikurono for spotting that!
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jan 25, 2010 at 02:56 PM.
  #6  
Old Dec 30, 2009, 07:34 AM
extremecarver
 
73 posts · Jul 2009
Well I don't know about the original fix. But the updated fix does not work for me. Form is only shown on pages without any posts. On other pages people can use "reply" but the comment form only shows for pages without any comment.
__________________
Don't settle for lousy expensive Maps - Get free Maps based on Openstreetmap with great autorouting for cyclists, hikers and Mountainbikers at http://openmtbmap.org
  #7  
Old Dec 30, 2009, 08:01 AM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I see I'd better go back to the drawing board and try
1) a page with no comments - comments open
2) a page with no comments - comments closed
3) a page with comments - comments open
4) a page with comments - comments closed
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #8  
Old Dec 30, 2009, 09:03 AM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Update, use the attached file in post #36 instead of this one - checked for 3.4.1 -> 3.4.6
================================================== =====
ok, I think I have it. A link to the page was getting dropped when the actual comments were displayed. Please try the attached version of comments.php and let me know how it goes.
comments.zip
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Feb 13, 2010 at 05:28 AM.
  #9  
Old Dec 30, 2009, 11:57 AM
extremecarver
 
73 posts · Jul 2009
working again now. BTW is there an easy solution to put the comment field ABOVE the comments?
Even though I page my comments to 25 comments per page, newest on top, this still is a lotta text to find the comment box.
__________________
Don't settle for lousy expensive Maps - Get free Maps based on Openstreetmap with great autorouting for cyclists, hikers and Mountainbikers at http://openmtbmap.org
  #10  
Old Dec 30, 2009, 12:35 PM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Using the new version, you could try this.

Take lines 85-181 and put them after line 20.
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jan 2, 2010 at 12:30 PM.
  #11  
Old Dec 30, 2009, 11:44 PM
Keikurono's Avatar
Keikurono
 
24 posts · Dec 2009
Colombia
works for me... thanks again..

edit: ehh... i'm sorry for bother you again but i have found a new problem: the link "reply to" on specific comments on a page only appears in the first (or last, depending on the order).. meaning i can only reply to that comment but no the others, is ther a way to fix that?? (http://www.shito-anime.net/?page_id=2018 < the link says "responder")

Last edited by Keikurono; Dec 30, 2009 at 11:59 PM.
  #12  
Old Dec 31, 2009, 05:17 AM
Keikurono's Avatar
Keikurono
 
24 posts · Dec 2009
Colombia
Quote:
Originally Posted by juggledad
Using the new version, you could try this.

Take lines 85-181 and put theem after line 20.
this did not work for me.. is there another way for putting the comment form above the comments??
  #13  
Old Dec 31, 2009, 05:20 AM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Sorry, this was just a stab in the dark looking at the code for 30 seconds and giving a 'well maybe this will work'.
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #14  
Old Dec 31, 2009, 07:37 AM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Wow, Keikurono you owe me a beer!

So I started looking at the issue of only being able to reply to the last comment for a PAGE and after many twists and turns, I ended up in the WordPress module 'comment-template.php' and may have discovered a bug (which I'm asking about on the WordPress Forums - http://wordpress.org/support/topic/3...1#post-1333439).

Anyway, to fix this, edit comment-template.php (it's in the wp-includes folder) and find the function
'get_comment_reply_link' (line 999 in version 2.8.6 -> 2.9.1)

Lines 1012-1013 are
HTML Code:
	$comment = get_comment($comment);
	$post = get_post($post);
make the following change
HTML Code:
	$comment = get_comment($comment);
	$post = get_post($comment->comment_post_ID);
This will always get the post (or page in our case) ID from the comment.
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Feb 13, 2010 at 04:51 AM.
  #15  
Old Jan 8, 2010, 01:15 AM
ideefixx
 
3 posts · Jan 2010
Hi,

Done the comments.zip and all seems to be OK , but when someone submits there typing there comes a error message telling :

Failed: enter tekst

Pls see url http://www.flyingfinish.eu/nl/?page_id=421


This is not only on pages now but on the complete site.

Thank you

Last edited by ideefixx; Jan 8, 2010 at 01:25 AM.
  #16  
Old Jan 8, 2010, 07:30 AM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
it looks like you are using some javascript to handle thecomments. Are you using a plugin? fi so which and what happen it you disable the plugin
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #17  
Old Jan 12, 2010, 02:38 PM
grandpa's Avatar
grandpa
 
6 posts · Jan 2010
Norway
Well done, juggledad, I had the same problem.
I used the donate button for this job.

svein-erik dahl
  #18  
Old Jan 20, 2010, 08:18 AM
hlanggo
 
6 posts · Jan 2010
To Juggledad:

There are four files in comments.zip:
http://forum.bytesforall.com/attachm...8&d=1262189005

comment/.DS_Store - 7KB
comments.php - 6KB

_MACOSX/comment/.DS_Store - 1KB
_MACOSX/comment/comments.php - 1KB

I'm supposed to just replace -

wp-content/themes/atahualpa/comments.php - 6KB
w/
comments.php - 6KB

- right?

Or do I have to upload the other 3 files too?
  #19  
Old Jan 20, 2010, 11:44 AM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Yeah, just the comments.php
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #20  
Old Jan 28, 2010, 11:18 AM
LauriePK
 
8 posts · Jan 2010
I'm so confused -- all I know is I'm having the same problem -- I can't add comments to pages that already have comments.

I have ata 3.4.4 and WP 2.9.1. I replaced the short code with the longer code, and I uploaded the new comments.php file.

Now I can get comments on one page ( http://theadventurouswriter.com/blog...awlik-kienlen/ ) but not the other ( http://theadventurouswriter.com/blog...t-infertility/ )

Can you please give me the correct php file to upload? And, tell me what files to delete -- should I delete the comments-paged.php file (or some other file)?

Thanks for your help,
Laurie
  #21  
Old Jan 28, 2010, 11:27 AM
LauriePK
 
8 posts · Jan 2010
Forget my comment and question -- I fixed it! I'd just done it in the wrong order, is all :-)

Cheers
  #22  
Old Jan 28, 2010, 11:57 AM
LauriePK
 
8 posts · Jan 2010
Actually -- I fixed that my first blog -- got the comments going there.

But I can't fix it on my other blog that has atahualpa! That one has ata 3.4.4 and WP 2.9.1 . I followed the same steps that worked for my first blog, but those didn't work for this one. I even transfered the comment.php file from the first blog to this one, but didn't work...

How can I get the comments to go on this blog, too?

http://seejanesoar.theadventurouswri...sk-a-question/

Thanks,
Laurie
  #23  
Old Jan 28, 2010, 01:50 PM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
do you have ATO->Style & configure COMMENTS->Allow comments on "Page" pages, too? set to YES
AND dashboard->pages->edit->one of the pages->discussion->Allow Comments. checked off?
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #24  
Old Jan 28, 2010, 01:57 PM
LauriePK
 
8 posts · Jan 2010
Yes, I've checked those 2 things repeatedly, and just quadrupled-checked again...both are set to "yes" I want comments on pages.

I can't figure out why it works on my other blog, but not this one.

http://seejanesoar.theadventurouswri...awlik-kienlen/

Should I be deleting comments.php file, or one of the other comment files? I didn't for my first blog...
  #25  
Old Jan 28, 2010, 03:30 PM
juggledad's Avatar
juggledad
 
22,168 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
no, both are needed.
Is this blog on the same host?
does it have many widgets?
Do you have any security plugins?
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] BUGFIX - 343 - Comments show 'Leave a Comment' even when comments are clos juggledad Old Version fixes and change logs 1 Sep 29, 2009 07:07 PM
Comment form: how do I clear the data from name and email when the form is submitted? blueprairie Comments, trackbacks & pings 3 Sep 15, 2009 05:15 PM
Comment Form on Posts jackiejart Forum How-To 11 Jun 5, 2009 07:45 PM
Clicking "Leave a comment" does not lead to comment form Fux Comments, trackbacks & pings 2 May 4, 2009 11:34 PM
How do I show | Category: Introduction | Leave a comment | Edit this post on a Page? PerryM Post-Kicker, -Byline & -Footer 2 Apr 17, 2009 09:03 PM


All times are GMT -6. The time now is 04:03 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.