Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

Weird code showing up in menu drop-down


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Aug 7, 2010, 09:52 PM
lhanft
 
88 posts · Jul 2009
Cleveland, OH
Weird code showing up in menu drop-down

Since I've upgraded to the latest Atahualpa, I've had a weird thing happening with my subpage dropdowns

I use Page Lists Plus to control which pages show up in wp_list_pages & thus in my drop down nav. Typically, I'll build a new page, then only add it to wp_list_pages once it has been approved to go live. The last two pages I've added since I upgraded show a superfluous
Code:
">
before the page name. If you hover your mouse over the page name you see the page name followed by
Code:
<span class=
I couldn't get a screenshot, but if you go to my website, look under "Admissions" the entry for Admission Forms is messed up. If you look under "Parents," the entry for Back-to-School Forms is messed up.

What do you think is going on?
  #2  
Old Aug 7, 2010, 09:59 PM
lhanft
 
88 posts · Jul 2009
Cleveland, OH
I just fixed the problem by de-selecting all these options in Page Lists Plus:

Quote:
Add class="first_item" to first list item (this can be useful if you want to style your first link differently to others, such as in horizontal menus with separators between Page links)
Add span tags at start of list items, i.e. <li><span class="gilder-levin"></span><a href="#">Link</a></li>
Add span tags inside list items, i.e. <li><span class="sliding-doors"><a href="#">Link</a></span></li>
Add span tags at start of anchors, i.e. <li><a href="#"><span class="gilder-levin"></span>Link</a></li>
Add span tags inside anchors, i.e. <li><a href="#"><span class="sliding-doors">Link</span></a></li>
I don't know which of these options was the culprit, but it works for now. Anyone know of a conflict with Page Lists Plus since Wordpress 3.01 or Atahualpa 3.5.3??
  #3  
Old Aug 7, 2010, 10:06 PM
lmilesw's Avatar
lmilesw
 
10,054 posts · Jul 2009
Central New York State USA
Glad you fixed and there certainly COULD be a problem with the Page List Plus plugin. Why not just use the WP 3 manu builder which will let you pick and choose which page show up in the menu
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #4  
Old Aug 7, 2010, 10:21 PM
lhanft
 
88 posts · Jul 2009
Cleveland, OH
Well I started out using the new WP 3 menu builder, but then I ran into the problem styling the WP 3 menu, problem which I hope will be fixed by applying the BUGFIX 353-01 described here.

Have you switched from the ATA page menus to the WP 3 menu builder? Any advice?
  #5  
Old Aug 7, 2010, 10:31 PM
lmilesw's Avatar
lmilesw
 
10,054 posts · Jul 2009
Central New York State USA
I just use the WP menu builder now and with the bug fix all works as expected. You can also add a class to the individual menu buttons. If the class box doesn't show hit the Screen Options at the top right and select CSS Classes. Now you will have a box in the individual buttons to add a class for styling.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Header Drop Down Navigation (Where to insert the code) rockport Header configuration & styling 7 Nov 15, 2010 07:57 PM
[SOLVED] Weird things showing up on my site in firefox, please help! jenb Atahualpa 3 Wordpress theme 9 Jul 15, 2010 08:41 AM
Weird Error With Code in Loop as Opposed to index.php adum Post-Kicker, -Byline & -Footer 1 Oct 10, 2009 04:48 AM
Weird phrase showing up instead of comment time / date Taquoriaan Comments, trackbacks & pings 0 May 15, 2009 10:49 PM
Page Menu Drop Down Only Showing First 6 Child Pages LabbyRoad Page & Category Menu Bars 4 Mar 11, 2009 11:40 AM


All times are GMT -6. The time now is 04:43 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.