Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » Forum Usage » Forum How-To »

[SOLVED] New Post Titles Showing as "Auto Draft"


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jul 31, 2010, 04:23 PM
mkmossop
 
3 posts · Jul 2010
[SOLVED] New Post Titles Showing as "Auto Draft"

The correct post titles won't display (this is a new issue that seems to have just started... before I upgraded to version 3.0.1 though).

The correct title displays in the Firefox browser in the very top info section of the browser, but not on the actual page.

Anyone know what's up?
  #2  
Old Jul 31, 2010, 05:13 PM
lmilesw's Avatar
lmilesw
 
10,069 posts · Jul 2009
Central New York State USA
To get rid of the current Auto Draft entries you need to go to ATO>Configure SEO and turn on Use Post/Page Options. Then when you open the posts that are showing Auto Draft you will see that in the Atahualpa Post or Page options. Just delete the lines and they will be recreated from the the title of the post or page.

Then to prevent this from being an issue you can continue as follows but before you do download a copy of functions.php which is in the Atahualpa theme folder as a backup.

Please read this carefully... You will be changing a line not adding one. You can edit functions.php by going to Appearance>Editor
and click on functions.php on the right.

Edit the functions.php (in the Atahualpa theme folder)
At about line 603 replace the line that is there with the following

$title = ($post_id->post_title !== 'Auto Draft') ? $post_id->post_title : '';



The line you are changing is right after
$thePostID = $post->ID;
$post_id = get_post($thePostID);
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Last edited by lmilesw; Jul 31, 2010 at 05:17 PM.
  #3  
Old Jul 31, 2010, 11:04 PM
mkmossop
 
3 posts · Jul 2010
Thanks very much for your reply.

I'm not sure which option to change under ATO > configure SEO.

I don't see anything saying "Use Post/Page Options".

Do you mean "Use Bytes For All SEO options?" or one of the other options?

Thanks again for the help!
  #4  
Old Aug 1, 2010, 06:30 AM
lmilesw's Avatar
lmilesw
 
10,069 posts · Jul 2009
Central New York State USA
The Auto Draft issue came to play with WP 3.

First make sure you don't have a post/page options in your pages and posts. If you do you will see "Auto Draft" in those fields for the posts and pages in question and you can just delete those entries as mentioned in a previous reply.

If you don't see that setting in the SEO options and don't see a post/page options in your posts and pages you are one of the versions of Atahualpa that had that feature turned off and you will need to upgrade to Atahualpa 353 which you can download here. I would highly suggest the manual update method as shown here but with any update you need to BACKUP YOUR DATABASE AND WP-CONFIG FOLDER FIRST.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Aug 1, 2010, 06:01 PM
mkmossop
 
3 posts · Jul 2010
Ah finally it worked... thank you!

I had to upgrade, then change the post options.

Thanks for all the help .

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Headline on post page displays as "Auto Draft" cytaylor Post-Kicker, -Byline & -Footer 33 Apr 17, 2011 06:30 AM
Post Title Showing Up As "Auto Draft" Jrdpa Center area post/pages 1 Jul 19, 2010 02:33 PM
[SOLVED] "auto draft" appearing at the top of each of my posts... brianbotkiller Atahualpa 3 Wordpress theme 9 Jul 18, 2010 06:31 PM
Hiding "Blogroll" and "Meta" titles nige Sidebars & Widgets 1 Jul 21, 2009 12:13 AM
Flexx theme - How to change my "List Category or Archives" to "List Titles ONLY" ?? idaks01 Post-Kicker, -Byline & -Footer 0 Mar 28, 2009 05:22 PM


All times are GMT -6. The time now is 06:06 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.