Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

How to remove blank lines in center column


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Apr 23, 2010, 04:03 PM
capelady
 
47 posts · Mar 2010
How to remove blank lines in center column

I have a site http://gardenlady.com.s52126.gridserver.com/wp/ where the home page is a static page, and I have a number of other static pages as well. On the home page, the area below the header contains a large blank area before the photos. Only two <br /> and one <p> show up in the source code, but the space looks larger than that. I searched the Atualpa files for <br /> and couldn't find any, and I can't tell where the rest of the blank area is generated. I suspect it's leftover code from blog stuff, but can't find it. The other pages don't have nearly so much blank space before the text/images, and they are acceptable. Any suggestions? Even if it's just where to look for the breaks. Thanks.
  #2  
Old Apr 23, 2010, 05:25 PM
aQuickStudy's Avatar
aQuickStudy
 
43 posts · Mar 2010
I see 2 paragraphs and 4 breaks. I am no expert but it looks to me like you'd edit it in the post editor.
  #3  
Old Apr 24, 2010, 05:53 AM
capelady
 
47 posts · Mar 2010
Thanks for your input. Yes, I was hoping it would be that easy, but when I edit the page, the table containing the two photographs is at the very top, with no line breaks before it. So, it is being generated somewhere in the Atahualpa code, whether php or css I don't know. And actually, as I look at the source code for my page again, the <br />s are within my table, not before it, so I guess it's not the <br />s that are causing it. It's not in the header code, as other static pages don't have so large a space, so it must be in the post code somewhere. It might be somewhere in a php or css file, but I haven't found it yet, and am not sure I'd recognize it if I saw it. I checked all the posting options and zero'ed out any spacing options that I thought might be suspect, but the extra space is still there.
  #4  
Old Apr 24, 2010, 06:15 AM
capelady
 
47 posts · Mar 2010
Ok, I took out the table with the two photos temporarily and the space was gone. I put the table back in and played around with the options for spacing around and within tables and could only move it up a little. So somewhere else in the code there must be setting overriding those settings. I have to say that fine-tuning wordpress, being this is my first experience with it, has been frustrating, finding all the code that affects the elements of the pages. I guess if I had experience in php and in css, or didn't need to fine-tune it I would be less frustrated. A learning process, for sure.
  #5  
Old Apr 24, 2010, 06:26 AM
juggledad's Avatar
juggledad
 
22,188 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
your problem is all teh <p> and <br /> you have mixed in your table.

a table is a set of rows (<tr>'s) and columns (<td>'s) you don't put <br> after a </td> it will mess things up.

Try this, change your table to the following
HTML Code:
<TABLE border="0px" margin="1px" padding="1px">
 <TR>
  <TD>
   <a href="http://gardenlady.com.s52126.gridserver.com/wp/wp-content/uploads/2010/03/annuals_and-perennials1.jpg"><img class="alignleft size-full wp-image-51" title="annuals_and-perennials" src="http://gardenlady.com.s52126.gridserver.com/wp/wp-content/uploads/2010/03/annuals_and-perennials1.jpg" alt="Annuals and Perennials" width="504" height="248" /></a>
 </TD>
  <TD>
   <a href="http://gardenlady.com.s52126.gridserver.com/wp/wp-content/uploads/2010/03/cl_splash.jpg"><img class="size-full wp-image-78 alignnone" title="cl_splash" src="http://gardenlady.com.s52126.gridserver.com/wp/wp-content/uploads/2010/03/cl_splash.jpg" alt="C.L. Fornari in the garden" width="173" height="248" /></a>
  </TD>
 </TR>
</TABLE>
and check out the results

oh, yeah, take out the </p> after the <a....> that follows the table
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #6  
Old Apr 24, 2010, 01:29 PM
capelady
 
47 posts · Mar 2010
I copied your code into the page, replacing what was there, with the same results.
I created a test page: http://gardenlady.com.s52126.gridser...p/?page_id=382 which ONLY has your table in the middle column, and it does the same thing.
I know it doesn't make sense, but I did not put the breaks <br /> in there. What is putting them in there, I don't know. Would there be some table definition somewhere that is doing that? Besides, it's also putting space above the table that I want to eliminate, and the source shows no breaks or paragraphs there.
Does it have to do with the code
<div class="post-382 page hentry category-uncategorized post" id="post-382">
<div class="post-bodycopy clearfix"><p>
which is BEFORE the table?

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Delete / remove center column Pieter Dekker Center area post/pages 2 Apr 18, 2010 02:31 AM
Using rollover images in text widget causes blank lines between rollovers? hankphone Sidebars & Widgets 8 Jul 27, 2009 03:16 PM
Center Column chiaxiong Atahualpa 3 Wordpress theme 1 Apr 8, 2009 06:28 PM
Center column styling: how can I remove margin or padding? bcorrigan Header configuration & styling 2 Apr 2, 2009 09:53 AM


All times are GMT -6. The time now is 12:17 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.