Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

Background-image showing only on Home page, but not on other pages


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Mar 18, 2010, 07:02 AM
niki.forova
 
2 posts · Mar 2010
Exclamation Background-image showing only on Home page, but not on other pages

I am a huge fan of Ata, and have been working with it for quite some time! Recently, I changed my permalink structure in WP to 'postname' extensions as opposed to the 'default' number values, and suddenly my background image is not showing up on any of the pages aside from the Home page. Did I break something?

Home page: http://save-a-mother.org/ (background image of red/blue showing)
About page: http://save-a-mother.org/about/ (background image of red/blue NOT showing)

I have the following CSS in Body, Text & Links option:

font-family: tahoma, arial, sans-serif;
font-size: 0.8em;
color: #000000;
background-color: #fbefe0;
background-image: url("wp-content/themes/atahualpa/images/SAM_top.gif");
background-repeat:repeat-x;
background-position:top;

Are there additional changes I am supposed to make? I found it interesting that the background image worked just fine with 'Default' permalinks, but stopped working after I switched to 'postname'

Thanks in advance for your help - this is for great cause! If there is a thread where this problem has been addressed, please send me a link :)

Mariya
  #2  
Old Mar 18, 2010, 07:10 AM
juggledad's Avatar
juggledad
 
22,191 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
for the url, put in the full path, ie http://yourdomain.com/wordpress....
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #3  
Old Mar 18, 2010, 01:24 PM
jbharding
 
6 posts · Feb 2010
I am fairly new to Atahualpa - fairly old in all other respects, but a long-time techie. What a great theme, BUT I can't get a background image to show (unless my browser refuses to reload - someone should address a non-cache browser).
Under ATO>Body, Text, and Links, I have"

font-family: verdana, arial, sans-serif;
font-size: 0.9em;
color: #000000;
background: url(http://www.normanspreciousmetalrefin...background.gif) repeat top left;

my site is www.normanspreciousmetalrefiners.com, and I have tested the path to the image.
  #4  
Old Mar 18, 2010, 03:49 PM
lmilesw's Avatar
lmilesw
 
10,087 posts · Jul 2009
Central New York State USA
What happens if you use
HTML Code:
background: url (/wp-content/themes/atahualpa/images/background.gif) repeat top left;
in that area or as I look at your cod again maybe just a space between background: and url.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Mar 18, 2010, 06:18 PM
juggledad's Avatar
juggledad
 
22,191 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
add HTTP:// to the befining of the address you have 'url(www.......' make it 'url(http://www.....'
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #6  
Old Mar 20, 2010, 02:03 PM
jbharding
 
6 posts · Feb 2010
Thanks, Juggledad - that did it! Happy to donate. All the best, John
  #7  
Old Mar 20, 2010, 01:57 PM
jbharding
 
6 posts · Feb 2010
Thanks - that should help

Bookmarks

Tags
background, background color, background image, background image repeat, image

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] menu background image only shows up on home page, missing on pages/post Athena account2 Page & Category Menu Bars 5 Mar 4, 2010 03:53 AM
[SOLVED] Still having issues with the page menu bar showing a background image. noitalever Page & Category Menu Bars 2 Jan 8, 2010 05:29 PM
image not showing in background of page menu bar rinoa3108 Page & Category Menu Bars 5 Jul 30, 2009 07:37 AM
Header image displays on all pages BUT the HOME page imabeliever Header configuration & styling 3 Apr 14, 2009 06:05 AM


All times are GMT -6. The time now is 04:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.