Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

Help! Page Title Does Not Display Hyphens, Commas, etc.!


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jan 4, 2010, 06:14 PM
sfdiaries
 
5 posts · Jan 2010
Help! Page Title Does Not Display Hyphens, Commas, etc.!

Hey Everyone,

I was hoping you could help. For some reason, my blog does not display hyphens, commas, colons, etc. in the page/tab title.

I am pretty sure I didn't play with these settings (in fact I dont know where to even do that), and I was hoping you could help solve the problem.

My blog is http://www.sfdiaries.com and a good example to look at is the post title "Earth - The Most Interesting Place". The page title or tab title looks like "Earth – The Most Interesting Place" instead of "Earth - The Most Interesting Place". It has done this on a couple of other posts too, but not to all of them.

Any ideas?

Thanks!
  #2  
Old Jan 4, 2010, 06:36 PM
juggledad's Avatar
juggledad
 
22,104 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Quote:
The page title or tab title looks like "Earth The Most Interesting Place" instead of "Earth - The Most Interesting Place".
those are the same??
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #3  
Old Jan 5, 2010, 12:36 AM
sfdiaries
 
5 posts · Jan 2010
Sorry I meant to say it says "Earth &_#_8211; The Most Interesting Place" (no underscores, I added those in because otherwise it would put in the hyphen).

If you can go to the link [http://www.sfdiaries.com/?p=240] and check it out, I would appreciate it!

Last edited by sfdiaries; Jan 5, 2010 at 12:38 AM.
  #4  
Old Jan 9, 2010, 04:23 PM
sfdiaries
 
5 posts · Jan 2010
Let me clarify. If you have more than one tab open and have a character such as a hyphen, colon, etc., that character would be replaced with an &#8211 in the page name in the tab.

Any thoughts on how to fix this?
  #5  
Old Jan 9, 2010, 06:22 PM
juggledad's Avatar
juggledad
 
22,104 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I'm sorry, I kept looking at the posts titles and the looked fine, I just realized it is the PAGE title giving the issue (sigh)

What SEO options do you have set?
Do you have anything different than the defaults at ATO->Configure SEO?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #6  
Old Jan 11, 2010, 12:44 PM
TwtrCoach
 
22 posts · Jun 2009
Tupelo, MS
Opps did not see this thread. So posted the same issue in another thread. Just delete that thread, so we can keep any fix in the same thread.

I actually have the same issue.

Seems like when I use special characters in title it converts it to HTML char. codes. Have to check if it do it for pages also.

The title shows ok in browser, and also when I checked my settings on WordPress it looks ok. But when I look at my source code, that's when I see the HTML char. codes.

And I use the default ATO Seo

Cheers.. Are
  #7  
Old Jan 13, 2010, 09:54 PM
sfdiaries
 
5 posts · Jan 2010
Here are my ATO SEO options...
Attached Thumbnails
Click image for larger version

Name:	Picture 4.jpg
Views:	546
Size:	142.9 KB
ID:	350  
  #8  
Old Jan 14, 2010, 02:02 AM
juggledad's Avatar
juggledad
 
22,104 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
What does teh title look like if you switch to the default theme? I'm trying to determine where the problem lies, I can't recreate it and am wondering if it could be the character set used for creating the MySQL database...

Atahualpa seems to be calling a wordpress function to display the title so i want to know what you see with the default theme, just swap themes, visit the page, make not of what you see and then swap back to Atahualpa.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #9  
Old Jan 15, 2010, 11:30 AM
sfdiaries
 
5 posts · Jan 2010
If I switch to the default and switch back, do I lose all of the formatting, that I refined for my current design?
  #10  
Old Jan 15, 2010, 12:00 PM
juggledad's Avatar
juggledad
 
22,104 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Nope, all the options are stored in the database.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #11  
Old Mar 12, 2010, 11:59 AM
grego
 
4 posts · Mar 2010
I am having the same issue. I switched back to the WP default and the title shows the correct hyphen character (-). When I switch back to Atahualpa I see this

Code:
–
Any advice on how to get the hyphen to show properly? The odd value is also showing in the title in the Google SERPs. I have another site using Atahualpa that doesn't seem to have this problem.

??

Thanks
  #12  
Old Jun 9, 2010, 02:53 PM
goldstockbull
 
6 posts · Jun 2010
Hello,

Did anyone ever figure this out? I am having the same problem and if you search for "wordpress &#8211" on google, you get a bunch of Athualpa themed sites. So this is obviously something to do with the theme.

I am using 3.4.6 and using the built in SEO. When I changed my post title to x-x, instead of x - x, this solved the issue. But I would like to be able to have the extra space as I think it looks better. This should be an easy thing to correct, but my coding skills are subpar.

Any help>
Attached Thumbnails
Click image for larger version

Name:	Picture 2.png
Views:	395
Size:	31.4 KB
ID:	529  
  #13  
Old Jun 9, 2010, 03:21 PM
lmilesw's Avatar
lmilesw
 
10,077 posts · Jul 2009
Central New York State USA
I believe that issue has been taken care of in 3.5.1 or you can take a look at this thread.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #14  
Old Jul 9, 2010, 11:45 AM
goldstockbull
 
6 posts · Jun 2010
Just wanted to let everyone know that the issue has NOT been resolved in 3.5.1.

I have attached a screenshot of the google search results.

As you can see, the hyphen is still showing up as "–"

On the other sites that have republished my article, the hyphen in the title is displaying correctly.

I guess I will try to edit bfa_meta_tags.php again and see if that helps.

If anyone has a confirmed fix for this issue, please post.

Thanks!
Attached Thumbnails
Click image for larger version

Name:	hyphen issue.png
Views:	399
Size:	113.4 KB
ID:	598  
  #15  
Old Jul 9, 2010, 11:59 AM
juggledad's Avatar
juggledad
 
22,104 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Wel the fix did not get into 3.5.1 - I'll code up a bugfix for this for 3.5.1
The line is the same as in 3.4.6 - line 71
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #16  
Old Jul 9, 2010, 12:12 PM
juggledad's Avatar
juggledad
 
22,104 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
see 'BUGFIX 351-05: Page Title Does Not Display Hyphens, Commas, etc.' (http://forum.bytesforall.com/showthr...6521#post36521)
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Bookmarks

Tags
page title

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Display post title only of a category in a page ladylulu Page & Category Menu Bars 9 Mar 1, 2011 08:02 AM
Category Page Listing - How to display: Post Title only TotalBalance Excerpts, Read more, Pagination 16 Jan 27, 2010 12:22 PM
[SOLVED] Turning off Page Title display MrCardinal Atahualpa 3 Wordpress theme 4 Jul 23, 2009 04:47 PM
Homepage title display wtan001 Forum How-To 1 May 24, 2009 05:44 AM
Catchable, no commas, missing/corrupt post info - Please check this file Flynn Atahualpa 3 Wordpress theme 4 Dec 14, 2008 02:23 PM


All times are GMT -6. The time now is 03:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.