Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Post-Kicker, -Byline & -Footer »

Possible speed issue culprit?


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Oct 1, 2009, 11:34 AM
paulae's Avatar
paulae
 
1,330 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Possible speed issue culprit?

I've been complaining for months about how slowly my site loads. Today, after tearing out my hair again, reducing plugins and widgets, and trying every way I could imagine to speed things up, I decided to try one last thing. I turned off the footer option that shows the page's load-time in the footer.

Shazaaam! Could that really have been the issue? I swear, after dumping the browser cache for Firefox and Safari, and even dumping the cached files in the cache directory on the server created by WP-Cache, I reloaded the page, and it was much, much faster.

Am I going nuts here? Please go to http://www.larchmontgazette.com and tell me if it seems pretty quick. You won't have the measurement in the footer to go by anymore, of course. Just compare it to some other similarly "busy" sites, please. I hope this was the cause, because it's so easy to do without it, and so easy to put it back if necessary.
  #2  
Old Oct 2, 2009, 08:15 AM
juggledad's Avatar
juggledad
 
21,702 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Well when I looked at this last night it was still taking about 8-9 seconds to load, this morning it loaded in about 5-6 seconds.

Looking at the source, the first time I see
<!-- Dynamic Page Served (once) in 2.128 seconds -->

the second time I see
<!-- Dynamic Page Served (once) in 2.128 seconds -->
<!-- Cached page served by WP-Cache -->
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Oct 2, 2009 at 08:23 AM.
  #3  
Old Oct 2, 2009, 09:32 AM
paulae's Avatar
paulae
 
1,330 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I was trying things yesterday, and maybe the first time you saw it, I had deactivated wp-cache, then turned it on again.

Do you see any other obvious problems? I know we have a lot of queries on the front page, and a lot of plugins running. But the site was a lot faster (under 2 sec.) before we were hacked, and before I installed Atahualpa 3.4.3.
  #4  
Old Oct 2, 2009, 10:23 AM
juggledad's Avatar
juggledad
 
21,702 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
The problem with speed issues it there are so many peices an dyou can't setup a controled environment. Even teh number of hops to get from your computer to the host could change between refreshes.

However I do have an idea to seperate the time it takes to generate a page and the time it takes to serve the page.

Veiw a page and then go view the source and copy the code and put it in a file. Then upload that file to the Atahualpa folder (so any non fully defined url's will still work) and them view that page.

This will tell you how much time it's taking to serve the page.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #5  
Old Oct 2, 2009, 10:36 AM
paulae's Avatar
paulae
 
1,330 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Am I having an HTML brain-freeze? View it how, once it's in the Atahualpa folder? You mean call it index.php?
  #6  
Old Oct 2, 2009, 10:46 AM
juggledad's Avatar
juggledad
 
21,702 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Sorry, once you display the page in Your browser, view the source and copy it to a text file called test.HTML then save this fully generated source of your page back to the server. Now you can view that page and wordpress/atahualpa are out of the picture

Http://larchmountgazette.com/wp27/so...alpa/test.HTML
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Oct 2, 2009 at 10:49 AM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed paulharrisjr Atahualpa 3 Wordpress theme 4 Aug 4, 2009 09:03 PM
[SOLVED] Can't edit posts - edits vanish - Virus? Theme Issue? WP Issue? jfrenaye Atahualpa 3 Wordpress theme 1 Aug 4, 2009 07:14 AM
[SOLVED] Atahualpa 3.4.2 speed issues ?? Dr.GameMaker Atahualpa 3 Wordpress theme 7 Jul 26, 2009 03:13 PM
WP 2.7.1 Upgrade Issue chiaxiong New Versions, & Updating 3 Apr 1, 2009 05:35 AM
IE issue c32v Atahualpa 3 Wordpress theme 1 Feb 11, 2009 05:16 AM


All times are GMT -6. The time now is 05:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.