Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

[SOLVED] Issue with creating a double cell widget


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Apr 24, 2012, 06:00 AM
sober's Avatar
sober
 
121 posts · Oct 2010
Unhappy [SOLVED] Issue with creating a double cell widget

Hi

I have been for the past two days trying to create a two cell widget and put in above the page title on a page. I was able to make the widget show up but the issue is that it inherits the styling from the table. What happens, the table border and background and colors comes as an additional layer around the widget. I would really appreciate if someone could give me the exact code. I am on 3.7.3 and the code I am using to create the widget is
PHP Code:
<?php if (is_page()) { ?><?php bfa_widget_area('name=pagetop-twin&cells=2&align=9'); ?><?php ?>
You can see the sample at http://www.nonebutchrist.com/privacy-policy/

You can see the twin widgets just above the title "privacy policy" and if you go to the end of the page, you can see a sample table whose styling the twin widgets has inherited as an additional layer around it. All I need is to take out this additional layer without change the table styling.

Jimmy

Last edited by sober; Apr 24, 2012 at 06:36 AM. Reason: to add more
  #2  
Old Apr 24, 2012, 07:35 AM
lmilesw's Avatar
lmilesw
 
10,054 posts · Jul 2009
Central New York State USA
Where did you get that code for a new widget area? It should be
HTML Code:
<?php bfa_widget_area('name=pagetop-twin&cells=2&align=9'); ?>
since only the code for new widget areas is allowed.
Where did you put the code?
If you want a two celled widget area above the page title on each page I would put the above code in ATO>Edit Post/Page Info Items>KICKER: "Page" Pages
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Apr 24, 2012, 07:48 AM
sober's Avatar
sober
 
121 posts · Oct 2010
Hi

Thanks for the code and the explanation. I do not have any experience with PHP or coding. The code that I mentioned was just a geusstimate code. Sometimes things worked for me that way. I inserted my code by editing index.php. I have inserted the code you gave in the "post/pages" kicker but nothing has changed. This could be something with caching so I am waiting for the cache to expire. Also, when i use single cell widget, it works perfect as you can see with the widget area just above the double cell widget and I find its strange. I really appreciate your help and hope it would work once the cache expires. The page, again, is at http://www.nonebutchrist.com/privacy-policy/
  #4  
Old Apr 24, 2012, 07:56 AM
lmilesw's Avatar
lmilesw
 
10,054 posts · Jul 2009
Central New York State USA
Why not just disable your caching plugin for the time being. Also once you put the code in the kicker area you need to go to a page to "activate" it. Then you should see the new widget areas in Appearance>Widgets.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Apr 24, 2012, 11:48 AM
sober's Avatar
sober
 
121 posts · Oct 2010
I am on a managed wordpress hosting and apparently, caching is not enabled on my blog. I think there is something else with this. I can see the widgets on the widget page in admin panel
  #6  
Old Apr 24, 2012, 12:15 PM
juggledad's Avatar
juggledad
 
21,979 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
first please don't double post. you won't get a faster response

try adding the following th the CSS inserts
HTML Code:
div.post table.bfa_widget_area td {
    background-color: #FFFFFF;
    border-bottom: medium none;
    border-left: medium none;
    border-right: medium none;
    padding: 10px;
    text-align: left;
}
Remember the widgets are styled in the theme options.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Bookmarks

Tags
double cell widget issue

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating different page templates without sidebars - (possible permalinks issue) xonline Atahualpa 3 Wordpress theme 4 Apr 5, 2012 11:50 AM
Double width sidebar widget? sky captain Sidebars & Widgets 2 Jun 6, 2011 11:05 AM
A cell that spans more than one cell/column? Sundrop Post-Kicker, -Byline & -Footer 4 Dec 22, 2009 12:51 PM
Background image &amp;amp; form in only 1 cell of a header extra widget cell? kippiper Header configuration & styling 8 Nov 22, 2009 06:58 AM
[SOLVED] Change the cell width in new widget area duping812 New Versions, & Updating 2 Jul 16, 2009 07:19 PM


All times are GMT -6. The time now is 06:56 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.