Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Problem with aligning images and text in Internet Explorer.


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Sep 8, 2011, 08:56 PM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
Problem with aligning images and text in Internet Explorer.

I am using Atahualpa 3.5.1 on Wordpress 3.2.1

I have an external stylesheet for aligning images. They work great for all browsers except IE.

Example page: http://www.theblogfarm.com/layout-test/

They work perfect in all browsers except IE. For some reason they align left instead of centered.

Here is the CSS for that:

#linklist3,

#linklist3 a {
color: #4D5232;
}

#linklist3 table {
background: transparent;
border: 0px solid #4D5232;
vertical-align: middle;
}

#linklist3 td {
background: transparent;
border: 0px solid #4D5232;
padding: 0px;
width: 150px;
}

#linklist3 td.center {
text-align: center;
vertical-align: top;
}

#linklist3 img {
background: url(/wp-content/themes/atahualpa351/images/sidebarbg04.jpg) repeat top left;
border: 1px solid #4D5232;
padding: 7px;
margin-bottom: 6px;
}

#linklist3 img {
margin: 5px;
width: 160px;
height: 120px;
}

Can someone please tell me how to fix this, I have tried everything for weeks but cannot find solution. Thank you...
  #2  
Old Sep 9, 2011, 06:26 AM
lmilesw's Avatar
lmilesw
 
9,955 posts · Jul 2009
Central New York State USA
What version of IE are you talking about. It looks fine to me in IE9 and in my emulator it looks good in IE8 as well. In IE7 the images do left align to the table cells probably because IE7 does not support some CSS.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Sep 9, 2011, 09:29 AM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
Yep, I am running xp on a gig of ram so I am stuck with IE7 since IE8 wont run properly due to lack of RAM. My other two new fast comps are down so I am stuck with an old emachine for now.

I was hoping that there was a fix for this so others stuck with older IE's would see them as intended. I had fixed it once before but do not remember what I did...

I tried everything I could find using W3schools forum, I even have the same question on their page. So far no luck...

Having read somewhere that it was a margin thing that IE doesn't like, I made several changes using margin: auto; and other stuff with no success. I thought I would check with you guys to see if you had run into this problem previously.

Any ideas?
  #4  
Old Sep 12, 2011, 09:41 PM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
I went through a lot of trouble, upgrading ram and updating to IE8 and still see the images aligning left. So no one knows a fix for this?
  #5  
Old Sep 13, 2011, 06:08 AM
juggledad's Avatar
juggledad
 
21,689 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Here is what I would do to figure this out
View the page in question, the view the source and do a select all/copy
Paste that into a text file and save it as xxxxx.HTML
Now open that file in IE

At this point you can edit the file and start removing code, save and do a refresh in IE and see the change. You should be able to remove the footer, the sidebars, then the CSS applying to them, the menus, it's CSS etc. Eventually you should find out if there is a conflict in the CSS.

Note I always start by finding the Atahualpa CSS and going to the end. I then remove everything from the bottom to the '.clearboth {......}' - everything after the '.clearboth' is what was in the CSS inserts area.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #6  
Old Sep 13, 2011, 08:05 AM
lmilesw's Avatar
lmilesw
 
9,955 posts · Jul 2009
Central New York State USA
I looked at your code again... Try taking off all vertical-align properties and width properties for the td. Just leave the width for the img. The td take care of itself. Here is what I would use.
HTML Code:
#linklist3, #linklist3 a {
color: #4D5232;
}

#linklist3 table {
background: transparent;
border: 0px solid #4D5232;
}

#linklist3 td {
background: transparent;
border: 0px solid #4D5232;
padding: 0px;
}

#linklist3 td.center {
text-align: center;
}

#linklist3 img {
background: url(/wp-content/themes/atahualpa351/images/sidebarbg04.jpg) repeat top left;
border: 1px solid #4D5232;
padding: 7px;
margin-bottom: 6px;
}

#linklist3 img {
margin: 5px;
width: 160px;
}
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Tags
css, image alignment, positioning

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problems with images and background image in Internet Explorer freelancekonsulenten Sidebars & Widgets 2 Mar 20, 2011 04:02 PM
Internet Explorer clipping images in Atahualpa 3.4.9 mattsimpson Center area post/pages 20 Aug 1, 2010 06:11 PM
[SOLVED] Images not displaying in Internet Explorer. CDJ Page & Category Menu Bars 2 Jun 23, 2010 05:44 AM
[SOLVED] Text GROWS in Internet Explorer? fluffysam Center area post/pages 3 Jan 10, 2010 04:49 PM


All times are GMT -6. The time now is 03:38 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.