Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Sub menu not displaying correctly


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Apr 1, 2011, 08:00 AM
quillik
 
6 posts · Apr 2011
[SOLVED] Sub menu not displaying correctly

Hello,

The sub menus are not displaying correctly on my website. Here's a link to my website:

https://prototype.quillik.com/

And here is the extra CSS code I have so far:

div#menu1 {
float: left;
width: 100%;
height: 100%;
background: url('http://prototype.quillik.com/wp-content/themes/atahualpa/images/nav-bg.png') repeat-x;
overflow: hidden;
position: relative;

}
div#menu1 ul.rMenu {
clear: left;
float: left;
list-style: none;
margin: 10px 0;
padding: 0;
position: relative;
left: 50%;
text-align: center;
}
div#menu1 ul.rMenu li {
display: block;
float: left;
list-style: none;
vertical-align: center;
margin: 0;
padding: 0;
background: transparent !important;
color: #fff;
position: relative;
right: 50%;
}
div#menu1 ul.rMenu li a {
display: block;
margin: 0 0 0 1px;
padding: 3px 10px;
background-color: transparent !important;
color: #fff;
text-decoration: none;
line-height: 100%;
}
div#menu1 ul.rMenu li a:link {
background-color: transparent !important;
}
div#menu1 ul.rMenu li a:visited {
background-color: transparent !important;
}
div#menu1 ul.rMenu li a:active {
background-color: transparent !important;
}
div#menu1 ul.rMenu li a:hover {
background-color: transparent !important;
font-weight: bold;
}


My problem at this point is the full sub menu does not display, and it seems like (from the sub menu that does display) is that the li alignment is off. Thanks.
  #2  
Old Apr 1, 2011, 10:03 AM
lmilesw's Avatar
lmilesw
 
10,053 posts · Jul 2009
Central New York State USA
I get a security warning when I try to access that site.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Apr 1, 2011, 10:11 AM
quillik
 
6 posts · Apr 2011
Sorry about that. It's http://prototype.quillik.com/
  #4  
Old Apr 1, 2011, 10:50 AM
juggledad's Avatar
juggledad
 
21,968 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
why are you setting the 'div#menu1 ul.rMenu li' to 'position: relative;' and 'right: 50%;'?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #5  
Old Apr 1, 2011, 10:54 AM
lmilesw's Avatar
lmilesw
 
10,053 posts · Jul 2009
Central New York State USA
Could you attach a setting file to a reply?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Apr 1, 2011, 11:03 AM
quillik
 
6 posts · Apr 2011
Hi Juggledad,

The "'div#menu1 ul.rMenu li' to 'position: relative;' and 'right: 50%;" setting is (partly) how I accomplished centering the top menu items.

lmilesw,

Not exactly sure what you mean by settings file, but i'm attached a copy of my added CSS.
Attached Files
File Type: txt css_settings.txt (1.5 KB, 243 views)
  #7  
Old Apr 1, 2011, 11:21 AM
juggledad's Avatar
juggledad
 
21,968 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
try removing the right: 50%;

go to ato->export/import settings and export your settings and attach them to a reply
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Site Not Displaying Correctly in Opera c12281 New Versions, & Updating 7 Nov 4, 2010 08:54 AM
Trouble displaying posts/pages correctly tigger32382 Atahualpa 3 Wordpress theme 0 Nov 20, 2009 11:50 AM
[SOLVED] blog not displaying correctly in safari pltrace Header configuration & styling 3 Sep 28, 2009 02:41 PM
[SOLVED] Site not displaying correctly in IE martdris Atahualpa 3 Wordpress theme 2 Aug 4, 2009 07:36 AM
[SOLVED] Safari not displaying page menu bar and post footer correctly chinnerz Atahualpa 3 Wordpress theme 4 May 31, 2009 09:52 PM


All times are GMT -6. The time now is 06:34 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.