Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

Category Menu and Internet Explorer Issue - Opacity & Drop-Down


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jan 23, 2011, 02:43 AM
dextor
 
19 posts · Sep 2009
Category Menu and Internet Explorer Issue - Opacity & Drop-Down

Hi there,

I am having two issues with my category menu in both IE and IE64, both Version 8:

Site: http://tvfrohnau.dextorslab.de/

(1) There should be a drop-down menu for two of the main menu items, which do not seem to appear.

(2) The menu itself should have some opacity. The setting I chose ist:

Code:
div#menu2 {
	height: 42px;
	width: 100%;
	margin-top: -42px;
	background-color: #361501;
	z-index: 5;
	position: relative;
	border: none;
	background: rgba(54, 21, 1, 0.55); /* R, G, B, A */
	filter: progid:DXImageTransform.Microsoft.gradient(startColorstr=#7f404040,   
        endColorstr=#7f404040); /* AA, RR, GG, BB */
}
The filter-setting has been suggested somewhere, to establish the opacity on the main menu level, but not on any of the childs. Maybe there is something wrong with that, causing both (1) and (2)?

Any advice is highly appreciated.

Best wishes

dextor
  #2  
Old Jan 23, 2011, 03:54 AM
juggledad's Avatar
juggledad
 
21,712 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
If you take it out do the menus show up?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #3  
Old Jan 24, 2011, 01:04 AM
dextor
 
19 posts · Sep 2009
Hi Juggledad,

I really don't know why I did not get that far to actually test it myself...

Anyway: yes, if I take out the filter it shows up correctly (at least confirmed for the
32bit version of IE8).

I could use the 'traditional' way of adding opacity to the menu, but that would be inherited
for the sub-menu items. And I don't want that to happen...

Any ideas for a workaround?

Best wishes

dextor
  #4  
Old Jan 24, 2011, 04:12 AM
juggledad's Avatar
juggledad
 
21,712 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Unset it for the sub menu items
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #5  
Old Jan 24, 2011, 05:15 AM
dextor
 
19 posts · Sep 2009
I tried to unset the filter on the sub menu.

Currently I test with only filter: alpha(opacity=60)

div#menu2 {
margin-top: -42px;
z-index: 5;
position: relative;
background-color: #361501;
background: rgba(54, 21, 1, 0.6); /* R, G, B, A */
filter: alpha(opacity=60);
}

div#menu2 ul.sub-menu {
filter: none;
}

This has no effect in IE. The drop down is not showing up.
In firefox it works as desired, because of the rgba-color definition.

Any more ideas?

dextor
  #6  
Old Jan 24, 2011, 06:10 AM
juggledad's Avatar
juggledad
 
21,712 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
don't use IE

I'd swap to twenty-ten and make the same changes in it's menu structure to see if it is a theme or general issue with IE.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet Explorer issue pamlicoink New Versions, & Updating 3 Jul 24, 2010 08:50 PM
Internet Explorer & Atahualpa mattsimpson Center area post/pages 2 Jul 19, 2010 11:49 AM
Header image issue in Internet Explorer omac7504 Header configuration & styling 5 Mar 16, 2010 07:11 AM
Adding Opacity to Page Menu & Drop-down Submenu buttercups0147 Page & Category Menu Bars 1 Dec 25, 2009 04:51 AM


All times are GMT -6. The time now is 09:25 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.