Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Server error_log flooded with PHP Parse Error


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Nov 4, 2010, 04:57 AM
Garwen
 
16 posts · Nov 2010
[SOLVED] Server error_log flooded with PHP Parse Error

Hello

Just noticed that the error_log of my webserver is flooded with the following error message:
Code:
[Thu Nov 04 10:19:18 2010] [error] [client x.x.x.x] PHP Parse error:  syntax error, unexpected '<' in [www-root]/wp-content/themes/atahualpa353/functions.php(532) : eval()'d code on line 7, referer: http://somepage.com
Everytime anyone access the page, a line per page is added to the error log.

Anyone an idea where this could come from ?

Thanks

Last edited by Garwen; Nov 4, 2010 at 08:31 AM.
  #2  
Old Nov 4, 2010, 05:23 AM
juggledad's Avatar
juggledad
 
22,380 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
did you add anything to ato->Style & edit CENTER COLUMN->The LOOP?

have you added any New Widget areas?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Nov 4, 2010, 05:48 AM
Garwen
 
16 posts · Nov 2010
Didn't change anything on the loop. At least, not that i can remember. It looks like this:
Code:
<?php /* For SINGLE post pages if activated at ATO -> Next/Previous Navigation: */
bfa_next_previous_post_links('Top'); ?>

<?php /* Post Container starts here */
if ( function_exists('post_class') ) { ?>
<div <?php if ( is_page() ) { post_class('post'); } else { post_class("$odd_or_even"); } ?> id="post-<?php the_ID(); ?>">
<?php } else { ?>
<div class="<?php echo ( is_page() ? 'page ' : '' ) . $odd_or_even . ' post" id="post-'; the_ID(); ?>">
<?php } ?>

<?php bfa_post_kicker('<div class="post-kicker">','</div>'); ?>

<?php bfa_post_headline('<div class="post-headline">','</div>'); ?>

<?php bfa_post_byline('<div class="post-byline">','</div>'); ?>

<?php bfa_post_bodycopy('<div class="post-bodycopy clearfix">','</div>'); ?>

<?php bfa_post_pagination('<p class="post-pagination"><strong>'.__('Pages:','atahualpa').'</strong>','</p>'); ?>

<?php bfa_post_footer('<div class="post-footer">','</div>'); ?>

</div><!-- / Post -->
Didn't add any widget area. I use only the default "Right Sidebar"

But I removed some code from the footer.php, because it's a company internal server.
Code:
<!-- Footer -->
<td id="footer" colspan="<?php echo $cols; ?>">

    <p>
{removed some code here}
    <?php wp_footer(); ?>

</td>
<!-- / Footer -->

</tr>
</table><!-- / layout -->
</div><!-- / container -->
</div><!-- / wrapper -->
<?php bfa_html_inserts($bfa_ata['html_inserts_body_bottom']); ?>
</body>
</html>
Might this cause the problem ?
  #4  
Old Nov 4, 2010, 06:36 AM
juggledad's Avatar
juggledad
 
22,380 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I suspect that what ever you removed, you did it incorrectly and now have an extra < in the code that is confusing the php processor
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Nov 4, 2010, 06:41 AM
Garwen
 
16 posts · Nov 2010
Easy to find out. Gonna replace the file with the original one.
  #6  
Old Nov 4, 2010, 06:49 AM
Garwen
 
16 posts · Nov 2010
No, this was not it.
Also replaced "The Loop" with the default, but didn't change anything.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parse error: syntax error, unexpected '<' in the functions.php file pingitt Atahualpa 3 Wordpress theme 6 Mar 12, 2013 04:52 AM
[SOLVED] ERROR MESSAGE: Parse error: syntax error, unexpected T_STRING in /hsphere/lo Candy Atahualpa 3 Wordpress theme 1 Oct 31, 2010 04:00 PM
PHP Parse error: syntax error, unexpected T_STRING Big Geek Daddy Atahualpa 3 Wordpress theme 5 Aug 6, 2010 06:25 AM
[SOLVED] Parse error in functions.php after changing GMT offset in admin. AVIDJockey Atahualpa 3 Wordpress theme 3 Jul 27, 2009 01:32 AM
Can not activate my theme due to parse erorr Parse error tanimwp Forum How-To 2 Jun 17, 2009 04:13 AM


All times are GMT -6. The time now is 11:57 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.