Thread: de_DE - Deutsch
View Single Post
Old Dec 27, 2008, 05:26 AM
Flynn's Avatar
3,768 posts · Oct 2008
Munich, Germany
Sorry I didn't check the .pot file, it seems that last minute changes were not included. I have attached a new atahualpa.pot file in this post. The .pot file is supposed to be the base file that is not linked to any specific language.

I have tested the attached .pot file and it seems o.k. except that it throws one error while saving for "% comments" if it's translated to "% Kommentare". Could you just save the de_DE.po regardless and see if the resulting file works on a german blog?

It should work like this:

In PoEdit:

"New catalog from pot file", choose "atahualpa.pot"

Fill out "Project Info" except plural forms:
Atahualpa Deutsch or similar, Your name, Your email, German, Germany, UTF-8, UTF-8
(not sure if iso-8859-1 would be better as German "charset" but UTF-8 should cover everything?)

The other two tabs (paths, keywords) should not be required

Save as "de_DE.po" (or, whatever the Wordpress extension for the given language is:

With PoEdit's default setting this would also create a "" along with the "de_DE.po" file. "" is the compiled file that would be included with the theme.

Translate and click "Save" before closing PoEdit

Unlikely but just in case:

Open de_DE.po and make sure the terms don't have paths from your local computer such as
#: C:\wordpress\theme-translations\atahualpa3\_atahualpa3.1.7/comments-paged.php:3

It should be more like this:
#: comments-paged.php:3
Attached Files
File Type: zip (1.5 KB, 1873 views)