Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Excerpts, Read more, Pagination (http://forum.bytesforall.com/forumdisplay.php?f=20)
-   -   Excerpt: h3.../h3 becomes p..., but no closing /p (http://forum.bytesforall.com/showthread.php?t=16486)

ymf Jan 12, 2012 01:22 PM

Excerpt: h3.../h3 becomes p..., but no closing /p
 
The post's fragment
HTML Code:

<h3>Some Text</h3>
in an excerpt becomes:
HTML Code:

<p> Some Text
Note the absence of closing "/p". I am not even sure if this is Atahualpa's issue or Wordpress issue?

juggledad Jan 12, 2012 01:27 PM

URL?
Is this a manual excerpt or atahualpa excerpt?

ymf Jan 12, 2012 01:57 PM

goo.gl/CKiLg and search for "When to call?". I think it's an automatic excerpt.

juggledad Jan 12, 2012 03:00 PM

If you want the text to have the <h3> surrounding it, then go to ato->Configure excerpts and add <h3> to the things not to strip

ymf Jan 12, 2012 03:38 PM

Oh no. It would have been perfectly ok to have the <h3>...</h3> converted into <p>...</p>. What is not ok is the </p> missing!

juggledad Jan 12, 2012 04:42 PM

What version are you on?

ymf Jan 12, 2012 05:51 PM

WP 3.3.1, Atahualpa 3.73.

I was able to reproduce the issue in a sandbox (local PC) even with all plugins deactivated.

juggledad Jan 12, 2012 06:43 PM

Yeah, I reproduced it. It something that crept into the code due to a change between 3.4.9 and 3.5.1 - I've tracked it down a bit and have forwarded my findings to the developer and am waiting on a reply from him.

Interestingly, it only happens to the <Hn>...</Hn> and doesn't effect other HTML codes like center or strong

ymf Jan 12, 2012 07:24 PM

Wow! glad you tracked it down. I noticed the issue accidentally, by running validator.w3.org, and this was such a minor issue I doubted whether to post it to the forum at all.


All times are GMT -6. The time now is 06:40 AM.

Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.