Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Languages & Translations (http://forum.bytesforall.com/forumdisplay.php?f=57)
-   -   how to install translation files? (http://forum.bytesforall.com/showthread.php?t=20968)

Kaori29 Oct 1, 2013 07:08 AM

how to install translation files?
 
i got the german translation file for montezuma theme.
but how can i start it?

i copied the files De_de.mo + DE_de.po in the wp-content/themes/montezuma/languages file but nothing happend :confused:

i also changed the wp-config.php in language to 'de_DE'

lmilesw Oct 1, 2013 12:14 PM

I'm not very familiar with language files but could there be some case sensitivity issues going on? I see de_DE in one place and DE_de in another.

juggledad Oct 1, 2013 01:49 PM

can you include your po and mo files?

Kaori29 Oct 2, 2013 03:54 PM

1 Attachment(s)
Here are my files :)

juggledad Oct 2, 2013 04:52 PM

Take a look at the footer on a page - \do you see
1) All Rights Reserved
or
2) Alle Rechte vorbehalten
??

With your files in and
HTML Code:

define('WPLANG', 'de_DE');
added to wp-config.php, I see 'Alle Rechte vorbehalten'

what version of Montezuma and WP?

Kaori29 Oct 3, 2013 04:46 AM

Oh my god, i am so sorry... i thought the german language file would translate the dashboard infos into german...

http://img820.imageshack.us/img820/1614/cvm.png

But it translated the frontend infos which where englsh in german.
Yes everything on the page, like in the footer or the Comments are german now. And i tried so often to chnage this in the css und php files.

This was my big mistake. Sorry for that :(
But i think its a good hint for other users... maybe they have the same error in reasoning.

juggledad Oct 3, 2013 07:05 AM

actually it should work in the backend, but the po you created is missing a lot. Are you working from the Montezuma 1.1.9 version of the POT?

Kaori29 Oct 6, 2013 03:55 AM

I'm still runing Montezuma Version 1.1.3.

I got the language file from another website some time ago.

juggledad Oct 6, 2013 09:50 AM

I would
1) upgrade to version 1.1.9 and
2) create new .po and .mo files


All times are GMT -6. The time now is 04:21 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.