Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Atahualpa 3 Wordpress theme (http://forum.bytesforall.com/forumdisplay.php?f=2)
-   -   [SOLVED] Need help removing top of page margin. (http://forum.bytesforall.com/showthread.php?t=22967)

wskdigital Dec 19, 2014 02:33 PM

[SOLVED] Need help removing top of page margin.
 
I had the same issue a few years back and found a fix for it. I've tried everything I could think of, but nothing is working.

I have this problem only in the FireFox browser.

For some odd reason I have between 15 and 20 pixel margin (maybe padding) at the very top of the page. I've use firebug to try to solve the issue, but still can't seem to find it.

Here is the site: augrabbernome.com

Any help is appreciated.

juggledad Dec 19, 2014 05:33 PM

its the 15px in this css
HTML Code:

div.widget {
    display: block;
    margin: 0 0 15px;
    width: auto;
}


wskdigital Dec 19, 2014 08:41 PM

Wouldn't that add a 15px margin below the widget, not above?

HTML Code:

div.widget {
    display: block;
    margin: 0 0 15px;
    width: auto;
}

margin: 0 (top margin), 0 (right/left margin), 15px(bottom margin);

juggledad Dec 20, 2014 03:44 AM

Did you try it?

wskdigital Dec 23, 2014 04:17 PM

Yes, I did try it. Both in Style Widgets > Widget Container and in Add HTML/CSS Inserts > CSS Inserts

The odd thing is that the problem only shows up in the Firefox browser.

Hmmm...

Any other suggestions?

juggledad Dec 23, 2014 07:26 PM

try this in css inserts and leave it there if it doesn't work so I can take a look
HTML Code:

div#text-2 {
    margin: 0 0 0px !important;
}

the reason I'm givine you this code is that when I use FireBug, this is what makes the margin go away.
it is caused by the 'float: Left' you have assigned in the div of the logo.png If you get rid of the float: left the gap goes away, but the image drops down.

wskdigital Dec 26, 2014 04:19 PM

I solved the issue, well not really. I just did something completely different for the same result.

First I removed all margins on text-2, I increased the logo image height to 165px for a false 15px margin at the bottom.

Then I added the pile of gold as two background images. The top part goes into the 'logo bar' and the bottom half into the 'navigation bar'. It works great.

I still don't know why I was getting that extra margin at the top, but I found a solution that works.

juggledad Dec 26, 2014 05:12 PM

the reason (as I said) was because of the 'float: left;'. It seems that FireFox does it a bit different than chrome and safari.

But I'm glad you have a solution - I'll make this solved (you can always reopen it if you need to)


All times are GMT -6. The time now is 04:37 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.