Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Post-Kicker, -Byline & -Footer (http://forum.bytesforall.com/forumdisplay.php?f=17)
-   -   ATA "Sticky Footer" and plugin conflict (http://forum.bytesforall.com/showthread.php?t=6417)

kdawes01 Mar 23, 2010 04:00 PM

ATA "Sticky Footer" and plugin conflict
 
Hi,
I'm having a problem in a site I'm doing. I want to use the ATA Sticky Footer feature... And it works just fine... *Except* on a page where I am using the "(a)Slideshow" plugin. On the page with the slideshow the footer goes back to its "normal" spot.. I'm imagining it's a jquery conflict of some sort...

I'd offer the url, but I'm working on it behind the scenes using "Test Drive".

Thanks!

Ken

juggledad Mar 23, 2010 04:05 PM

what plugin - could you point to the download

kdawes01 Mar 23, 2010 04:34 PM

Hi Juggledad,
It's the (a)Slideshow or maybe it's (a) Slideshow ... It's in the WordPress.org plugin directory

Thanks!
Ken

juggledad Mar 23, 2010 05:28 PM

can you provide the link?

kdawes01 Mar 23, 2010 05:46 PM

Sorry!
Here's the link to the plugin...
http://wordpress.org/extend/plugins/a-slideshow/

Ken

kdawes01 Mar 28, 2010 03:42 PM

Sounds like no luck? I have also removed the plugin and used an embedded javascript image rotator and it has the same effect of making the footer "unsticky" Once either is removed the footer goes to the bottom of the screen.

I wish I could send you to the site to see... but as I said, my client doesn't want a "less than perfect" (her words) website seeing the light of day. I am using the "Theme Test Drive", so only someone logged in can see it.... I'd be happy to give you site access so you could see it for yourself... If there's a way to do it privately.

Please let me know!

Thanks!
Ken

juggledad Mar 28, 2010 06:15 PM

send me a PM with the link

juggledad Apr 1, 2010 07:20 AM

I just tried this in both wp 2.9.1 and 2.9.2
in 2.9.1 the sticky footer works fine with the slide show
in 2.9.2 the sticky footer works fine with the slide show

if you are having a problem try deactivating your other plugins

kdawes01 Apr 1, 2010 10:15 PM

Hi Juggledad,
Thank you for taking a look.... but it doesn't seem to be plugins... and I'm way confused.

The site I inherited and have converted to ATA is way bloated with plugins... So I thought I'd be smart... I have done a fresh WP test install on my own website. It's at
http://www.the-web-mechanic.com/test06

All I have installed is WP 9.2 and ATA... and a mod to the function.php to allow shortcodes in pages (this is installed on the problem site as well). It's about as bare-bones as you can get!

I made a static front page... footer is "up" in the middle of the page- as expected

I set the ATA footer to "sticky" --- Goes right to the bottom of the browser.. perfect!

I add the content from the problem site the pictures and html in the page and the javascript in the custom field.

I go back to check the published page... poof! The footer is no longer sticky. Its gone back to the middle of the page...

I'm tearing my hair out here!

I have given you access to my test site(above) with the same user and p/w that I emailed you previously. I'd appreciate it if you could take another look.

Thanks so much!

Ken

lmilesw Apr 1, 2010 11:12 PM

I was scanning through this thread and wondered why you added a mod to the function.php for shortcodes in pages. I use shortcodes all the time in pages without any mods. Also does the sticky footer come back if you don't have the slideshow from the jutehome.com site embedded?

juggledad Apr 2, 2010 06:27 AM

Ok, you have two sites that you changed functions.php and it's a problem, I have two sites without any mod and it woks fine....hmmmm

Rename your functions.php, upload a fresh copy and see what happens

kdawes01 Apr 7, 2010 03:40 PM

Hi,
Sorry to be slow to follow up with what happened...

Well, I have cured the footer problem... Though I'll have to admit that I don't totally get the "why".

Whether the the slideshow (either the plug-in or the javascript method) or ATA is the problem, the cure was to put a "height" on the image container (div).

There are 3 images on the page, all 374 px tall, and despite the images going into a slideshow that is the height of one image, the sticky footer moved to the bottom of the "body" instead of being sticky to the bottom of the browser unless the 3 images were put in a div with a 374px height. No height declaration, no sticky.

Once I gave the container a height of 374px, the sticky footer popped down to the bottom of the browser window and works as advertised.

I don't know the "why", just that it's now working!

Thank you so much for your help! Any explanation of what's going on?

Ken


All times are GMT -6. The time now is 05:50 AM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.