Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Installation/Upgrade Issues (http://forum.bytesforall.com/forumdisplay.php?f=58)
-   -   PHP 7 compatibility? (http://forum.bytesforall.com/showthread.php?t=24002)

bswb97 Jan 29, 2018 03:04 PM

PHP 7 compatibility?
 
I have a number of legacy sites running on Atahualpa. One old client host pinged them and they got this error

[Sun Jan 28 19:56:51.328131 2018] [proxy_fcgi:error] [pid 29150:tid 140100390336256] [client 37.233.27.142:47228] AH01071: Got error 'PHP message: PHP Warning: A non-numeric value encountered in/wp-content/themes/atahualpa/css.php on line 137\nPHP message: PHP Warning: A non-numeric value encountered in /home/www/whphx12/writersinthestormblog.com/htdocs/wp-content/themes/atahualpa/css.php on line 138\n'

I also ran a checker plugin and it detected these issues:

FILE: /wp-content/themes/atahualpa/functions/JSON.php
----------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 3 LINES
----------------------------------------------------------------------------------------------
133 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
783 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
797 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
----------------------------------------------------------------------------------------------

As I work more on the CSS/HTML end, are any of these catastrophic issues? I have a new tool that I use that is even more flexible than Atahualpa, and it's not terribly hard to convert but I wasn't sure if this would even require any tinkering or conversion.

juggledad Jan 29, 2018 07:51 PM

I'm running PHP V7.0.27 on my site and I don't see any errors. and looking at css.php I don't see any problems with those two lines but it is possible. Could you export his Atahualpa settings and attach them to an reply.

Also what version of Atahualpa?

bswb97 Jan 29, 2018 09:45 PM

1 Attachment(s)
I've attached the export file.

It's running 3.7.24 and WP 4.9.2.

juggledad Jan 30, 2018 07:45 AM

I just imported the settings and I don't see those messages. This may mean there is a plugin issue.

Temporarily disable all plugins and see if the issue still occurs. If it doesn't then add a couple plugins in at a time and test till you isolate the one causing the conflict.

juggledad Jan 30, 2018 06:01 PM

For the second issue if you can, rename the atahualpa/functions/json.php file to json.old and see if you see any issues.

That file is a simple encoder/decoder for JSON but JSON is part of PHP now, so I don't think it is needed anymore. In my simple test of removing the file, I did not see any issues.

bswb97 Jan 31, 2018 02:33 PM

Since JSON is now built into PHP 7, is the file essentially a benign redundant? Will it harm anything if it's just kept in?

Also, can the fix you've identified be patched into the file, like an unofficial 3.7.24.1?

juggledad Jan 31, 2018 03:54 PM

All you need to do is rename the file or delete it and you have your patched 3.7.24.1


All times are GMT -6. The time now is 02:47 PM.

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.