Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Atahualpa 3 Wordpress theme (http://forum.bytesforall.com/forumdisplay.php?f=2)
-   -   Page Corruption: Visual Editor and Page Revisions vanish when clicking Update! (http://forum.bytesforall.com/showthread.php?t=5747)

asellon Feb 6, 2010 04:24 PM

Page Corruption: Visual Editor and Page Revisions vanish when clicking Update!
I am trying to migrate my current web site content into the Atahualpa Theme 3.4.5 in WP 2.9.1. I have tried copying the content both from the site front-end, and also from the source code. In both cases, I'm copying tables with a mixture of text and images. All goes fine for a couple of hours of reformatting (other than font spacing not alway sticking!), and I save regularly. Then, for no reason I can discern, one of the times I click Update, I see the HTML code on the Visual Editor tab and my list of Page Revisions vanishes! This has happened to me twice now, the first time I had copied the content from the front end, put in the images fresh from my Media gallery, published the page then continued editing. The second time I took the source code for the page and put it onto a new WP page, and proceeded to edit, add images, etc. Either way, same result. Esmi on the WP forum suggested I try restoring a default theme, and sure enough, the page normalizes. So this is an Atahualpa issue. Is there a table bug? I don't see an easy way to create tables in visual editor, and I'd rather not do everything in hand-coded HTML. I can't find anything in the forum quite like this combination of issues, and I'm supposed to migrate my whole site this weekend. Can anyone help?? I set up a much larger site on Atahualpa with no problem, including copying content, but it wasn't tables or so many images. Can these pages be fixed? Or do I have to find a different theme? I do not have any plugins active on this particular site. I saw the info about some "concatenate" code, but was not sure if that still applies to 2.9.1?

paulae Feb 6, 2010 04:51 PM

I don't have time right now to try to parse through all of your troubles, but I can suggest a quick fix for the tables creation problem: if you get the Tiny MCE Advanced plugin, you'll be able to create tables pretty easily in the Visual editor. http://wordpress.org/extend/plugins/tinymce-advanced/

There are a couple of other table-specific plugins too.

You might need to look at the Atahualpa theme options and see if the table CSS is somehow interfering with the way your tables are coded...maybe they have some CSS that conflicts?

asellon Feb 6, 2010 05:53 PM

Thanks for your speedy reply, Paula. I will certainly look into that plugin as soon as time allows. But for now, I'm hoping that someone in the forum will recognize these symptoms and provide this newbie non-coder with the specific steps to resolve the issue. It's happened on another page on the site, too, now. For the moment, I can use a default theme to simplify my editing process, then switch to Atahualpa to view, but I'm really hoping for a fix rather than a workaround. Thx! :)

juggledad Feb 7, 2010 06:49 AM

what is your url pointing at one of the posts that causes problems.

I haven't seen anything where editing a post cause the post revisions to disappear.

How many plugins do you have?

Does it happen if you disable the plugins? (some plugins can cause problems)

you say that if the problem happens and you switch to the default theme, the post is there.
- Are the revisions?
- when you switch back to Atahualpa - are the revisions there or gone?

My guess is that something with the post is causing a php error and the backend page stops being generated before it displays the revision information. Looking ath the sites error.log on access.log may show the error and lead us to a solution. Please check them to see if there are any php errors showing up at the times you have this problem.

You can verify that this is what's happing by looking at the source of the backend page the next time it happens. Look to see if teh HTML is complete for teh page.

asellon Feb 7, 2010 07:27 AM

Hi Juggledad -- thanks for your reply, but let me repeat some of the information I provided in my first post:
-- I'm editing static pages on WP
-- I do not have any plugins active on this particular site
-- Yes, when I switch back to a default theme, both Visual Editor and Page Revisions are visible again
-- I'm a non-coding newbie

And per my response to Paula's note, it has now happened on additional pages on that installation. So far three pages have freaked out in the same way upon clicking the Update button after a series of edits. I'm afraid to check out another WP site I already built with Atahualpa on another server for someone else, until I know what's going on with this install. Clearly the information is still there on my new site, but Atahualpa is having trouble showing it for some reason. I am able to edit the pages multiple times and all is fine, then for some reason one of the times I click Update, poof!, Visual Editor and Page Revisions become unavailable, and I'm staring at the HTML code on the Visual Editor tab. I'm thinking either the tables, the images in some of the cells, or something like that, may be throwing it off, but I don't know. When I copied the content from the old pages, I deleted the images on the WP pages, then re-added them from my WP Media Gallery.
I apologize that I don't know how to "look at the site's error.log on access.log" but if you can give me a bit more information, I will gladly check it out.
As to the HTML code I'm pasting from the old, non-WP web site, I'm not sure what to look for? As far as I can see the code is complete, or the table wouldn't render properly, etc., yes? What should I be seeking?
I would also be glad to contribute $ to the forum as I plan to use Atahualpa on 3 sites I'm launching this month and next, if I can get this issue cleared up. But it wasn't clear if there was a general Paypal donation box, or if all donations are to go to you? Yours is the only name on the donations list when I look at it.
I appreciate any further help you can provide! I really love Atahualpa and want to stick with it, but the workaround of using a default theme so that I can see Visual Editor and Page Revisions is awkward. I'd rather not have to rebuild these pages if I can humanly help it. Thx!

paulae Feb 7, 2010 07:53 AM

Do you have any iframe code on those pages?

asellon Feb 7, 2010 08:19 AM

Hi Paula -- No, no iFrame code. I originally built these pages on FrontPage2000 years ago, relying mostly again on WYSIWYG view, but in looking at the HTML, I see tr and td codes for the table, that's all. It's been a long time since I've even had to work with HTML so I'm very rusty with it, but nothing unique in the coding is jumping out at me between the pages that have lost the View Editor & Page Revisions vs. those that have not (yet) gone bad. Yet all pages look fine and fully functional in edit mode when I switch back to a default theme. So frustrating!

paulae Feb 7, 2010 09:05 AM

Can you give us the URL so we can take a look at the code?

Have you cleared your browser cache? Which browser are you using?

asellon Feb 7, 2010 09:40 AM

Sure! Thanks so much for your willingness to help, and apologies for my own lack of experience/knowledge with code. The site I'm building is: http://s310666245.onlinehome.us/ and while all the pages display properly, I can tell you that the "All Reviews and Photos" and the "I Am My Own Wife" sub-page are not showing properly in Edit Page mode. The other sub-pages under "All Reviews and Photos" still are, at least at the moment. And the other pages (only one of which has a table, and that with no images) are currently fine in Edit Page mode. I'm using IE8, and yes, I tried clearing the cache a few times yesterday, but no change. My host is 1and1.com. Thanks for making the time to take a look; that's very good of you, and I really appreciate it! :)

juggledad Feb 7, 2010 09:59 AM

please install teh wp-dbmanager plugin (http://wordpress.org/extend/plugins/wp-dbmanager/) and after you activate it, go to the security screen and copy the info on the right hand side of the screen (system Info) and paste it here.

This has to be a environemntal issue, something unique between your host and the psots.

Did you check the error.log at 1and1?

paulae Feb 7, 2010 10:18 AM

Andrew, I'm happy to try to help. Fellow UNC-Chapel Hill grad. :) And fellow New Yorker.

And fellow Wordpress/PHP seeker.

One thing that jumps out at me: why are you using H5 for the body of the text on the Wife page? (I'd love to see that play, by the way!) You should use the theme's options to set the body text to something "normal" and not use a headline tag for long pieces of text. It's too big, too harsh and hard to read. In the other pages under that category, the text is normal. I wonder if this could be screwing up the formatting in the visual editor, to the point where it's screaming, "No! No! Help!"? I have no idea if that would matter at all, but certainly it's not good HTML to do it that way. Of course, I am not a fan of MS FrontPage anyway. If I were you, I'd redo that page completely and strip out any code that came from Front Page.

Just stylistically, I'd suggest not using tables at all for this kind of thing. It would look much nicer if you just did a normal paragraph structure with the images aligned right or left with text wrapping around them, more magazine-style. But that's just me.

What is http://s310666245.onlinehome.us/ ? I see it defaults to 1and1 if you remove the subdomain. I wonder if this is a part of 1and1 that is running Wordpress but isn't fully under your control? s310....is your username, maybe? A temp URL?

asellon Feb 7, 2010 10:52 AM

Hey, Paula! I think you hit on the at least part of solution: the fonts, which came over screwy in the first place when I pasted these pages. I only had that Header 5 code in there as an attempt to get the spacing to lay out better; I just wanted regular Paragraph weight, with occasional bolding, but the fonts were showing up differently even from paragraph to paragraph in edit view, so I was trying other headings to see what effect that would have. I was finally just now able to get all the text on the "I Am My Own Wife" page changed to WP's Paragraph setting, and now that page has shows the View Editor again in Atahualpa--but still not the list of Page Revisions.
Maybe you're right and I should just do those pages over from scratch without tables at all. I agree that FrontPage (MS in general) throws in a lot of crappy code.
I will install the plugin that Juggledad recommends and see what info that may contribute, and I can try to find the error log on 1and1. That URL is the address for my acting site as listed on 1and1, and I apologize that I don't know much beyond that; it's not my user name or password on 1and1. But it's starting to look like I just had too much crappy code from FrontPage days, and doing the pages over may be the best way at this point, since troubleshooting looks like it may take as much time as starting fresh. Again thanks to you and Juggledad for all the help!
PS -- Cool that you went to Chapel Hill, too! What was your subject? (Mine is by now obvious!) And yes, "Wife" is an amazing play. :-) Here's a sneak peek at a WP site I'm building for my non-profit. So far, no issues there! http://www.lcsna.org/wordpress/

paulae Feb 7, 2010 10:59 AM

1975, BA in Journalism. I'm publisher/editor/tekkie for http://larchmontgazette.com, so I've stayed in (or more correctly, come back to) my old major, and combined it with my love of all things Internet and my new-found interest in Wordpress. I was doing HTML way back when, before any WYSIWYG HTML editors existed. Wow, that makes me a dinosaur!

I'm not sure what's going on with the page revisions, why that would be affected by font issues, but I do think starting over within the WP environment is the best choice right now. I keep trying to get our reporters to stop composing in Word and just start afresh right in WP, or at least use the "paste from Word" option in the editor so it'll strip out the "crappy" MS code.

I think your site would look great with a slideshow for some of the images. There are a bunch of good plugins for that. NextGen Gallery is good.

asellon Feb 7, 2010 11:10 AM

I would love to do the slideshow approach for the specific show's pix on each of those sub-pages, but wasn't sure how to do it. I was contemplating NextGen but wasn't sure which gallery plugin was the best for my needs. I'm going to put a rotating set of show-specific images in the Atahualpa header as well.
I'm switching from Cablevision to FIOS tomorrow, so right now my goal is to get a functional version of my new site up by tomorrow night, so that I can disconnect Cablevision and let my old site (on their server) go. Then I will definitely look into NextGen once I launch the Carroll Society's site and have that off my hands (a fellow volunteer is supposed to be working on implementing eShop this weekend on that site; fingers crossed!).
That Larchmont Gazette site is very impressive!! Lots of information. We're in Yonkers, so probably not even that far from you. I'm just getting back into hands-on web site work, and am now in love with both WordPress and Atahualpa. This was the first serious glitch I've encountered, and as you say, I think it's just bad code that came over from the old pages. I just installed that dbmanager plugin, so I'm going to go look for that information Juggledad mentioned. Thx!

asellon Feb 7, 2010 11:19 AM

FYI -- I just installed the dbmanager plugin (which I realize is exactly what we need for the Carroll site as well, so thanks!!), but I don't see a Security option anywhere on my Admin panel. Where would that be?
I do see this warning:

Your backup folder MIGHT be visible to the public. To correct this issue, move the .htaccess file from wp-content/plugins/wp-dbmanager to /homepages/32/d310666225/htdocs/wp-content/backup-db
so I guess I should move that file as directed, and hopefully it won't mess up anything else. :-)

paulae Feb 7, 2010 11:28 AM

We switched to FIOS about a year ago. Much superior to Cablevision! We love it. We use it for the phone, too.

Yes, I guess Yonkers is just about due east from here. So, Westchester, Chapel Hill....and Vermont. My son went to UVM, and we ski in southern Vermont most weekends. Lots of geographical connections.

asellon Feb 7, 2010 11:33 AM

Glad to hear you're happier with FIOS! I'm not looking forward to the lengthy install process tomorrow, but want better service. I loved Chapel Hill (MFA in Acting '93) and my partner and I love Vermont, too! Vermont Stage Company is in downtown Burlington. I've done a lot of shows for them, and hope to do more.
Right now, I'm stripping out all the text from one of my problem pages, and pasting it in as clean text this time. If that doesn't fix things, I'll rebuild the page as you suggested. Many thanks! :-)

asellon Feb 7, 2010 12:17 PM

Question on TinyMCE-Advanced: I installed it, but do not see any table buttons available?? I only see two rows of editing buttons, and the table buttons are not there. When I click the icon that's supposed to show a third row, instead it hides one of the two rows, as it does on the default WP editor. Am I missing something? Sorry!

paulae Feb 7, 2010 12:30 PM

Settings/TinyMCE Advanced: you drag and drop the features you want from the lower box to the upper one. Don't forget to Save. Now you should see the table insertion icon in your editor. The table elements icons will be grayed out until you have a table to work with.

RE: the database plugin

Yes, do move that file. I too don't see anything about security in the plugin; maybe he means the path info that's under Database Options?

juggledad Feb 7, 2010 02:14 PM

oops, I meant wp-security scan (http://wordpress.org/extend/plugins/wp-security-scan/) but wp-dbmanager is good to have bfor auto backups and optimizing

asellon Feb 7, 2010 02:17 PM

Super -- thanks again, Paula! :)

I moved that file, and am now recreating those pages with plain text to avoid possible phantom code issues. It brings back the Visual Editor, but I'm still not seeing the Page Revisions for those two pages when using Atahualpa. I just saw Juggledad's correction, so I'll install the other plugin he mentions and maybe that will lead to a solution that will restore the Page Revisions for those affected pages.

asellon Feb 7, 2010 10:22 PM

Well, I'm really at my wit's end now: I spent hours reworking the "I Am My Own Wife" subpage of content in a brand new WP page, no tables, nothing fancy. Then when I went to add italics around the play title on the first line of the page in Visual Editor, I clicked Update, and both Visual Editor and Page Revisions vanished on this brand new page!!! If I switch to a default Theme, the page shows fine in Page Edit mode again. I brought my text in from Text Pad and left it plain almost everywhere. I really have no idea what to do, but now I'm very concerned about using Atahualpa unless someone cleverer and more experienced than me can get to the bottom of what's happening here. I'm beyond exhausted and exasperated. I really thought both WordPress and Atahualpa were going to make my next web site a bit easier.
Juggledad -- I wasn't sure whether to install that wp-security plugin as it said it has not yet been tested for 2.9.1? If anyone can help, I would be extremely grateful. I've pretty much had it.

juggledad Feb 8, 2010 04:27 AM

Please install it unless you can tell me for certian what version of php you are running. And I will ask once again, have you looked at your sites error log?

asellon Feb 8, 2010 06:30 AM

Hi Juggledad -- Thanks for your reply. I will apologize for the third time, now, but I have said I'm a non-coding newbie and that's exactly what I meant each time. If you ask me what version of PHP I'm running or have I checked the error log on my host server, I may need a bit of "how do I do that?" information. If I'm too much of a beginner for this forum and product, so be it, but everyone has to start somewhere. I see that there is a "logs" folder in my installation, but I don't see anything named in such a way as to tell me it's an error log. I have no idea how to know what version of PHP I'm running because I don't know where to look. On the server somewhere? In WP Admin? I'm not unintelligent, just new to all of this. I appreciate the help Paula and you have tried to supply so far, but if you ask me to do something technical, I just need to know how to do that and I'll very gladly do it.
I should have mentioned in my post late last night that I had trouble with a second new page as well, of a different sort. I followed Paula's advice and installed the tinymce-advanced plugin, and built a new page with a table using that functionality. When I put in just one row of content, the page resized fine when I tested it. Once I finished the page, I found the table and its content no longer resize, so in a smaller browser window, content would just not be visible instead of reshaping itself to the new window size. That's even worse than the other issue with Visual Editor and Page Revisions vanishing in Edit mode, because it affects what people will see.
If you don't mind telling me where to look for an error log, and what to look for in it, and where I'd find my PHP version, I will check those out right away.
Thanks again for your patience with a beginner. I'm here to learn from those who know, and once I've learned, I'll be happy to help others someday in return.

juggledad Feb 8, 2010 06:49 AM

The wp-securityscan has a nice feature, it dumps a bit of information about your sstem including teh version of PHP you are running. This is why I've been asking you to install it and copy and paste the 'system info' found at the top right hand side of the security page.

You need to take one issue at a time and finding out why the WordPress Editor doesn't show the page revision area. As I said previously, my guess is that something is causing a failure in WordPress and it stops generating the page.

The revisions still exist, it's just that an error cause the editor to stumble before getting to the point where it can get to the point of displaying that information.

This is an issue that I've never heard of before, so it is unique to your setup. The trick is to find out what is unique, and that means digging into areas that most people never have to look at.

while I'd love to b able to tell you exactly where to look to find the error log (if there is one), that is a HOST specific item. I do not have my sites server by 1and1. I could tell you where to look at my host company, but it wouldn't help you.

If you wish me to dig into this, send me a PM and I'll quote you my rate for personal service, other than that, my gut is telling me that someone with a bit of technical knowledge needs to poke arround in your system to get to the bottom of this unique issue, and from what you are saying, that person is not you ;)

All times are GMT -6. The time now is 02:28 AM.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.