Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Montezuma Theme (http://forum.bytesforall.com/forumdisplay.php?f=53)
-   -   Menu messing up (http://forum.bytesforall.com/showthread.php?t=21997)

YJR Apr 9, 2014 02:37 PM

Menu messing up
 
1 Attachment(s)
Hi all, I run into a problem with the main menu of montezuma. At a certain page width menu switch to a two row rendering which is fine. But it doesn't seem to adapt it s box resulting in the menu going into the next element as shown in the attachement.

header php for reference:

<div id="banner-bg" class="cf">
<div id="banner" class="row">
<?php wp_nav_menu( array(
'container' => 'nav',
'container_class' => 'menu-wrapper col7',
'container_id' => 'menu1-wrapper',
'menu_id' => 'menu1',
'menu_class' => 'cf menu',
'theme_location' => 'menu1',
'fallback_cb' => 'bfa_page_menu'
) ); ?>

<div id="logo-area" class="col5">
<<?php bfa_if_front_else( 'h1', 'h3' ); ?> id="sitetitle">
<a href="<?php echo home_url(); ?>"><?php bloginfo( 'name' ); ?></a>
</<?php bfa_if_front_else( 'h1', 'h3' ); ?>>
<p id="tagline"><?php bloginfo( 'description' ); ?></p>
</div>


</div>
</div>


<?php
$curdir=getcwd(); chdir(get_template_directory() . "/images/header");
$files=glob("*.{gif,png,jpg,gif}", GLOB_BRACE);
chdir($curdir);
$file=$files[array_rand($files)];
?>

<div id="image" style="width:100%;float:center;" class="row">
<img src="<?php echo "//blabla/wp-content/themes/montezuma/images/header/$file"; ?>"
alt="Logo_SelvaViva_standard"/>

</div>

juggledad Apr 9, 2014 02:49 PM

1) what is the url?
2) is the code from the virtual header.php template?
3) if so some of that code will not work like getcwd() or chdir() since they are not part of the 'Limited PHP Code'

YJR Apr 11, 2014 08:54 AM

HI,
No it's not a virtual header template I created a child template, but the issue is not related it was already happening with a virtual template without the non permitted code.
The site is not yet online, so I'can't get you a public url !
Hope you can still help me !

juggledad Apr 12, 2014 04:40 AM

what do you mean you created a child template? did you create a child theme and put the header.php there or did you code a new header.php and remove the exiisting header.php file from the theme folder?

YJR Apr 12, 2014 10:05 AM

Hi I just create a child directory and add a simple style.css as described in wp user man pages, which basically loads the original style.css. Then I add the modified header.php file there with the code in the first post.
Thanks for tracking my issue !

juggledad Apr 13, 2014 09:52 AM

Termonology is important - you created a child theme.
go to MTO->Export/Import and save your exort to a text file ands attach it to a reply.

your child CSS.style file should look like thous
HTML Code:

/*
Theme Name: Montezuma Child
Theme URI: http://wordpress.bytesforall.com/wordpress-themes/montezuma/
Description: Child Theme for Montezuma
Author: BytesForAll
Author URI: http://wordpress.bytesforall.com/
Template: montezuma
Version: 1.2.2
*/
@import url("../montezuma/style.css");



All times are GMT -6. The time now is 12:04 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.