Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Montezuma Theme (http://forum.bytesforall.com/forumdisplay.php?f=53)
-   -   Applied Montezuma theme. Unable to apply Virtual Template? n00bwarning (http://forum.bytesforall.com/showthread.php?t=21225)

apestate Dec 6, 2013 04:06 AM

Applied Montezuma theme. Unable to apply Virtual Template? n00bwarning
 
Hello

I have applied the Montezuma template to my blog http://apestate.com. I have not modified it in any serious manner yet, just establishing a beach landing here.

My first efforts are toward moving all of the Updates (which were entered during a multi-state bicycle tour) into an archive. My design idea is to put the loop on a pseudo-static page, a child of "My Adventures" which will live in the menu bar. The loop would list posts from the bicycletour2013 category.

Whether or not I actually go that route is beside the point of this question, I just wanted to provide some background.

The problem I'm having is this: When I create or edit a pseudo-static page in wordpress, it gives me the option to select from among Virtual Templates, such as index.php, image, page, single, etc. Instead of a selection taking effect, the setting always reads "Best match based on WP hierarchy."

I would like the change to take effect so I can horse around with templates, would I not?

juggledad Dec 6, 2013 04:48 AM

so when you click on the selection box in the 'Virtual Template' it doesn't drop down with choices?

Try disabling ALL your plugins to see if there is a conflict.

Note: nothing will show in your page, the templates are in the theme options

apestate Dec 6, 2013 08:13 AM

Hi juggledad, thank you for the quick response!

Actually, when I click in the Virtual Templates dropdown, the choices are shown, and I can select a different choice than "Best match based on WP hierarchy." When I click publish, whatever changed I've tried to make in that drop down reverts to "Best match based on WP hierarchy."

My idea is something like: create a copy of index.php called archives.php and change the code in that template file to fire a post loop inside of a page other than "front page".

I am unable to select any templates however. For instance, in Atahualpa theme, I was able to change a "static page" from the default template to JUGGLEDAD multi-column template and that change would TAKE. In Montezuma the template change does not take.

*In addition, I disabled all plugins and checked again. Virtual Templates still sticks to "Best match based on WP hierarchy." instead of updating with the other choices in the drop down, "image, index, page, single".

juggledad Dec 6, 2013 10:00 AM

if you send me a PM with an admin ID/PW I'll take a look. I have no problem and am curious as to what might be happening.

apestate Dec 6, 2013 11:35 AM

Ah yeah, Juggledad, per your PM

Confirmed that the Virtual Template drop-down selection takes effect in Firefox...

Now it works in Chrome as well, which it certainly did not before. :confused:

But thank you, that allows me to fiddle with the theme some more.

apestate Dec 6, 2013 11:45 AM

and I'm immediately proven wrong.

Same problem, both in firefox and chrome now... Virtual Template setting takes no effect.

However, at least the ones that did "take" have stayed set.

At this point I'm trying to change static page Bicycle Tour 2013 to template Archive-94, which is a copy of index.php

I'm unable to change static page Bicycle Tour 2013 to any Virtual Template. Will respawn and try again.

apestate Dec 6, 2013 07:01 PM

I don't really know the answer but I deleted the page in question, then created a new page, and was able to apply the Virtual Template at will.


All times are GMT -6. The time now is 01:52 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.